summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-01 07:23:43 +0100
committerRemi Collet <remi@php.net>2023-12-01 07:23:43 +0100
commitf818d63bb1ee19cb9b7bd54dffcd84d38a108a68 (patch)
treed409581a53e361df532d5d3ed5bf6bc9957cdd21 /php-pecl-xdebug3.spec
parentacd1432d17fce67f5e46ee3ca5128fb8df942ae3 (diff)
update to 3.3.0
Diffstat (limited to 'php-pecl-xdebug3.spec')
-rw-r--r--php-pecl-xdebug3.spec40
1 files changed, 31 insertions, 9 deletions
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index eca64fb..46d5397 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -16,16 +16,22 @@
%bcond_without tests
+%if 0%{?rhel} == 7
+%bcond_with zlib
+%else
+%bcond_without zlib
+%endif
+
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit a03bda14ba866a34e7f90399078c73eadb1ecbfe
+%global gh_commit 15d672e84caa6015d1b2b509aa13a0528d6e9a7e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20201011
# version/release
%global upstream_version 3.3.0
-%global upstream_prever alpha3
-%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
+#global upstream_prever alpha3
+#global upstream_lower %%(echo %%{upstream_prever} | tr '[:upper:]' '[:lower:]')
%global sources src
%global _configure ../%{sources}/configure
@@ -38,15 +44,13 @@ Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
Release: 1.%{gh_date}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: Xdebug-1.03
URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
-Patch0: https://patch-diff.githubusercontent.com/raw/xdebug/xdebug/pull/916.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
@@ -55,6 +59,9 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
BuildRequires: libtool
BuildRequires: %{?scl_prefix}php-soap
+%if %{with zlib}
+BuildRequires: pkgconfig(zlib) >= 1.2.9
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -132,8 +139,6 @@ mv %{sources}/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd %{sources}
-%patch -P0 -p1
-
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
@@ -154,7 +159,6 @@ zend_extension=%{pecl_name}.so
; Configuration
; See https://xdebug.org/docs/all_settings
-
EOF
sed -e '1,2d' %{sources}/%{pecl_name}.ini >>%{ini_name}
@@ -170,6 +174,11 @@ cd %{sources}
cd ../NTS
%configure \
--enable-xdebug \
+%if %{with zlib}
+ --with-xdebug-compression \
+%else
+ --without-xdebug-compression \
+%endif
--with-php-config=%{__phpconfig}
make %{?_smp_mflags}
@@ -177,6 +186,11 @@ make %{?_smp_mflags}
cd ../ZTS
%configure \
--enable-xdebug \
+%if %{with zlib}
+ --with-xdebug-compression \
+%else
+ --without-xdebug-compression \
+%endif
--with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -230,6 +244,7 @@ done
--no-php-ini \
-d extension_dir=%{buildroot}%{php_extdir} \
-c %{buildroot}%{php_inidir}/%{ini_name} -v
+
%{__php} \
--no-php-ini \
-d extension_dir=%{buildroot}%{php_extdir} \
@@ -250,6 +265,10 @@ fi
%if %{with tests}
cd %{sources}
+%if %{without zlib}
+rm tests/profiler/bug02001-no-zlib-compression.phpt
+rm tests/tracing/start_no_zlib_compression.phpt
+%endif
: Upstream test suite NTS extension
# bug00886 is marked as slow as it uses a lot of disk space
@@ -298,6 +317,9 @@ fi
%changelog
+* Fri Dec 1 2023 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+
* Sun Oct 22 2023 Remi Collet <remi@remirepo.net> - 3.3.0~alpha3-2
- fix configuration file using patch from
https://github.com/xdebug/xdebug/pull/916