summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-22 10:07:22 +0200
committerRemi Collet <remi@php.net>2023-10-22 10:07:22 +0200
commit78a5d623631660f9d866c6dd97735c2792f674a9 (patch)
tree8ab3366ee578a0a82bf97767284588193205adfc /php-pecl-xdebug3.spec
parent48baf25c7d097aa80965ccc9107e99a988c79407 (diff)
comments
Diffstat (limited to 'php-pecl-xdebug3.spec')
-rw-r--r--php-pecl-xdebug3.spec5
1 files changed, 3 insertions, 2 deletions
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index 6093546..e1b53fc 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -219,13 +219,13 @@ for mod in simplexml; do
fi
done
-# only check if build extension can be loaded
+: check if NTS build extension can be loaded
%{__php} \
--no-php-ini \
--define zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^Xdebug$'
-# check if provided config file is usable
+: check if provided config file is usable
%{__php} \
--no-php-ini \
-c %{buildroot}%{php_inidir}/%{ini_name} -v 2>err.log \
@@ -236,6 +236,7 @@ if [ -s err.log ]; then
fi
%if %{with_zts}
+: check if ZTS build extension can be loaded
%{__ztsphp} \
--no-php-ini \
--define zend_extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \