summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-07 16:41:16 +0200
committerRemi Collet <remi@remirepo.net>2021-09-07 16:41:16 +0200
commitcf4178762ecd172fb85420709b47b1eb367e9eb1 (patch)
tree7f55b53237ee910c34af245c0fda3ff2ac9130e5
parented4ffd7882954db8937764625b2b7585af73d954 (diff)
update to 3.1.0beta2 (no change)
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION34
-rw-r--r--php-pecl-xdebug3.spec9
3 files changed, 24 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index 1bdf69f..222ff8e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -10,7 +10,7 @@ xdebug
 __/ |
 |___/
-Version => 3.1.0beta1
+Version => 3.1.0beta2
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
Enabled Features (through 'xdebug.mode' setting)
diff --git a/REFLECTION b/REFLECTION
index 851ce55..655395d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
+Extension [ <persistent> extension #15 xdebug version 3.1.0beta2 ] {
- INI {
Entry [ xdebug.mode <SYSTEM> ]
@@ -257,25 +257,25 @@ Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
Function [ <internal:xdebug> function xdebug_call_class ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $depth = 2 ]
+ Parameter #0 [ <optional> int $depth ]
}
}
Function [ <internal:xdebug> function xdebug_call_file ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $depth = 2 ]
+ Parameter #0 [ <optional> int $depth ]
}
}
Function [ <internal:xdebug> function xdebug_call_function ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $depth = 2 ]
+ Parameter #0 [ <optional> int $depth ]
}
}
Function [ <internal:xdebug> function xdebug_call_line ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $depth = 2 ]
+ Parameter #0 [ <optional> int $depth ]
}
}
Function [ <internal:xdebug> function xdebug_code_coverage_started ] {
@@ -316,7 +316,7 @@ Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
Function [ <internal:xdebug> function xdebug_get_collected_errors ] {
- Parameters [1] {
- Parameter #0 [ <optional> bool $emptyList = false ]
+ Parameter #0 [ <optional> bool $emptyList ]
}
- Return [ array ]
}
@@ -380,7 +380,7 @@ Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
Function [ <internal:xdebug> function xdebug_info ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $category = null ]
+ Parameter #0 [ <optional> string $category ]
}
}
Function [ <internal:xdebug> function xdebug_is_debugger_active ] {
@@ -398,7 +398,7 @@ Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
Function [ <internal:xdebug> function xdebug_notify ] {
- Parameters [1] {
- Parameter #0 [ <required> mixed $data ]
+ Parameter #0 [ <required> $data ]
}
- Return [ bool ]
}
@@ -411,8 +411,8 @@ Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
Function [ <internal:xdebug> function xdebug_print_function_stack ] {
- Parameters [2] {
- Parameter #0 [ <optional> string $message = "user triggered" ]
- Parameter #1 [ <optional> int $options = 0 ]
+ Parameter #0 [ <optional> string $message ]
+ Parameter #1 [ <optional> int $options ]
}
}
Function [ <internal:xdebug> function xdebug_set_filter ] {
@@ -426,7 +426,7 @@ Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
Function [ <internal:xdebug> function xdebug_start_code_coverage ] {
- Parameters [1] {
- Parameter #0 [ <optional> int $options = 0 ]
+ Parameter #0 [ <optional> int $options ]
}
}
Function [ <internal:xdebug> function xdebug_start_error_collection ] {
@@ -443,21 +443,21 @@ Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
Function [ <internal:xdebug> function xdebug_start_gcstats ] {
- Parameters [1] {
- Parameter #0 [ <optional> ?string $gcstatsFile = null ]
+ Parameter #0 [ <optional> string or NULL $gcstatsFile ]
}
}
Function [ <internal:xdebug> function xdebug_start_trace ] {
- Parameters [2] {
- Parameter #0 [ <optional> ?string $traceFile = null ]
- Parameter #1 [ <optional> int $options = 0 ]
+ Parameter #0 [ <optional> string or NULL $traceFile ]
+ Parameter #1 [ <optional> int $options ]
}
- - Return [ ?string ]
+ - Return [ string or NULL ]
}
Function [ <internal:xdebug> function xdebug_stop_code_coverage ] {
- Parameters [1] {
- Parameter #0 [ <optional> bool $cleanUp = true ]
+ Parameter #0 [ <optional> bool $cleanUp ]
}
}
Function [ <internal:xdebug> function xdebug_stop_error_collection ] {
@@ -489,7 +489,7 @@ Extension [ <persistent> extension #16 xdebug version 3.1.0beta1 ] {
Function [ <internal:xdebug> function xdebug_var_dump ] {
- Parameters [1] {
- Parameter #0 [ <optional> mixed ...$variable ]
+ Parameter #0 [ <optional> ...$variable ]
}
}
}
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index 8a1386d..e64e1eb 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -21,14 +21,14 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit ab502054a44a594774c63e9037f1802cb861c224
+%global gh_commit 7b526d8571336ca9c14701f72fac151d314a76c8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20201011
# version/release
%global upstream_version 3.1.0
-%global upstream_prever beta1
-%global upstream_lower beta1
+%global upstream_prever beta2
+%global upstream_lower beta2
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -295,6 +295,9 @@ fi
%changelog
+* Tue Sep 7 2021 Remi Collet <remi@remirepo.net> - 3.1.0~beta2-1
+- update to 3.1.0beta2 (no change)
+
* Mon Sep 6 2021 Remi Collet <remi@remirepo.net> - 3.1.0~beta1-1
- update to 3.1.0beta1