summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-10-22 09:12:16 +0200
committerRemi Collet <remi@php.net>2023-10-22 09:12:16 +0200
commitbe08e6691b7b5b6e529e1e2af99757c8c4762655 (patch)
treeacd13a6e79858683cec575dacb8f42b2691b65d9
parentd1164db7fdb15b514aa41d57277b1d88260deac0 (diff)
fix configuration file using patch from
https://github.com/xdebug/xdebug/pull/916
-rw-r--r--916.patch23
-rw-r--r--php-pecl-xdebug3.spec16
2 files changed, 36 insertions, 3 deletions
diff --git a/916.patch b/916.patch
new file mode 100644
index 0000000..ef61153
--- /dev/null
+++ b/916.patch
@@ -0,0 +1,23 @@
+From d9a61214ca40418dba961858029dc00e79977056 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Sun, 22 Oct 2023 08:55:38 +0200
+Subject: [PATCH] Update xdebug.ini
+
+---
+ xdebug.ini | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/xdebug.ini b/xdebug.ini
+index c983bef23..9d091b4c7 100644
+--- a/xdebug.ini
++++ b/xdebug.ini
+@@ -1,9 +1,5 @@
+ ; This file is generated by the 'xdebug.org:html/docs/convert.php' robot
+-<<<<<<< Updated upstream
+-; for Xdebug 3.3.0alpha2 — do not modify by hand
+-=======
+ ; for Xdebug 3.3.0alpha3 — do not modify by hand
+->>>>>>> Stashed changes
+
+ ; -----------------------------------------------------------------------------
+ ; xdebug.cli_color
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index 9b5eb63..06730c8 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -38,13 +38,15 @@ Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
Release: 1.%{gh_date}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: Xdebug-1.03
URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
+Patch0: https://patch-diff.githubusercontent.com/raw/xdebug/xdebug/pull/916.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
@@ -130,6 +132,8 @@ mv %{sources}/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd %{sources}
+%patch -P0 -p1
+
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
@@ -144,7 +148,7 @@ mkdir NTS
mkdir ZTS
%endif
-cat << 'EOF' | tee %{ini_name}
+cat << 'EOF' > %{ini_name}
; Enable xdebug extension module
zend_extension=%{pecl_name}.so
@@ -152,7 +156,9 @@ zend_extension=%{pecl_name}.so
; See https://xdebug.org/docs/all_settings
EOF
-sed -e '1d' %{sources}/%{pecl_name}.ini >>%{ini_name}
+sed -e '1,2d' %{sources}/%{pecl_name}.ini >>%{ini_name}
+
+head -n15 <%{ini_name}
%build
@@ -276,6 +282,10 @@ fi
%changelog
+* Sun Oct 22 2023 Remi Collet <remi@remirepo.net> - 3.3.0~alpha3-2
+- fix configuration file using patch from
+ https://github.com/xdebug/xdebug/pull/916
+
* Fri Oct 20 2023 Remi Collet <remi@remirepo.net> - 3.3.0~alpha3-1
- update to 3.3.0alpha3