summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-06 13:19:00 +0200
committerRemi Collet <remi@php.net>2023-09-06 13:19:00 +0200
commit8ef8187e5de253c058854fd28d2275e86be37300 (patch)
tree2b6fb05d21107d3b1f5d090c2ff1bda89f0123bb
parent003954ef69a1836886570908b6477a4f7f2589ed (diff)
update to 3.3.0alpha1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION5
-rw-r--r--php-pecl-xdebug3.spec29
3 files changed, 18 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 5197bfa..4732613 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -10,7 +10,7 @@ xdebug
 __/ |
 |___/
-Version => 3.2.2
+Version => 3.3.0alpha1
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
Enabled Features (through 'xdebug.mode' setting)
diff --git a/REFLECTION b/REFLECTION
index 2d6a080..1a7fdd1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #16 xdebug version 3.2.2 ] {
+Extension [ <persistent> extension #16 xdebug version 3.3.0alpha1 ] {
- INI {
Entry [ xdebug.mode <SYSTEM> ]
@@ -327,7 +327,8 @@ Extension [ <persistent> extension #16 xdebug version 3.2.2 ] {
}
Function [ <internal:xdebug> function xdebug_get_function_stack ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> array $options = [] ]
}
- Return [ array ]
}
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index ede77a8..f3ce70b 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -12,23 +12,20 @@
# Please, preserve the changelog entries
#
-%bcond_without tests
-
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-pecl-xdebug3}
-%{?scl: %scl_package php-pecl-xdebug}
+%bcond_without tests
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit a909eb088ad9fd8c8e09fcc71d892fa54b957b31
+%global gh_commit d2557211b4fb2898bcd238bef24e18f9cc5f3445
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20201011
# version/release
-%global upstream_version 3.2.2
-#global upstream_prever RC2
-#global upstream_lower %%(echo %%{upstream_prever} | tr '[:upper:]' '[:lower:]')
+%global upstream_version 3.3.0
+%global upstream_prever alpha1
+%global upstream_lower %(echo %%{upstream_prever} | tr '[:upper:]' '[:lower:]')
%global sources src
%global _configure ../%{sources}/configure
@@ -51,7 +48,7 @@ Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
-BuildRequires: %{?scl_prefix}php-devel < 8.3
+BuildRequires: %{?scl_prefix}php-devel < 8.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
BuildRequires: libtool
@@ -217,13 +214,13 @@ for mod in simplexml; do
done
# only check if build extension can be loaded
-%{_bindir}/php \
+%{__php} \
--no-php-ini \
--define zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep Xdebug
%if %{with_zts}
-%{_bindir}/zts-php \
+%{__ztsphp} \
--no-php-ini \
--define zend_extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep Xdebug
@@ -231,12 +228,11 @@ done
%if %{with tests}
cd %{sources}
-: Upstream test suite NTS extension
+: Upstream test suite NTS extension
# bug00886 is marked as slow as it uses a lot of disk space
TEST_OPTS="-q -x --show-diff"
-
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-xdebug-tests.php $TEST_OPTS
@@ -280,6 +276,9 @@ fi
%changelog
+* Wed Sep 6 2023 Remi Collet <remi@remirepo.net> - 3.3.0~alpha1-1
+- update to 3.3.0alpha1
+
* Sun Jul 16 2023 Remi Collet <remi@remirepo.net> - 3.2.2-1
- update to 3.2.2
- build out of sources tree