summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-13 11:57:28 +0200
committerRemi Collet <remi@remirepo.net>2020-10-13 11:57:28 +0200
commit87c613ae6739531f84f253cbc9365f82c11e4108 (patch)
tree4e08bdef6ce0971f42f6522290f93be8d4c8f397
duplicate v2
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO74
-rw-r--r--REFLECTION451
4 files changed, 538 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..facb1ef
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,74 @@
+
+xdebug
+
+xdebug support => enabled
+Version => 2.9.8
+Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
+
+Debugger => enabled
+IDE Key => remi
+
+Directive => Local Value => Master Value
+xdebug.coverage_enable => On => On
+xdebug.collect_includes => On => On
+xdebug.collect_params => 0 => 0
+xdebug.collect_return => Off => Off
+xdebug.collect_vars => Off => Off
+xdebug.collect_assignments => Off => Off
+xdebug.default_enable => On => On
+xdebug.file_link_format => no value => no value
+xdebug.filename_format => no value => no value
+xdebug.force_display_errors => Off => Off
+xdebug.force_error_reporting => 0 => 0
+xdebug.halt_level => 0 => 0
+xdebug.max_nesting_level => 256 => 256
+xdebug.max_stack_frames => -1 => -1
+xdebug.overload_var_dump => 2 => 2
+xdebug.show_error_trace => Off => Off
+xdebug.show_exception_trace => Off => Off
+xdebug.show_local_vars => Off => Off
+xdebug.show_mem_delta => Off => Off
+xdebug.dump.COOKIE => no value => no value
+xdebug.dump.ENV => no value => no value
+xdebug.dump.FILES => no value => no value
+xdebug.dump.GET => no value => no value
+xdebug.dump.POST => no value => no value
+xdebug.dump.REQUEST => no value => no value
+xdebug.dump.SERVER => no value => no value
+xdebug.dump.SESSION => no value => no value
+xdebug.dump_globals => On => On
+xdebug.dump_once => On => On
+xdebug.dump_undefined => Off => Off
+xdebug.profiler_enable => Off => Off
+xdebug.profiler_output_dir => /tmp => /tmp
+xdebug.profiler_output_name => cachegrind.out.%p => cachegrind.out.%p
+xdebug.profiler_enable_trigger => Off => Off
+xdebug.profiler_enable_trigger_value => no value => no value
+xdebug.profiler_append => Off => Off
+xdebug.remote_enable => Off => Off
+xdebug.remote_host => localhost => localhost
+xdebug.remote_mode => req => req
+xdebug.remote_port => 9000 => 9000
+xdebug.remote_autostart => Off => Off
+xdebug.remote_connect_back => Off => Off
+xdebug.remote_log => no value => no value
+xdebug.remote_log_level => 7 => 7
+xdebug.idekey => no value => no value
+xdebug.remote_cookie_expire_time => 3600 => 3600
+xdebug.remote_addr_header => no value => no value
+xdebug.remote_timeout => 200 => 200
+xdebug.var_display_max_children => 128 => 128
+xdebug.var_display_max_data => 512 => 512
+xdebug.var_display_max_depth => 3 => 3
+xdebug.cli_color => 0 => 0
+xdebug.scream => Off => Off
+xdebug.gc_stats_enable => Off => Off
+xdebug.gc_stats_output_dir => /tmp => /tmp
+xdebug.gc_stats_output_name => gcstats.%p => gcstats.%p
+xdebug.auto_trace => Off => Off
+xdebug.trace_enable_trigger => Off => Off
+xdebug.trace_enable_trigger_value => no value => no value
+xdebug.trace_output_dir => /tmp => /tmp
+xdebug.trace_output_name => trace.%c => trace.%c
+xdebug.trace_format => 0 => 0
+xdebug.trace_options => 0 => 0
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..54a00b8
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,451 @@
+Extension [ <persistent> extension #117 xdebug version 2.9.8 ] {
+
+ - INI {
+ Entry [ xdebug.coverage_enable <SYSTEM> ]
+ Current = '1'
+ }
+ Entry [ xdebug.collect_includes <ALL> ]
+ Current = '1'
+ }
+ Entry [ xdebug.collect_params <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.collect_return <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.collect_vars <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.collect_assignments <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.default_enable <ALL> ]
+ Current = '1'
+ }
+ Entry [ xdebug.file_link_format <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.filename_format <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.force_display_errors <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.force_error_reporting <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.halt_level <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.max_nesting_level <ALL> ]
+ Current = '256'
+ }
+ Entry [ xdebug.max_stack_frames <ALL> ]
+ Current = '-1'
+ }
+ Entry [ xdebug.overload_var_dump <ALL> ]
+ Current = '2'
+ }
+ Entry [ xdebug.show_error_trace <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.show_exception_trace <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.show_local_vars <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.show_mem_delta <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.dump.COOKIE <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.dump.ENV <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.dump.FILES <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.dump.GET <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.dump.POST <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.dump.REQUEST <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.dump.SERVER <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.dump.SESSION <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.dump_globals <ALL> ]
+ Current = '1'
+ }
+ Entry [ xdebug.dump_once <ALL> ]
+ Current = '1'
+ }
+ Entry [ xdebug.dump_undefined <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.profiler_enable <PERDIR,SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.profiler_output_dir <PERDIR,SYSTEM> ]
+ Current = '/tmp'
+ }
+ Entry [ xdebug.profiler_output_name <PERDIR,SYSTEM> ]
+ Current = 'cachegrind.out.%p'
+ }
+ Entry [ xdebug.profiler_enable_trigger <PERDIR,SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.profiler_enable_trigger_value <PERDIR,SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.profiler_append <PERDIR,SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.remote_enable <PERDIR,SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.remote_host <ALL> ]
+ Current = 'localhost'
+ }
+ Entry [ xdebug.remote_mode <ALL> ]
+ Current = 'req'
+ }
+ Entry [ xdebug.remote_port <ALL> ]
+ Current = '9000'
+ }
+ Entry [ xdebug.remote_autostart <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.remote_connect_back <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.remote_log <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.remote_log_level <ALL> ]
+ Current = '7'
+ }
+ Entry [ xdebug.idekey <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.remote_cookie_expire_time <ALL> ]
+ Current = '3600'
+ }
+ Entry [ xdebug.remote_addr_header <ALL> ]
+ Current = ''
+ }
+ Entry [ xdebug.remote_timeout <ALL> ]
+ Current = '200'
+ }
+ Entry [ xdebug.var_display_max_children <ALL> ]
+ Current = '128'
+ }
+ Entry [ xdebug.var_display_max_data <ALL> ]
+ Current = '512'
+ }
+ Entry [ xdebug.var_display_max_depth <ALL> ]
+ Current = '3'
+ }
+ Entry [ xdebug.cli_color <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.scream <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.gc_stats_enable <PERDIR,SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.gc_stats_output_dir <PERDIR,SYSTEM> ]
+ Current = '/tmp'
+ }
+ Entry [ xdebug.gc_stats_output_name <PERDIR,SYSTEM> ]
+ Current = 'gcstats.%p'
+ }
+ Entry [ xdebug.auto_trace <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.trace_enable_trigger <PERDIR,SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ xdebug.trace_enable_trigger_value <PERDIR,SYSTEM> ]
+ Current = ''
+ }
+ Entry [ xdebug.trace_output_dir <ALL> ]
+ Current = '/tmp'
+ }
+ Entry [ xdebug.trace_output_name <ALL> ]
+ Current = 'trace.%c'
+ }
+ Entry [ xdebug.trace_format <ALL> ]
+ Current = '0'
+ }
+ Entry [ xdebug.trace_options <ALL> ]
+ Current = '0'
+ }
+ }
+
+ - Constants [15] {
+ Constant [ int XDEBUG_STACK_NO_DESC ] { 1 }
+ Constant [ int XDEBUG_TRACE_APPEND ] { 1 }
+ Constant [ int XDEBUG_TRACE_COMPUTERIZED ] { 2 }
+ Constant [ int XDEBUG_TRACE_HTML ] { 4 }
+ Constant [ int XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
+ Constant [ int XDEBUG_CC_UNUSED ] { 1 }
+ Constant [ int XDEBUG_CC_DEAD_CODE ] { 2 }
+ Constant [ int XDEBUG_CC_BRANCH_CHECK ] { 4 }
+ Constant [ int XDEBUG_FILTER_TRACING ] { 256 }
+ Constant [ int XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
+ Constant [ int XDEBUG_FILTER_NONE ] { 0 }
+ Constant [ int XDEBUG_PATH_WHITELIST ] { 1 }
+ Constant [ int XDEBUG_PATH_BLACKLIST ] { 2 }
+ Constant [ int XDEBUG_NAMESPACE_WHITELIST ] { 17 }
+ Constant [ int XDEBUG_NAMESPACE_BLACKLIST ] { 18 }
+ }
+
+ - Functions {
+ Function [ <internal:xdebug> function xdebug_get_stack_depth ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_function_stack ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_formatted_function_stack ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_print_function_stack ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $options ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_declared_vars ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_call_class ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $depth ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_call_function ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $depth ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_call_file ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $depth ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_call_line ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $depth ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_var_dump ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $var ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_debug_zval ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $var ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_debug_zval_stdout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $var ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_enable ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_disable ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_is_enabled ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_is_debugger_active ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_break ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_start_trace ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $fname ]
+ Parameter #1 [ <optional> $options ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_stop_trace ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_tracefile_name ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_profiler_filename ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_start_gcstats ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $fname ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_stop_gcstats ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_gcstats_filename ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_gc_run_count ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_gc_total_collected_roots ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_memory_usage ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_peak_memory_usage ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_time_index ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_start_error_collection ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_stop_error_collection ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_collected_errors ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $clear ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_start_function_monitor ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $functions_to_monitor ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_stop_function_monitor ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_monitored_functions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $clear ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_start_code_coverage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $options ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_stop_code_coverage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $cleanup ]
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_code_coverage ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_code_coverage_started ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_function_count ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_dump_superglobals ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_get_headers ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xdebug> function xdebug_set_filter ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $filter_group ]
+ Parameter #1 [ <required> $filter_type ]
+ Parameter #2 [ <required> $array_of_filters ]
+ }
+ }
+ }
+}
+