summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-21 09:50:48 +0200
committerRemi Collet <remi@php.net>2022-07-21 09:50:48 +0200
commit1ed5613ef03b3830c7b439bd3bcaa8411564858d (patch)
tree1e9a45029d84f13a4d6893f1d76983dd733580ef
parente0267a43520e8fb08e7b0cdb45d704dc8dcf0ec8 (diff)
update to 3.2.0alpha1
raise dependency on PHP 8.0
-rw-r--r--PHPINFO7
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-xdebug3.spec24
3 files changed, 19 insertions, 16 deletions
diff --git a/PHPINFO b/PHPINFO
index c792192..33e4047 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -10,7 +10,7 @@ xdebug
 __/ |
 |___/
-Version => 3.1.5
+Version => 3.2.0alpha1
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
Enabled Features (through 'xdebug.mode' setting)
@@ -25,6 +25,9 @@ Tracing => ✘ disabled
Optional Features
Compressed File Support => yes (gzip)
Clock Source => clock_gettime
+'xdebug://gateway' pseudo-host support => yes
+'xdebug://nameserver' pseudo-host support => yes
+Systemd Private Temp Directory => not enabled
Directive => Local Value => Master Value
xdebug.mode => develop => develop
@@ -66,7 +69,7 @@ xdebug.cloud_id => no value => no value
xdebug.client_host => localhost => localhost
xdebug.client_port => 9003 => 9003
xdebug.discover_client_host => Off => Off
-xdebug.client_discovery_header => no value => no value
+xdebug.client_discovery_header => HTTP_X_FORWARDED_FOR,REMOTE_ADDR => HTTP_X_FORWARDED_FOR,REMOTE_ADDR
xdebug.idekey => no value => no value
xdebug.connect_timeout_ms => 200 => 200
xdebug.scream => Off => Off
diff --git a/REFLECTION b/REFLECTION
index a12ff25..d5a02eb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #16 xdebug version 3.1.5 ] {
+Extension [ <persistent> extension #16 xdebug version 3.2.0alpha1 ] {
- INI {
Entry [ xdebug.mode <SYSTEM> ]
@@ -119,7 +119,7 @@ Extension [ <persistent> extension #16 xdebug version 3.1.5 ] {
Current = '0'
}
Entry [ xdebug.client_discovery_header <ALL> ]
- Current = ''
+ Current = 'HTTP_X_FORWARDED_FOR,REMOTE_ADDR'
}
Entry [ xdebug.idekey <ALL> ]
Current = ''
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index 069109a..dceea97 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -21,14 +21,14 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 9f4bbc4a299e2c34033b01e9cc8e6b78d927a5bd
+%global gh_commit 7af0a499277ccdd07ee10176cd0158a06847ed77
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20201011
# version/release
-%global upstream_version 3.1.5
-#global upstream_prever beta2
-#global upstream_lower beta2
+%global upstream_version 3.2.0
+%global upstream_prever alpha1
+%global upstream_lower %(echo %{upstream_prever} | tr '[:upper:]' '[:lower:]')
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -50,7 +50,7 @@ Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.2
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
BuildRequires: libtool
@@ -65,24 +65,20 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug) = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug)%{?_isa} = %{version}
-%if 0%{?fedora} >= 35 || 0%{?rhel} >= 9 || "%{php_version}" > "8.0"
Obsoletes: %{?scl_prefix}php-pecl-%{pecl_name} < 3
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%else
-# A single version can be installed
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 3
-%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
# older versions are obsoleted by php-pecl-xdebug v2
-%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "8.1"
Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.2"
+Obsoletes: php82-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -273,6 +269,10 @@ fi
%changelog
+* Thu Jul 21 2022 Remi Collet <remi@remirepo.net> - 3.2.0~alpha1-1
+- update to 3.2.0alpha1
+- raise dependency on PHP 8.0
+
* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 3.1.5-1
- update to 3.1.5