summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-02-18 14:12:46 +0100
committerRemi Collet <remi@php.net>2025-02-18 14:12:46 +0100
commit1c91a0ed4d05f5b329e7523df0fed2bab24d2d3f (patch)
tree1545f79729040fafbd9d723d3d2e35744fc19544
parent732fc60da59f09721fd5e728fddfe42e559184df (diff)
fix xdebug_develop_minit function prototypev3.1
-rw-r--r--php-pecl-xdebug3.spec14
-rw-r--r--xdebug-proto.patch12
2 files changed, 22 insertions, 4 deletions
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index d1e6bff..30b3bdd 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-xdebug3
#
-# Copyright (c) 2010-2024 Remi Collet
+# Copyright (c) 2010-2025 Remi Collet
# Copyright (c) 2006-2009 Christopher Stone
#
# License: MIT
@@ -39,7 +39,7 @@ Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
Release: 1.%{gh_date}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -48,10 +48,11 @@ License: BSD
URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
+Patch0: xdebug-proto.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.2
-BuildRequires: %{?scl_prefix}php-devel < 8.2
+BuildRequires: (%{?scl_prefix}php-devel >= 7.2 with %{?scl_prefix}php-devel < 8.2)
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
BuildRequires: libtool
@@ -118,6 +119,8 @@ mv NTS/package.xml .
sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd NTS
+%patch -P0 -p1 -b .proto
+
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{upstream_version}%{?upstream_prever}%{?gh_date:-dev}"; then
@@ -246,6 +249,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Feb 18 2025 Remi Collet <remi@remirepo.net> - 3.1.6-3
+- fix xdebug_develop_minit function prototype
+
* Tue Aug 27 2024 Remi Collet <remi@remirepo.net> - 3.1.6-2
- cleanup
diff --git a/xdebug-proto.patch b/xdebug-proto.patch
new file mode 100644
index 0000000..7ace145
--- /dev/null
+++ b/xdebug-proto.patch
@@ -0,0 +1,12 @@
+diff -up ./src/develop/develop.h.old ./src/develop/develop.h
+--- ./src/develop/develop.h.old 2025-02-18 14:06:12.274999069 +0100
++++ ./src/develop/develop.h 2025-02-18 14:06:34.955866802 +0100
+@@ -67,7 +67,7 @@ typedef struct _xdebug_develop_settings_
+ void xdebug_init_develop_globals(xdebug_develop_globals_t *xg);
+ void xdebug_deinit_develop_globals(xdebug_develop_globals_t *xg);
+
+-void xdebug_develop_minit();
++void xdebug_develop_minit(INIT_FUNC_ARGS);
+ void xdebug_develop_mshutdown();
+ void xdebug_develop_rinit();
+ void xdebug_develop_post_deactivate();