summaryrefslogtreecommitdiffstats
path: root/php-pecl-xdebug.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-xdebug.spec')
-rw-r--r--php-pecl-xdebug.spec24
1 files changed, 19 insertions, 5 deletions
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 584633b..b7aef95 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,12 +19,12 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 4981b8329b1fc1b84fb680d9f70737b860cbdcc1
+%global gh_commit a264af33ac6cea474bd155d3c2d346f6d9dc88ac
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20171202
%global with_tests 0%{!?_without_tests:1}
%global upstream_version 2.7.0
-%global upstream_prever alpha1
+%global upstream_prever beta1
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -35,16 +35,16 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
# (Based on "The PHP License", version 3.0)
License: BSD
-URL: http://xdebug.org/
+URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
-Patch0: 0001-skip-test-if-localhost-doesn-t-resolve-as-IPv6.patch
+Patch0: 0001-zif_handler-exists-in-7.2.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
@@ -85,6 +85,10 @@ Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.3"
+Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -112,6 +116,8 @@ Xdebug also provides:
* code coverage analysis
* capabilities to debug your scripts interactively with a debug client
+Documentation: https://xdebug.org/docs/
+
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -154,6 +160,9 @@ cat << 'EOF' | tee %{ini_name}
; Enable xdebug extension module
zend_extension=%{pecl_name}.so
+; Configuration
+; See https://xdebug.org/docs/all_settings
+
EOF
sed -e '1d' NTS/%{pecl_name}.ini >>%{ini_name}
@@ -291,6 +300,11 @@ fi
%changelog
+* Fri Sep 21 2018 Remi Collet <remi@remirepo.net> - 2.7.0~beta1-1
+- update to 2.7.0beta1
+- add link to documentation in description and configuration file
+- open https://github.com/xdebug/xdebug/pull/431 zif_handler in 7.2
+
* Tue Apr 3 2018 Remi Collet <remi@remirepo.net> - 2.7.0~alpha1-2
- test build for https://github.com/xdebug/xdebug/pull/419