summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--359.patch26
-rw-r--r--php-pecl-xdebug.spec11
2 files changed, 35 insertions, 2 deletions
diff --git a/359.patch b/359.patch
new file mode 100644
index 0000000..fe48fd3
--- /dev/null
+++ b/359.patch
@@ -0,0 +1,26 @@
+From 1a7c4d9b50575e2738984bcaea1684d12535078d Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 5 Jul 2017 06:17:17 +0200
+Subject: [PATCH] Used EG(active) instead of Removed EG(valid_symbol_table) -
+ 7.2.0alpha3
+
+---
+ xdebug_stack.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/xdebug_stack.c b/xdebug_stack.c
+index 0e5b34ad..15bf5e82 100644
+--- a/xdebug_stack.c
++++ b/xdebug_stack.c
+@@ -800,7 +800,11 @@ void xdebug_error_cb(int type, const char *error_filename, const uint error_line
+ break;
+ }
+
++#if PHP_VERSION_ID >= 70200
++ if (PG(track_errors) && EG(active)) {
++#else
+ if (PG(track_errors) && EG(valid_symbol_table)) {
++#endif
+ zval tmp;
+ ZVAL_STRINGL(&tmp, buffer, buffer_len);
+
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 7a63496..efc0d1f 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -29,7 +29,7 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.6.0
%if 0%{?gh_date:1}
-Release: 0.2.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.3.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -41,6 +41,8 @@ Group: Development/Languages
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
+Patch0: 359.patch
+
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libedit-devel
@@ -127,6 +129,7 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1 -b .pr359
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
@@ -285,7 +288,11 @@ fi
%changelog
-* Wed Jun 21 2017 Remi Collet <remi@fedoraproject.org> - 2.6.0-0.2.20170601.d82879d
+* Wed Jun 21 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.3.20170601.d82879d
+- add patch for 7.2.0alpha3 from
+ https://github.com/xdebug/xdebug/pull/359
+
+* Wed Jun 21 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.2.20170601.d82879d
- rebuild for 7.2.0alpha2
* Thu Jun 15 2017 Remi Collet <remi@remirepo.net> - 2.6.0-0.1.20170601.d82879d