summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION2
-rw-r--r--d9c0704548d2db0052ea8a97c53855b977c8a481.patch24
-rw-r--r--php-pecl-xdebug.spec13
3 files changed, 7 insertions, 32 deletions
diff --git a/REFLECTION b/REFLECTION
index 78b2c12..84d3ab1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #191 xdebug version 2.6.0RC2 ] {
+Extension [ <persistent> extension #192 xdebug version 2.6.0 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
diff --git a/d9c0704548d2db0052ea8a97c53855b977c8a481.patch b/d9c0704548d2db0052ea8a97c53855b977c8a481.patch
deleted file mode 100644
index 97687d5..0000000
--- a/d9c0704548d2db0052ea8a97c53855b977c8a481.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From d9c0704548d2db0052ea8a97c53855b977c8a481 Mon Sep 17 00:00:00 2001
-From: Derick Rethans <github@derickrethans.nl>
-Date: Sat, 27 Jan 2018 13:45:21 +0000
-Subject: [PATCH] Fixed issue #1522: Remote debugging test failures on s390
- (Big Endian)
-
----
- xdebug_handler_dbgp.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/xdebug_handler_dbgp.c b/xdebug_handler_dbgp.c
-index e7f945e0..2daac9cc 100644
---- a/xdebug_handler_dbgp.c
-+++ b/xdebug_handler_dbgp.c
-@@ -2034,7 +2034,8 @@ static int xdebug_dbgp_parse_cmd(char *line, char **cmd, xdebug_dbgp_arg **ret_a
- int len = ptr - value_begin;
-
- args->value[opt_index] = xdebug_str_create(value_begin, len);
-- xdebug_stripcslashes(args->value[opt_index]->d, (int*) &(args->value[opt_index]->l));
-+ xdebug_stripcslashes(args->value[opt_index]->d, &len);
-+ args->value[opt_index]->l = len;
-
- state = STATE_SKIP_CHAR;
- } else {
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index b6c27d5..f5ae622 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,11 +19,11 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit e53e2073568dc26a74b73479bff4e3fd88fe3ab2
+%global gh_commit 61690fbc6e7991f12c6a36bc72db9e0a145406e0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20171202
%global with_tests 0%{!?_without_tests:1}
-%global prever RC2
+#global prever RC2
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -37,7 +37,7 @@ Release: 0.12.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo "
%if 0%{?gh_date:1}
Release: 0.8.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
%endif
@@ -48,8 +48,6 @@ Group: Development/Languages
URL: http://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
-Patch0: https://github.com/xdebug/xdebug/commit/d9c0704548d2db0052ea8a97c53855b977c8a481.patch
-
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
@@ -137,8 +135,6 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .upstream
-
# Check extension version
ver=$(sed -n '/XDEBUG_VERSION/{s/.* "//;s/".*$//;p}' php_xdebug.h)
if test "$ver" != "%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -293,6 +289,9 @@ fi
%changelog
+* Tue Jan 30 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0 (stable)
+
* Mon Jan 29 2018 Remi Collet <remi@remirepo.net> - 2.6.0-0.12.RC2
- Add upstream patch for bigendian