summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION32
-rw-r--r--php-pecl-xdebug.spec16
3 files changed, 28 insertions, 22 deletions
diff --git a/PHPINFO b/PHPINFO
index f4c4bfb..fe79b48 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xdebug
xdebug support => enabled
-Version => 2.8.0beta1
+Version => 2.8.0beta2
IDE Key => remi
Support Xdebug on Patreon: https://www.patreon.com/bePatron?u=7864328
diff --git a/REFLECTION b/REFLECTION
index 0dff417..7b5dd40 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #195 xdebug version 2.8.0beta1 ] {
+Extension [ <persistent> extension #201 xdebug version 2.8.0beta2 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -199,21 +199,21 @@ Extension [ <persistent> extension #195 xdebug version 2.8.0beta1 ] {
}
- Constants [15] {
- Constant [ int XDEBUG_TRACE_APPEND ] { 1 }
- Constant [ int XDEBUG_TRACE_COMPUTERIZED ] { 2 }
- Constant [ int XDEBUG_TRACE_HTML ] { 4 }
- Constant [ int XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
- Constant [ int XDEBUG_CC_UNUSED ] { 1 }
- Constant [ int XDEBUG_CC_DEAD_CODE ] { 2 }
- Constant [ int XDEBUG_CC_BRANCH_CHECK ] { 4 }
- Constant [ int XDEBUG_STACK_NO_DESC ] { 1 }
- Constant [ int XDEBUG_FILTER_TRACING ] { 256 }
- Constant [ int XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
- Constant [ int XDEBUG_FILTER_NONE ] { 0 }
- Constant [ int XDEBUG_PATH_WHITELIST ] { 1 }
- Constant [ int XDEBUG_PATH_BLACKLIST ] { 2 }
- Constant [ int XDEBUG_NAMESPACE_WHITELIST ] { 17 }
- Constant [ int XDEBUG_NAMESPACE_BLACKLIST ] { 18 }
+ Constant [ integer XDEBUG_TRACE_APPEND ] { 1 }
+ Constant [ integer XDEBUG_TRACE_COMPUTERIZED ] { 2 }
+ Constant [ integer XDEBUG_TRACE_HTML ] { 4 }
+ Constant [ integer XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
+ Constant [ integer XDEBUG_CC_UNUSED ] { 1 }
+ Constant [ integer XDEBUG_CC_DEAD_CODE ] { 2 }
+ Constant [ integer XDEBUG_CC_BRANCH_CHECK ] { 4 }
+ Constant [ integer XDEBUG_STACK_NO_DESC ] { 1 }
+ Constant [ integer XDEBUG_FILTER_TRACING ] { 256 }
+ Constant [ integer XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
+ Constant [ integer XDEBUG_FILTER_NONE ] { 0 }
+ Constant [ integer XDEBUG_PATH_WHITELIST ] { 1 }
+ Constant [ integer XDEBUG_PATH_BLACKLIST ] { 2 }
+ Constant [ integer XDEBUG_NAMESPACE_WHITELIST ] { 17 }
+ Constant [ integer XDEBUG_NAMESPACE_BLACKLIST ] { 18 }
}
- Functions {
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index e34eea2..ff3a49a 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,13 +19,13 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit e10085a60463ba2bfb74fd640abceda8d7d125d7
+%global gh_commit f1bde951b797bd6669a5ba677d98214b5c3ac315
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20190614
%global with_tests 0%{!?_without_tests:1}
%global upstream_version 2.8.0
-%global upstream_prever beta1
-%global upstream_lower beta1
+%global upstream_prever beta2
+%global upstream_lower beta2
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -34,9 +34,9 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
-Release: 1.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
# The Xdebug License, version 1.01
@@ -301,6 +301,12 @@ fi
%changelog
+* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 2.8.0~beta2-2
+- rebuild for 7.4.0RC1
+
+* Tue Aug 27 2019 Remi Collet <remi@remirepo.net> - 2.8.0~beta2-1
+- update to 2.8.0beta2
+
* Fri Jul 26 2019 Remi Collet <remi@remirepo.net> - 2.8.0~beta1-1
- update to 2.8.0beta1