summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xdebug.spec16
3 files changed, 10 insertions, 10 deletions
diff --git a/PHPINFO b/PHPINFO
index b59d829..f4c4bfb 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xdebug
xdebug support => enabled
-Version => 2.8.0alpha1
+Version => 2.8.0beta1
IDE Key => remi
Support Xdebug on Patreon: https://www.patreon.com/bePatron?u=7864328
diff --git a/REFLECTION b/REFLECTION
index b8acf3a..0dff417 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 xdebug version 2.8.0alpha1 ] {
+Extension [ <persistent> extension #195 xdebug version 2.8.0beta1 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 8e4b1b4..e34eea2 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,13 +19,13 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit f6b96e69868b3a243ac9985c962a4b158a8dd7f9
+%global gh_commit e10085a60463ba2bfb74fd640abceda8d7d125d7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20190614
%global with_tests 0%{!?_without_tests:1}
%global upstream_version 2.8.0
-%global upstream_prever alpha1
-%global upstream_lower alpha1
+%global upstream_prever beta1
+%global upstream_lower beta1
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -255,14 +255,11 @@ cd NTS
# bug00886 is marked as slow as it uses a lot of disk space
TEST_OPTS="-q -x --show-diff"
-%if "%{php_version}" > "7.4"
-TEST_OPTS="$TEST_OPTS %{?_smp_mflags}"
-%endif
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so -d xdebug.auto_trace=0" \
+TEST_PHP_ARGS="-n $modules -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so -d xdebug.auto_trace=0 -d foo=yes" \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php $TEST_OPTS
+%{__php} -n run-xdebug-tests.php $TEST_OPTS
%else
: Test suite disabled
%endif
@@ -304,6 +301,9 @@ fi
%changelog
+* Fri Jul 26 2019 Remi Collet <remi@remirepo.net> - 2.8.0~beta1-1
+- update to 2.8.0beta1
+
* Sat Jun 29 2019 Remi Collet <remi@remirepo.net> - 2.8.0~alpha1-1
- update to 2.8.0alpha1