summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-xdebug.spec49
3 files changed, 45 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index 0f97cb8..facb1ef 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xdebug
xdebug support => enabled
-Version => 2.9.1
+Version => 2.9.8
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
Debugger => enabled
diff --git a/REFLECTION b/REFLECTION
index 8c42c43..54a00b8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 xdebug version 2.9.1 ] {
+Extension [ <persistent> extension #117 xdebug version 2.9.8 ] {
- INI {
Entry [ xdebug.coverage_enable <SYSTEM> ]
@@ -194,13 +194,13 @@ Extension [ <persistent> extension #108 xdebug version 2.9.1 ] {
- Constants [15] {
Constant [ int XDEBUG_STACK_NO_DESC ] { 1 }
- Constant [ int XDEBUG_CC_UNUSED ] { 1 }
- Constant [ int XDEBUG_CC_DEAD_CODE ] { 2 }
- Constant [ int XDEBUG_CC_BRANCH_CHECK ] { 4 }
Constant [ int XDEBUG_TRACE_APPEND ] { 1 }
Constant [ int XDEBUG_TRACE_COMPUTERIZED ] { 2 }
Constant [ int XDEBUG_TRACE_HTML ] { 4 }
Constant [ int XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
+ Constant [ int XDEBUG_CC_UNUSED ] { 1 }
+ Constant [ int XDEBUG_CC_DEAD_CODE ] { 2 }
+ Constant [ int XDEBUG_CC_BRANCH_CHECK ] { 4 }
Constant [ int XDEBUG_FILTER_TRACING ] { 256 }
Constant [ int XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
Constant [ int XDEBUG_FILTER_NONE ] { 0 }
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 684627d..f611c41 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,11 +19,11 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 02890b34d419e6d0364946ddd904a0ebfbe92bca
+%global gh_commit 3e09864af111d63b7eb486d88bfc6eb7d6429b85
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20190614
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.9.1
+%global upstream_version 2.9.8
#global upstream_prever beta2
#global upstream_lower beta2
@@ -31,10 +31,10 @@
%global ini_name 15-%{pecl_name}.ini
Name: %{?scl_prefix}php-pecl-xdebug
-Summary: PECL package for debugging PHP scripts
+Summary: Provides functions for function traces and profiling
Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
-Release: 2.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -46,7 +46,7 @@ URL: https://xdebug.org/
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-simplexml
BuildRequires: libedit-devel
@@ -54,6 +54,9 @@ BuildRequires: libtool
%if %{with_tests}
BuildRequires: %{?scl_prefix}php-soap
%endif
+%if 0%{?rhel} == 6
+BuildRequires: autoconf268
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -64,7 +67,7 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug) = %{version}
Provides: %{?scl_prefix}php-pecl(Xdebug)%{?_isa} = %{version}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
@@ -76,10 +79,8 @@ Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
@@ -90,7 +91,9 @@ Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -169,6 +172,9 @@ sed -e '1d' NTS/%{pecl_name}.ini >>%{ini_name}
%build
+%if 0%{?rhel} == 6
+export PHP_AUTOCONF=autoconf268;export PHP_AUTOHEADER=autoheader268
+%endif
%{?dtsenable}
cd NTS
@@ -301,8 +307,33 @@ fi
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.9.8-1
+- update to 2.9.8
+
+* Wed Sep 16 2020 Remi Collet <remi@remirepo.net> - 2.9.7-1
+- update to 2.9.7
+
+* Sat May 30 2020 Remi Collet <remi@remirepo.net> - 2.9.6-1
+- update to 2.9.6
+
+* Tue May 5 2020 Remi Collet <remi@remirepo.net> - 2.9.5-2
+- rebuild for https://github.com/remicollet/remirepo/issues/146
+
+* Sun Apr 26 2020 Remi Collet <remi@remirepo.net> - 2.9.5-1
+- update to 2.9.5
+
+* Mon Mar 23 2020 Remi Collet <remi@remirepo.net> - 2.9.4-1
+- update to 2.9.4
+
+* Sat Mar 14 2020 Remi Collet <remi@remirepo.net> - 2.9.3-1
+- update to 2.9.3
+
+* Fri Jan 31 2020 Remi Collet <remi@remirepo.net> - 2.9.2-1
+- update to 2.9.2
+
* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 2.9.1-1
- update to 2.9.1
+- raise dependency on PHP 7.1
* Mon Dec 9 2019 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0