summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-14 07:44:23 +0100
committerRemi Collet <remi@remirepo.net>2020-03-14 07:44:23 +0100
commitc86f7d9ab16d17b5602e240513115f932d9809c6 (patch)
tree4a2deaa8eb2dd71c0f0f8ed2a6d4fcb2b1cce840
parentdf0d7f9d0b13fa4b36572bca6d35b99ec7ca89f6 (diff)
update to 2.9.3
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-xdebug.spec9
3 files changed, 11 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index 71ee13d..bf138c2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xdebug
xdebug support => enabled
-Version => 2.9.2
+Version => 2.9.3
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
Debugger => enabled
diff --git a/REFLECTION b/REFLECTION
index 4ad43f8..dbf0567 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 xdebug version 2.9.2 ] {
+Extension [ <persistent> extension #112 xdebug version 2.9.3 ] {
- INI {
Entry [ xdebug.coverage_enable <SYSTEM> ]
@@ -194,13 +194,13 @@ Extension [ <persistent> extension #108 xdebug version 2.9.2 ] {
- Constants [15] {
Constant [ int XDEBUG_STACK_NO_DESC ] { 1 }
- Constant [ int XDEBUG_CC_UNUSED ] { 1 }
- Constant [ int XDEBUG_CC_DEAD_CODE ] { 2 }
- Constant [ int XDEBUG_CC_BRANCH_CHECK ] { 4 }
Constant [ int XDEBUG_TRACE_APPEND ] { 1 }
Constant [ int XDEBUG_TRACE_COMPUTERIZED ] { 2 }
Constant [ int XDEBUG_TRACE_HTML ] { 4 }
Constant [ int XDEBUG_TRACE_NAKED_FILENAME ] { 8 }
+ Constant [ int XDEBUG_CC_UNUSED ] { 1 }
+ Constant [ int XDEBUG_CC_DEAD_CODE ] { 2 }
+ Constant [ int XDEBUG_CC_BRANCH_CHECK ] { 4 }
Constant [ int XDEBUG_FILTER_TRACING ] { 256 }
Constant [ int XDEBUG_FILTER_CODE_COVERAGE ] { 512 }
Constant [ int XDEBUG_FILTER_NONE ] { 0 }
diff --git a/php-pecl-xdebug.spec b/php-pecl-xdebug.spec
index 35d6a19..6f03bfd 100644
--- a/php-pecl-xdebug.spec
+++ b/php-pecl-xdebug.spec
@@ -19,11 +19,11 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit b626bc5c75bb28d99f289fbd9a86895cb11aeb29
+%global gh_commit fc206eb55672875c8f10a0c21a491e6ff6e6762d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20190614
%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 2.9.2
+%global upstream_version 2.9.3
#global upstream_prever beta2
#global upstream_lower beta2
@@ -34,7 +34,7 @@ Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: %{upstream_version}%{?upstream_lower:~%{upstream_lower}}
%if 0%{?gh_date:1}
-Release: 2.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -299,6 +299,9 @@ fi
%changelog
+* Sat Mar 14 2020 Remi Collet <remi@remirepo.net> - 2.9.3-1
+- update to 2.9.3
+
* Fri Jan 31 2020 Remi Collet <remi@remirepo.net> - 2.9.2-1
- update to 2.9.2