summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-03 06:58:12 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-03 06:58:12 +0100
commitab25012954db438005d3d335b20c3e9f5a460850 (patch)
treec869f802b50fd73d061c23cce37f34b93a589257
parent85af69307f44c795cd2c05e45d905ffaa1ab2f54 (diff)
php-pecl-xdebug: 2.4.0RC2
-rw-r--r--217.patch37
-rw-r--r--221.patch22
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-xdebug-php7.spec9
-rw-r--r--xdebug-upstream.patch28
5 files changed, 8 insertions, 92 deletions
diff --git a/217.patch b/217.patch
deleted file mode 100644
index cda53d2..0000000
--- a/217.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 05efe9a3e6574d7692fbd49f3116f5db320e71a9 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 5 Nov 2015 15:52:52 +0100
-Subject: [PATCH] fix -Wmaybe-uninitialized
-
----
- usefulstuff.c | 2 +-
- xdebug_stack.c | 3 ---
- 2 files changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/usefulstuff.c b/usefulstuff.c
-index 60e8f19..1ed45c8 100644
---- a/usefulstuff.c
-+++ b/usefulstuff.c
-@@ -619,7 +619,7 @@ int xdebug_format_output_filename(char **filename, char *format, char *script_na
- case 'R': { /* $_SERVER['REQUEST_URI'] */
- char *char_ptr, *strval;
- #if PHP_VERSION_ID >= 70000
-- zval *data;
-+ zval *data = NULL;
-
- if (Z_TYPE(PG(http_globals)[TRACK_VARS_SERVER]) == IS_ARRAY) {
- switch (*format) {
-diff --git a/xdebug_stack.c b/xdebug_stack.c
-index a13b2a4..9ecf4ec 100644
---- a/xdebug_stack.c
-+++ b/xdebug_stack.c
-@@ -1505,9 +1505,6 @@ function_stack_entry *xdebug_add_stack_frame(zend_execute_data *zdata, zend_op_a
- aggr_key_len = strlen(aggr_key);
- #if PHP_VERSION_ID >= 70000
- aggr_key_str = zend_string_init(aggr_key, aggr_key_len, 0);
--#endif
--
--#if PHP_VERSION_ID >= 70000
- if ((tmp->aggr_entry = zend_hash_find_ptr(&XG(aggr_calls), aggr_key_str)) == NULL) {
- #else
- if (zend_hash_find(&XG(aggr_calls), aggr_key, aggr_key_len+1, (void**)&tmp->aggr_entry) == FAILURE) {
diff --git a/221.patch b/221.patch
deleted file mode 100644
index 9244f65..0000000
--- a/221.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 7d540886765540e593c2dc89d63e41504697f1b2 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 5 Nov 2015 19:13:33 +0100
-Subject: [PATCH] fix build on i686
-
----
- xdebug_code_coverage.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/xdebug_code_coverage.c b/xdebug_code_coverage.c
-index 6c52f81..8745b04 100644
---- a/xdebug_code_coverage.c
-+++ b/xdebug_code_coverage.c
-@@ -554,7 +554,7 @@ static zend_brk_cont_element* xdebug_find_brk_cont(zend_uint nest_levels, int ar
-
- static int xdebug_find_jump(zend_op_array *opa, unsigned int position, long *jmp1, long *jmp2)
- {
--#if PHP_VERSION_ID < 70000
-+#if defined(ZEND_USE_ABS_JMP_ADDR) || PHP_VERSION_ID < 70000
- zend_op *base_address = &(opa->opcodes[0]);
- #endif
-
diff --git a/REFLECTION b/REFLECTION
index 5dea39a..f79458f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #206 xdebug version 2.4.0beta1 ] {
+Extension [ <persistent> extension #207 xdebug version 2.4.0RC2 ] {
- INI {
Entry [ xdebug.auto_trace <ALL> ]
@@ -68,7 +68,7 @@ Extension [ <persistent> extension #206 xdebug version 2.4.0beta1 ] {
Current = '1'
}
Entry [ xdebug.show_error_trace <ALL> ]
- Current = '1'
+ Current = '0'
}
Entry [ xdebug.show_exception_trace <ALL> ]
Current = '0'
diff --git a/php-pecl-xdebug-php7.spec b/php-pecl-xdebug-php7.spec
index 42b38d3..3c4ccc6 100644
--- a/php-pecl-xdebug-php7.spec
+++ b/php-pecl-xdebug-php7.spec
@@ -19,11 +19,11 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit b1d281f612d3b14abce0b090bfaedbfc8680c0cc
+%global gh_commit 587416c8146bf2aec785ff3fa16ea55d04a30c4b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151118
%global with_tests 0%{?_with_tests:1}
-%global prever rc1
+%global prever RC2
# XDebug should be loaded after opcache
%if "%{php_version}" < "5.6"
@@ -35,7 +35,7 @@
Name: %{?scl_prefix}php-pecl-xdebug
Summary: PECL package for debugging PHP scripts
Version: 2.4.0
-Release: 0.5.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.6.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}%{?prever}-%{gh_short}.tar.gz
# The Xdebug License, version 1.01
@@ -288,6 +288,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Dec 3 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.6.RC2
+- update to 2.4.0RC1
+
* Wed Nov 25 2015 Remi Collet <remi@fedoraproject.org> - 2.4.0-0.5.RC1
- update to 2.4.0RC1
diff --git a/xdebug-upstream.patch b/xdebug-upstream.patch
deleted file mode 100644
index c0d73fb..0000000
--- a/xdebug-upstream.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ac8557ff69d2961e91a9212a81ef5eb535beda5f Mon Sep 17 00:00:00 2001
-From: Derick Rethans <github@derickrethans.nl>
-Date: Sun, 8 Nov 2015 20:35:36 -0500
-Subject: [PATCH] Fixed issue #1195: Segfault with code coverage and foreach
-
----
- tests/bug01195-php5.phpt | 37 +++++++++++++++++++++++++++++++++++++
- tests/bug01195-php7.phpt | 38 ++++++++++++++++++++++++++++++++++++++
- tests/bug01195.inc | 12 ++++++++++++
- xdebug_code_coverage.c | 2 +-
- 4 files changed, 88 insertions(+), 1 deletion(-)
- create mode 100644 tests/bug01195-php5.phpt
- create mode 100644 tests/bug01195-php7.phpt
- create mode 100644 tests/bug01195.inc
-
-diff --git a/xdebug_code_coverage.c b/xdebug_code_coverage.c
-index 6c52f81..85a9752 100644
---- a/xdebug_code_coverage.c
-+++ b/xdebug_code_coverage.c
-@@ -615,7 +615,7 @@ static int xdebug_find_jump(zend_op_array *opa, unsigned int position, long *jmp
- #endif
- *jmp1 = position + 1;
- #if PHP_VERSION_ID >= 70000
-- *jmp2 = XDEBUG_ZNODE_JMP_LINE(opcode.op2, position, base_address) * sizeof(zend_op);
-+ *jmp2 = XDEBUG_ZNODE_JMP_LINE(opcode.op2, position, base_address);
- #else
- *jmp2 = XDEBUG_ZNODE_ELEM(opcode.op2, opline_num);
- #endif