summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-22 10:22:10 +0200
committerRemi Collet <remi@remirepo.net>2020-04-22 10:22:10 +0200
commitc59fb84bdc359cc80333ae9b9097ebfa4c6eb511 (patch)
tree49046e1f304e17be275919cbdf5fddc861742b37
parenta8b5d0b2659a4f56e407488233f57bfec14bab4a (diff)
v1.3.1
-rw-r--r--PHPINFO5
-rw-r--r--REFLECTION20
-rw-r--r--php-pecl-xattr.spec37
3 files changed, 25 insertions, 37 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..fa7967b
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,5 @@
+
+xattr
+
+xattr support => enabled
+PECL module version => 1.3.1
diff --git a/REFLECTION b/REFLECTION
index 8ac5c71..9e97b4b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,15 +1,15 @@
-Extension [ <persistent> extension #178 xattr version 1.3.0 ] {
+Extension [ <persistent> extension #99 xattr version 1.3.1 ] {
- Constants [9] {
- Constant [ integer XATTR_CREATE ] { 1 }
- Constant [ integer XATTR_REPLACE ] { 2 }
- Constant [ integer XATTR_DONTFOLLOW ] { 4 }
- Constant [ integer XATTR_USER ] { 8 }
- Constant [ integer XATTR_ROOT ] { 16 }
- Constant [ integer XATTR_TRUSTED ] { 16 }
- Constant [ integer XATTR_SYSTEM ] { 32 }
- Constant [ integer XATTR_SECURITY ] { 64 }
- Constant [ integer XATTR_ALL ] { 128 }
+ Constant [ int XATTR_CREATE ] { 1 }
+ Constant [ int XATTR_REPLACE ] { 2 }
+ Constant [ int XATTR_DONTFOLLOW ] { 4 }
+ Constant [ int XATTR_USER ] { 8 }
+ Constant [ int XATTR_ROOT ] { 16 }
+ Constant [ int XATTR_TRUSTED ] { 16 }
+ Constant [ int XATTR_SYSTEM ] { 32 }
+ Constant [ int XATTR_SECURITY ] { 64 }
+ Constant [ int XATTR_ALL ] { 128 }
}
- Functions {
diff --git a/php-pecl-xattr.spec b/php-pecl-xattr.spec
index bd283a6..168a522 100644
--- a/php-pecl-xattr.spec
+++ b/php-pecl-xattr.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-xattr
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -21,11 +21,11 @@
Summary: Extended attributes
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.0
-Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.3.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -44,36 +44,16 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -234,6 +214,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Apr 22 2020 Remi Collet <remi@remirepo.net> - 1.3.1-1
+- update to 1.3.1
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.3.0-8
- rebuild for 7.4.0RC1