summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-05-05 15:26:22 +0200
committerRemi Collet <fedora@famillecollet.com>2014-05-05 15:26:22 +0200
commitb547272bb3e259e2fcf83542d50eac51013e055a (patch)
treedb459391b51e8dd6ed5e2f2cbfa76cce049998fd
parent39581d0bc8e3aa9107f5bd3fdd44a82829cf876b (diff)
php-pecl-weakref: 0.2.4 (beta)
-rw-r--r--3_01.txt68
-rw-r--r--php-pecl-weakref.spec21
2 files changed, 8 insertions, 81 deletions
diff --git a/3_01.txt b/3_01.txt
deleted file mode 100644
index 6059c80..0000000
--- a/3_01.txt
+++ /dev/null
@@ -1,68 +0,0 @@
---------------------------------------------------------------------
- The PHP License, version 3.01
-Copyright (c) 1999 - 2014 The PHP Group. All rights reserved.
---------------------------------------------------------------------
-
-Redistribution and use in source and binary forms, with or without
-modification, is permitted provided that the following conditions
-are met:
-
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
-
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in
- the documentation and/or other materials provided with the
- distribution.
-
- 3. The name "PHP" must not be used to endorse or promote products
- derived from this software without prior written permission. For
- written permission, please contact group@php.net.
-
- 4. Products derived from this software may not be called "PHP", nor
- may "PHP" appear in their name, without prior written permission
- from group@php.net. You may indicate that your software works in
- conjunction with PHP by saying "Foo for PHP" instead of calling
- it "PHP Foo" or "phpfoo"
-
- 5. The PHP Group may publish revised and/or new versions of the
- license from time to time. Each version will be given a
- distinguishing version number.
- Once covered code has been published under a particular version
- of the license, you may always continue to use it under the terms
- of that version. You may also choose to use such covered code
- under the terms of any subsequent version of the license
- published by the PHP Group. No one other than the PHP Group has
- the right to modify the terms applicable to covered code created
- under this License.
-
- 6. Redistributions of any form whatsoever must retain the following
- acknowledgment:
- "This product includes PHP software, freely available from
- <http://www.php.net/software/>".
-
-THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
-ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
-THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
-PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
-DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
-INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
-OF THE POSSIBILITY OF SUCH DAMAGE.
-
---------------------------------------------------------------------
-
-This software consists of voluntary contributions made by many
-individuals on behalf of the PHP Group.
-
-The PHP Group can be contacted via Email at group@php.net.
-
-For more information on the PHP Group and the PHP project,
-please see <http://www.php.net>.
-
-PHP includes the Zend Engine, freely available at
-<http://www.zend.com>.
diff --git a/php-pecl-weakref.spec b/php-pecl-weakref.spec
index 41900c8..af5e641 100644
--- a/php-pecl-weakref.spec
+++ b/php-pecl-weakref.spec
@@ -15,6 +15,7 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name Weakref
%global ext_name weakref
+%global versuf -beta
%if "%{php_version}" < "5.6"
%global ini_name %{ext_name}.ini
%else
@@ -23,17 +24,13 @@
Summary: Implementation of weak references
Name: %{?scl_prefix}php-pecl-weakref
-Version: 0.2.3
+Version: 0.2.4
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# URL from sources header
-# https://github.com/colder/php-weakref/issues/11
-Source1: http://www.php.net/license/3_01.txt
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
@@ -82,16 +79,11 @@ that object from being collected by the garbage collector (GC).
mv %{pecl_name}-%{version} NTS
cd NTS
-cp %{SOURCE1} LICENSE
-
-# https://github.com/colder/php-weakref/issues/12
-sed -e '/PHP_WEAKREF_VERSION/s/0.0.1-alpha/%{version}/' \
- -i php_weakref.h
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_WEAKREF_VERSION/{s/.* "//;s/".*$//;p}' php_weakref.h)
-if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+if test "x${extver}" != "x%{version}%{?versuf}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?versuf}.
exit 1
fi
cd ..
@@ -146,7 +138,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
-for i in LICENSE $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -194,6 +186,9 @@ rm -rf %{buildroot}
%changelog
+* Mon May 05 2014 Remi Collet <remi@fedoraproject.org> - 0.2.4-1
+- Update to 0.2.4 (beta)
+
* Sun May 4 2014 Remi Collet <remi@fedoraproject.org> - 0.2.3-1
- initial package, version 0.2.3 (beta)
- open https://github.com/colder/php-weakref/issues/11 License