summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-25 15:47:13 +0200
committerRemi Collet <remi@remirepo.net>2017-08-25 15:47:13 +0200
commit142625859a0c729476f95b6883c620591b57a3a1 (patch)
treeb19904341a14aeb1849c5fd3f5d26b1027132124
parent10a9a2a19a8f16498b2b05d4d365e47fb40976bc (diff)
switch
-rw-r--r--REFLECTION2
-rw-r--r--REFLECTION-PHP7141
-rw-r--r--php-pecl-weakref-php7.spec290
-rw-r--r--php-pecl-weakref.spec102
4 files changed, 85 insertions, 450 deletions
diff --git a/REFLECTION b/REFLECTION
index 71333dc..694ccf7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 Weakref version 0.2.6 ] {
+Extension [ <persistent> extension #138 Weakref version 0.3.3 ] {
- Classes [2] {
Class [ <internal:Weakref> final class WeakRef ] {
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index 694ccf7..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,141 +0,0 @@
-Extension [ <persistent> extension #138 Weakref version 0.3.3 ] {
-
- - Classes [2] {
- Class [ <internal:Weakref> final class WeakRef ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [5] {
- Method [ <internal:Weakref, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $object ]
- }
- }
-
- Method [ <internal:Weakref> public method valid ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref> public method get ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref> public method acquire ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref> public method release ] {
-
- - Parameters [0] {
- }
- }
- }
- }
-
- Class [ <internal:Weakref> <iterateable> final class WeakMap implements Countable, ArrayAccess, Iterator, Traversable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [11] {
- Method [ <internal:Weakref, ctor> public method __construct ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref, prototype Countable> public method count ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref, prototype ArrayAccess> public method offsetExists ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $object ]
- }
- }
-
- Method [ <internal:Weakref, prototype ArrayAccess> public method offsetGet ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $object ]
- }
- }
-
- Method [ <internal:Weakref, prototype ArrayAccess> public method offsetSet ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $object ]
- Parameter #1 [ <required> $value ]
- }
- }
-
- Method [ <internal:Weakref, prototype ArrayAccess> public method offsetUnset ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $object ]
- }
- }
-
- Method [ <internal:Weakref, prototype Iterator> public method rewind ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref, prototype Iterator> public method valid ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref, prototype Iterator> public method key ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref, prototype Iterator> public method current ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:Weakref, prototype Iterator> public method next ] {
-
- - Parameters [0] {
- }
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-weakref-php7.spec b/php-pecl-weakref-php7.spec
deleted file mode 100644
index 4ba7f9c..0000000
--- a/php-pecl-weakref-php7.spec
+++ /dev/null
@@ -1,290 +0,0 @@
-# remirepo spec file for php-pecl-weakref
-#
-# Copyright (c) 2014-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%{?scl: %scl_package php-pecl-weakref}
-
-%global gh_commit faa99eef4c7333ec563e7c22afa152753d1bf3d5
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner colder
-%global gh_project php-weakref
-#global gh_date 20160111
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global with_tests 0%{!?_without_tests:1}
-%global pecl_name Weakref
-%global ext_name weakref
-#global versuf -beta
-%global ini_name 40-%{ext_name}.ini
-
-Summary: Implementation of weak references
-Name: %{?scl_prefix}php-pecl-weakref
-Version: 0.3.3
-%if 0%{?gh_date}
-Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-%else
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-%endif
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-pear
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{ext_name} = %{version}
-Provides: %{?scl_prefix}php-%{ext_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{ext_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{ext_name}%{?_isa} = %{version}-%{release}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-A weak reference provides a gateway to an object without preventing
-that object from being collected by the garbage collector (GC).
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -q -c
-%if 0%{?gh_date}
-mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package.xml .
-%else
-mv %{pecl_name}-%{version} NTS
-%endif
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-cd NTS
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_WEAKREF_VERSION/{s/.* "//;s/".*$//;p}' php_weakref.h)
-if test "x${extver}" != "x%{version}%{?versuf}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?versuf}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat << 'EOF' | tee %{ini_name}
-; Enable %{pecl_name} extension module
-extension=%{ext_name}.so
-EOF
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
-
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
-
-make %{?_smp_mflags}
-%endif
-
-
-%install
-rm -rf %{buildroot}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%check
-cd NTS
-: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{ext_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_tests}
-: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{ext_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
-%else
-: Upstream test suite disabled
-%endif
-
-%if %{with_zts}
-cd ../ZTS
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{ext_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{ext_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
-%else
-: Upstream test suite disabled
-%endif
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{ext_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{ext_name}.so
-%endif
-
-
-%changelog
-* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 0.3.3-2
-- rebuild for PHP 7.2.0beta1 new API
-
-* Tue Dec 13 2016 Remi Collet <remi@fedoraproject.org> - 0.3.3-1
-- update to 0.3.3
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.3.2-4
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 0.3.2-3
-- rebuild for PHP 7.1 new API version
-
-* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 0.3.2-2
-- adapt for F24
-- drop runtime dependency on pear, new scriptlets
-
-* Sun Jan 24 2016 Remi Collet <remi@fedoraproject.org> - 0.3.2-1
-- update to 0.3.2
-
-* Mon Jan 11 2016 Remi Collet <remi@fedoraproject.org> - 0.3.1-1
-- update to 0.3.1
-- run test suite during the build
-- include patch to prevent segfault
- open https://github.com/colder/php-weakref/pull/22
-- use generated tarball from master + pr22 to include tests
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.2.6-1.1
-- Fedora 21 SCL mass rebuild
-
-* Thu Nov 13 2014 Remi Collet <remi@fedoraproject.org> - 0.2.6-1
-- Update to 0.2.6
-
-* Wed Oct 08 2014 Remi Collet <remi@fedoraproject.org> - 0.2.5-1
-- Update to 0.2.5
-
-* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 0.2.4-2
-- improve SCL build
-
-* Mon May 05 2014 Remi Collet <remi@fedoraproject.org> - 0.2.4-1
-- Update to 0.2.4 (beta)
-
-* Sun May 4 2014 Remi Collet <remi@fedoraproject.org> - 0.2.3-1
-- initial package, version 0.2.3 (beta)
-- open https://github.com/colder/php-weakref/issues/11 License
-- open https://github.com/colder/php-weakref/issues/12 Version
-
diff --git a/php-pecl-weakref.spec b/php-pecl-weakref.spec
index 16ff932..4ba7f9c 100644
--- a/php-pecl-weakref.spec
+++ b/php-pecl-weakref.spec
@@ -6,32 +6,38 @@
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-pecl-judy}
-
-%global with_zts 0%{?__ztsphp:1}
+%{?scl: %scl_package php-pecl-weakref}
+
+%global gh_commit faa99eef4c7333ec563e7c22afa152753d1bf3d5
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner colder
+%global gh_project php-weakref
+#global gh_date 20160111
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global with_tests 0%{!?_without_tests:1}
%global pecl_name Weakref
%global ext_name weakref
#global versuf -beta
-%if "%{php_version}" < "5.6"
-%global ini_name %{ext_name}.ini
-%else
%global ini_name 40-%{ext_name}.ini
-%endif
Summary: Implementation of weak references
Name: %{?scl_prefix}php-pecl-weakref
-Version: 0.2.6
+Version: 0.3.3
+%if 0%{?gh_date}
+Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
+%else
Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+%endif
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel < 7
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: Judy-devel
-BuildRequires: pcre-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -50,13 +56,19 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -76,12 +88,19 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
+%if 0%{?gh_date}
+mv %{gh_project}-%{gh_commit} NTS
+mv NTS/package.xml .
+%else
mv %{pecl_name}-%{version} NTS
+%endif
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_WEAKREF_VERSION/{s/.* "//;s/".*$//;p}' php_weakref.h)
if test "x${extver}" != "x%{version}%{?versuf}"; then
@@ -166,16 +185,40 @@ fi
%check
+cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{ext_name}.so \
--modules | grep %{pecl_name}
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{ext_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%else
+: Upstream test suite disabled
+%endif
+
%if %{with_zts}
+cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{ext_name}.so \
--modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{ext_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%else
+: Upstream test suite disabled
+%endif
%endif
@@ -199,10 +242,32 @@ rm -rf %{buildroot}
%changelog
-* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.2.6-2
+* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 0.3.3-2
+- rebuild for PHP 7.2.0beta1 new API
+
+* Tue Dec 13 2016 Remi Collet <remi@fedoraproject.org> - 0.3.3-1
+- update to 0.3.3
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.3.2-4
+- rebuild with PHP 7.1.0 GA
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 0.3.2-3
+- rebuild for PHP 7.1 new API version
+
+* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 0.3.2-2
- adapt for F24
- drop runtime dependency on pear, new scriptlets
+* Sun Jan 24 2016 Remi Collet <remi@fedoraproject.org> - 0.3.2-1
+- update to 0.3.2
+
+* Mon Jan 11 2016 Remi Collet <remi@fedoraproject.org> - 0.3.1-1
+- update to 0.3.1
+- run test suite during the build
+- include patch to prevent segfault
+ open https://github.com/colder/php-weakref/pull/22
+- use generated tarball from master + pr22 to include tests
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.2.6-1.1
- Fedora 21 SCL mass rebuild
@@ -222,3 +287,4 @@ rm -rf %{buildroot}
- initial package, version 0.2.3 (beta)
- open https://github.com/colder/php-weakref/issues/11 License
- open https://github.com/colder/php-weakref/issues/12 Version
+