summaryrefslogtreecommitdiffstats
path: root/php-pecl-vld.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-30 11:29:38 +0100
committerRemi Collet <remi@php.net>2021-11-30 11:29:38 +0100
commitf180723049d5f8e6e5bdeda4a0bf52484cfb5c55 (patch)
tree3c1527039dbd0aa8cffaa5db30a62420de77a785 /php-pecl-vld.spec
parenta82f714c60300b412ac1119db2ff2c80c4f06230 (diff)
update to 0.17.2
add patch for build warnings from https://github.com/derickr/vld/pull/72
Diffstat (limited to 'php-pecl-vld.spec')
-rw-r--r--php-pecl-vld.spec25
1 files changed, 18 insertions, 7 deletions
diff --git a/php-pecl-vld.spec b/php-pecl-vld.spec
index e39bc20..e3a1cd3 100644
--- a/php-pecl-vld.spec
+++ b/php-pecl-vld.spec
@@ -26,7 +26,7 @@
Summary: Dump the internal representation of PHP scripts
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.17.1
+Version: 0.17.2
%if 0%{?gh_date:1}
Release: 0.16.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -37,6 +37,8 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
+Patch0: 0001-constify.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: make
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -57,15 +59,15 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -96,11 +98,15 @@ mv %{pecl_name}-%{version} NTS
: Fix version
sed -e 's/"0.16.0"/"%{version}"/' -i NTS/vld.c
+pushd NTS
+%patch0 -p1
+
: Check version
-if ! grep -q '"%{version}%{?gh_date:-dev}"' NTS/vld.c; then
+if ! grep -q '"%{version}%{?gh_date:-dev}"' vld.c; then
: Error: Upstream extension version, expecting %{version}%{?gh_date:-dev}%{?prever:-%{prever}}.
exit 1
fi
+popd
%if %{with_zts}
@@ -193,13 +199,13 @@ fi
# Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=NTS/modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with_zts}
# Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=ZTS/modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%endif
@@ -218,6 +224,11 @@ fi
%changelog
+* Tue Nov 30 2021 Remi Collet <remi@remirepo.net> - 0.17.2-1
+- update to 0.17.2
+- add patch for build warnings from
+ https://github.com/derickr/vld/pull/72
+
* Mon Jan 11 2021 Remi Collet <remi@remirepo.net> - 0.17.1-1
- update to 0.17.1