summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-19 19:19:22 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-19 19:19:22 +0100
commitcded0d2a745082521245fb3b93f4c98ba5401545 (patch)
tree4371fc54a8eef0bdf97152aa909cd01652796fb9
parent0983804b622f25aeea17277eb29c2f9cf14130ad (diff)
php-pecl-vld: 0.14.0
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-vld.spec44
-rw-r--r--vld-git.patch48
3 files changed, 33 insertions, 61 deletions
diff --git a/REFLECTION b/REFLECTION
index 0e9861b..1983072 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 vld version 0.13.0 ] {
+Extension [ <persistent> extension #138 vld version 0.14.0 ] {
- INI {
Entry [ vld.active <SYSTEM> ]
diff --git a/php-pecl-vld.spec b/php-pecl-vld.spec
index 1482b91..ae0ccef 100644
--- a/php-pecl-vld.spec
+++ b/php-pecl-vld.spec
@@ -6,10 +6,13 @@
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-pecl-vld}
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-vld
+%endif
%global pecl_name vld
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
@@ -17,17 +20,14 @@
%endif
Summary: Dump the internal representation of PHP scripts
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.13.0
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 0.14.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/derickr/vld/commits/master
-Patch0: %{pecl_name}-git.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -40,8 +40,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -57,6 +59,14 @@ Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -77,10 +87,17 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -q -c
mv %{pecl_name}-%{version} NTS
-cd NTS
-%patch0 -p1 -b .fromgit
-chmod +r LICENS*
-cd ..
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
+: Fix version
+sed -e 's/"0.14.0-dev"/"%{version}"/' -i NTS/vld.c
+
+: Check version
+if ! grep -q '"%{version}"' NTS/vld.c; then
+ : Error: Upstream extension version, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
@@ -200,6 +217,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Dec 19 2016 Remi Collet <remi@fedoraproject.org> - 0.14.0-1
+- Update to 0.14.0
+
* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.13.0-2
- adapt for F24
- fix license management
diff --git a/vld-git.patch b/vld-git.patch
deleted file mode 100644
index c4f118a..0000000
--- a/vld-git.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From b116904efc9399a1fcf3933efeba12b556dde593 Mon Sep 17 00:00:00 2001
-From: Derick Rethans <github@derickrethans.nl>
-Date: Tue, 22 Oct 2013 09:58:31 +0100
-Subject: [PATCH] Fixed license headers in files.
-
----
- CREDITS | 4 ++--
- LICENSE | 23 +++++++++++++++++++++++
- branchinfo.c | 14 ++++----------
- branchinfo.h | 14 ++++----------
- php_vld.h | 14 ++++----------
- set.c | 14 ++++----------
- set.h | 14 ++++----------
- srm_oparray.c | 14 ++++----------
- srm_oparray.h | 14 ++++----------
- vld.c | 14 ++++----------
- 10 files changed, 57 insertions(+), 82 deletions(-)
- create mode 100644 LICENSE
-
-diff --git a/LICENSE b/LICENSE
-new file mode 100644
-index 0000000..14dbb68
---- /dev/null
-+++ b/LICENSE
-@@ -0,0 +1,23 @@
-+Copyright (c) 2002-2013, Derick Rethans
-+
-+All rights reserved.
-+
-+Redistribution and use in source and binary forms, with or without
-+modification, are permitted provided that the following conditions are met:
-+
-+ - Redistributions of source code must retain the above copyright notice, this
-+ list of conditions and the following disclaimer.
-+ - Redistributions in binary form must reproduce the above copyright notice,
-+ this list of conditions and the following disclaimer in the documentation
-+ and/or other materials provided with the distribution.
-+
-+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
-+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.