summaryrefslogtreecommitdiffstats
path: root/php-pecl-vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-vips.spec')
-rw-r--r--php-pecl-vips.spec24
1 files changed, 8 insertions, 16 deletions
diff --git a/php-pecl-vips.spec b/php-pecl-vips.spec
index 66e7aa1..9fb37ef 100644
--- a/php-pecl-vips.spec
+++ b/php-pecl-vips.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-vips
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -21,17 +21,13 @@
Summary: PHP extension for interfacing with libvips
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.12
-Release: 6%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.0.13
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# https://github.com/libvips/php-vips-ext/issues/43
-# https://github.com/libvips/php-vips-ext/pull/44
-Patch0: %{pecl_name}-pr44.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: make
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -89,8 +85,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/define PHP_VIPS_VERSION/{s/.* "//;s/".*$//;p}' php_vips.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -180,9 +174,6 @@ fi
%check
-# Need investigation
-rm ?TS/tests/029.phpt
-
: Minimal load test for NTS extension
cd NTS
%{_bindir}/php --no-php-ini \
@@ -192,9 +183,8 @@ cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php --show-diff
+%{_bindir}/php -n run-tests.php -q --show-diff
%if %{with_zts}
@@ -208,9 +198,8 @@ cd ../ZTS
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -229,6 +218,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Feb 16 2022 Remi Collet <remi@remirepo.net> - 1.0.13-1
+- update to 1.0.13
+
* Wed Sep 8 2021 Remi Collet <remi@remirepo.net> - 1.0.12-6
- test build for upstream patch