summaryrefslogtreecommitdiffstats
path: root/php-pecl-vips.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-21 14:57:36 +0200
committerRemi Collet <remi@php.net>2023-07-21 14:57:36 +0200
commit95ef2751e708531ccbeb920a7be95d338a43af95 (patch)
treef2a8055f87ae3ee538071510adce326bd6dcc63c /php-pecl-vips.spec
parentc7928df3fe75528cac077825e019430d4ce1f4fb (diff)
build out of sources tree
Diffstat (limited to 'php-pecl-vips.spec')
-rw-r--r--php-pecl-vips.spec62
1 files changed, 32 insertions, 30 deletions
diff --git a/php-pecl-vips.spec b/php-pecl-vips.spec
index 2b322b3..00e1bcc 100644
--- a/php-pecl-vips.spec
+++ b/php-pecl-vips.spec
@@ -1,21 +1,21 @@
# remirepo spec file for php-pecl-vips
#
# Copyright (c) 2016-2023 Remi Collet
-# License: CC-BY-SA
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%scl_package php-pecl-vips
-%endif
+%{?scl:%scl_package php-pecl-vips}
-%bcond_with tests
+%bcond_without tests
-%global pecl_name vips
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global ini_name 40-%{pecl_name}.ini
-#global prever RC9
+%global pecl_name vips
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+#global prever RC9
+%global sources %{pecl_name}-%{version}%{?prever}
+%global _configure ../%{sources}/configure
# Ensure runtime version > buildtime version, for possible new symbols
%global vipsbuildver %(pkg-config --silence-errors --modversion vips 2>/dev/null || echo 65536)
@@ -23,14 +23,14 @@
Summary: PHP extension for interfacing with libvips
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.13
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP-3.01
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
-BuildRequires: %{?dtsprefix}gcc
BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
# ensure latest version is used (upstream requires 8.2)
@@ -39,7 +39,6 @@ Requires: vips%{?_isa} >= %{vipsbuildver}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -55,14 +54,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version}%{?prever} NTS
# Don't register test files on install
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/define PHP_VIPS_VERSION/{s/.* "//;s/".*$//;p}' php_vips.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -71,9 +69,10 @@ if test "x${extver}" != "x%{version}%{?prever}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -86,22 +85,23 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-vips \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-vips \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -125,7 +125,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -152,24 +152,23 @@ fi
%check
+cd %{sources}
+
: Minimal load test for NTS extension
-cd NTS
-%{_bindir}/php --no-php-ini \
+%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%if %{with tests}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php -q --show-diff
+%{__php} -n run-tests.php -q --show-diff
%endif
%if %{with_zts}
: Minimal load test for ZTS extension
-cd ../ZTS
-
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
@@ -185,7 +184,7 @@ REPORT_EXIT_STATUS=1 \
%files
-%{?_licensedir:%license NTS/LICENSE.txt}
+%{?_licensedir:%license %{sources}/LICENSE.txt}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -199,6 +198,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Jul 21 2023 Remi Collet <remi@remirepo.net> - 1.0.13-3
+- build out of sources tree
+
* Mon Jan 2 2023 Remi Collet <remi@remirepo.net> - 1.0.13-2
- rebuild against vips 8.14