summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-23 18:15:05 +0100
committerRemi Collet <remi@remirepo.net>2017-11-23 18:15:05 +0100
commitf27537ad329db3ffea7f7664811f8e1046739a5d (patch)
tree7af07b9dcd5ca7a82d90032bdd5d6a7fd5e928dd
parent73121757ddb15b75b7781a87f2b5f0c997a3f00e (diff)
v1.0.8
-rw-r--r--REFLECTION23
-rw-r--r--php-pecl-vips.spec7
2 files changed, 27 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
index 363ebc5..4161c4a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #149 vips version 1.0.7 ] {
+Extension [ <persistent> extension #158 vips version 1.0.8 ] {
- Functions {
Function [ <internal:vips> function vips_image_new_from_file ] {
@@ -45,6 +45,22 @@ Extension [ <persistent> extension #149 vips version 1.0.7 ] {
Parameter #0 [ <required> $image ]
}
}
+ Function [ <internal:vips> function vips_image_new_from_memory ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $array ]
+ Parameter #1 [ <required> $width ]
+ Parameter #2 [ <required> $height ]
+ Parameter #3 [ <required> $bands ]
+ Parameter #4 [ <required> $format ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_write_to_memory ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $image ]
+ }
+ }
Function [ <internal:vips> function vips_foreign_find_load ] {
- Parameters [1] {
@@ -128,6 +144,11 @@ Extension [ <persistent> extension #149 vips version 1.0.7 ] {
Parameter #0 [ <required> $value ]
}
}
+ Function [ <internal:vips> function vips_version ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
diff --git a/php-pecl-vips.spec b/php-pecl-vips.spec
index 27be47d..af71020 100644
--- a/php-pecl-vips.spec
+++ b/php-pecl-vips.spec
@@ -21,8 +21,8 @@
Summary: PHP extension for interfacing with libvips
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.7
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.0.8
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -218,6 +218,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Nov 23 2017 Remi Collet <remi@remirepo.net> - 1.0.8-1
+- Update to 1.0.8
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.0.7-3
- rebuild for PHP 7.2.0beta1 new API