summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-24 12:38:17 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-24 12:38:17 +0100
commit4b7e19c26460572a3ac678726d2cb4edb11c8b3a (patch)
treef76cf73738da7bd00eaa616fe61e9071392bcce8
php-pecl-vips: 1.0.0 (New package)
-rw-r--r--Makefile4
-rw-r--r--REFLECTION109
-rw-r--r--php-pecl-vips.spec211
3 files changed, 324 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..b55c05e
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,109 @@
+Extension [ <persistent> extension #135 vips version 1.0.0 ] {
+
+ - Functions {
+ Function [ <internal:vips> function vips_image_new_from_file ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $filename ]
+ Parameter #1 [ <required> $options ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_new_from_buffer ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $buffer ]
+ Parameter #1 [ <required> $option_string ]
+ Parameter #2 [ <required> $options ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_new_from_array ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $array ]
+ Parameter #1 [ <required> $scale ]
+ Parameter #2 [ <required> $offset ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_write_to_file ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $image ]
+ Parameter #1 [ <required> $filename ]
+ Parameter #2 [ <required> $options ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_write_to_buffer ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $image ]
+ Parameter #1 [ <required> $options ]
+ }
+ }
+ Function [ <internal:vips> function vips_call ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $operation_name ]
+ Parameter #1 [ <required> $instance ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_get ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $image ]
+ Parameter #1 [ <required> $field ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_get_typeof ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $image ]
+ Parameter #1 [ <required> $field ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_set ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $image ]
+ Parameter #1 [ <required> $field ]
+ Parameter #2 [ <required> $value ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_remove ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $image ]
+ Parameter #1 [ <required> $field ]
+ }
+ }
+ Function [ <internal:vips> function vips_error_buffer ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:vips> function vips_cache_set_max ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+ Function [ <internal:vips> function vips_cache_set_max_mem ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+ Function [ <internal:vips> function vips_cache_set_max_files ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+ Function [ <internal:vips> function vips_concurrency_set ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-vips.spec b/php-pecl-vips.spec
new file mode 100644
index 0000000..a4e6e4f
--- /dev/null
+++ b/php-pecl-vips.spec
@@ -0,0 +1,211 @@
+# remirepo spec file for php-pecl-vips
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-vips
+%endif
+
+%global pecl_name vips
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+#global prever RC9
+
+Summary: PHP extension for interfacing with libvips
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 1.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+
+BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: pkgconfig(vips) >= 8.3
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter private shared object
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This extension uses libvips to provide image processing facilities.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version}%{?prever} NTS
+
+# Don't register test files on install
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+# Sanity check, really often broken
+extver=$(sed -n '/define PHP_VIPS_VERSION/{s/.* "//;s/".*$//;p}' php_vips.h)
+if test "x${extver}" != "x%{version}%{?prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-vips \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-vips \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Test & Documentation
+cd NTS
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+: Minimal load test for NTS extension
+cd NTS
+%{_bindir}/php --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php --show-diff
+
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+cd ../ZTS
+
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE.txt}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Thu Nov 24 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package, version 1.0.0 (php 7, stable)
+