summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-28 07:05:07 +0200
committerRemi Collet <remi@remirepo.net>2020-08-28 07:05:07 +0200
commit1700ca65d8ea6db2e6b4fd46b808e4e123cfd466 (patch)
tree1be34b7e2d56b517007577101b5b7b88a7564f27
parentb05198df80db11e98b5be18d80bdf8883115fa90 (diff)
update to 1.0.11
-rw-r--r--PHPINFO13
-rw-r--r--REFLECTION17
-rw-r--r--php-pecl-vips.spec15
3 files changed, 33 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 42287e9..5c2776b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,16 +2,19 @@
vips
vips property => value
-Vips headers version => 8.9.0
-Vips library version => 8.9.0
-Vips ABI version => 54.0.12
+Vips headers version => 8.10.0
+Vips library version => 8.10.0
+Vips ABI version => 54.3.12
Major version => 8
-Minor version => 9
+Minor version => 10
Micro version => 0
Cache max mem => 104857600
-Cache max operations => 1000
+Cache max operations => 100
Cache current operations => 0
Cache max open files => 100
+Memory allocations => 0
+Memory currently allocated => 0
+Memory high water => 0
Concurrency => 16
SIMD support with liborc => no
JPEG support => yes
diff --git a/REFLECTION b/REFLECTION
index 44246c7..a604290 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 vips version 1.0.10 ] {
+Extension [ <persistent> extension #116 vips version 1.0.11 ] {
- Functions {
Function [ <internal:vips> function vips_image_new_from_file ] {
@@ -114,6 +114,21 @@ Extension [ <persistent> extension #108 vips version 1.0.10 ] {
Parameter #2 [ <required> $value ]
}
}
+ Function [ <internal:vips> function vips_type_from_name ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+ Function [ <internal:vips> function vips_image_set_type ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $image ]
+ Parameter #1 [ <required> $type ]
+ Parameter #2 [ <required> $field ]
+ Parameter #3 [ <required> $value ]
+ }
+ }
Function [ <internal:vips> function vips_image_remove ] {
- Parameters [2] {
diff --git a/php-pecl-vips.spec b/php-pecl-vips.spec
index 0d0c19c..d49e632 100644
--- a/php-pecl-vips.spec
+++ b/php-pecl-vips.spec
@@ -21,8 +21,8 @@
Summary: PHP extension for interfacing with libvips
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.10
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.0.11
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
@@ -48,19 +48,19 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -225,6 +225,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Aug 28 2020 Remi Collet <remi@remirepo.net> - 1.0.11-1
+- update to 1.0.11
+
* Wed Jan 8 2020 Remi Collet <remi@remirepo.net> - 1.0.10-2
- rebuild with libvips 8.9.0