summaryrefslogtreecommitdiffstats
path: root/php-pecl-varnish.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-varnish.spec')
-rw-r--r--php-pecl-varnish.spec120
1 files changed, 47 insertions, 73 deletions
diff --git a/php-pecl-varnish.spec b/php-pecl-varnish.spec
index 9bfc197..b74f88f 100644
--- a/php-pecl-varnish.spec
+++ b/php-pecl-varnish.spec
@@ -1,17 +1,15 @@
# remirepo spec file for php-pecl-varnish
#
-# Copyright (c) 2013-2018 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2013-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%bcond_with tests
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-varnish
%else
%global _root_sbindir %{_sbindir}
@@ -19,28 +17,32 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name varnish
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
%global ini_name 40-%{pecl_name}.ini
%endif
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Varnish Cache bindings
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.4
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.2.6
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: BSD-2-Clause
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+Patch0: %{pecl_name}-up.patch
BuildRequires: %{?dtsprefix}gcc
+BuildRequires: make
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: varnish-libs-devel > 3
# For tests
-%if %{with_tests}
+%if %{with tests}
BuildRequires: varnish
%endif
@@ -52,40 +54,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
%description
@@ -99,14 +67,15 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
+cd %{sources}
+%patch -P0 -p3
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_VARNISH_VERSION/{s/.* "//;s/".*$//;p}' php_varnish.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -115,9 +84,9 @@ if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -130,19 +99,20 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -165,7 +135,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -204,8 +174,8 @@ ret=0
--modules | grep %{pecl_name}
%endif
-%if %{with_tests}
-cd NTS
+%if %{with tests}
+cd %{sources}
: Run a varnish server for test suite
sed -n '/secret/{s/.* "//;s/".*$//;p}' \
@@ -239,25 +209,16 @@ sed -e 's:/var/lib/varnish/silent:/tmp/vtest:' \
tests/config.php-dist | tee tests/config.php
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
+TEST_PHP_ARGS="-n -d extension=$PWD/../NTS/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff || ret=1
+%{__php} -n run-tests.php -q --show-diff || ret=1
%if %{with_zts}
-cd ../ZTS
-
: Upstream test suite for ZTS extension
-sed -e 's:/var/lib/varnish/silent:/tmp/vtest:' \
- -e "s/6081/$PORTUSR/" \
- -e "s/6082/$PORTADM/" \
- tests/config.php-dist | tee tests/config.php
-
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
+TEST_PHP_ARGS="-n -d extension=$PWD/../ZTS/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff || ret=1
+%{__ztsphp} -n run-tests.php -q --show-diff || ret=1
%endif
: Stop the test server
@@ -272,7 +233,7 @@ exit $ret
%files
%doc %{pecl_docdir}/%{pecl_name}
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -285,6 +246,19 @@ exit $ret
%changelog
+* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 1.2.6-2
+- build out of sources tree
+
+* Mon Jan 18 2021 Remi Collet <remi@remirepo.net> - 1.2.6-1
+- update to 1.2.6
+- drop patch merged upstream
+
+* Mon Aug 24 2020 Remi Collet <remi@remirepo.net> - 1.2.4-5
+- add upstream patch for PHP 8
+
+* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.2.4-4
+- rebuild for 7.4.0RC1
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.2.4-3
- rebuild for 7.3.0beta2 new ABI