summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-varnish.spec11
-rw-r--r--varnish-upstream.patch101
3 files changed, 5 insertions, 109 deletions
diff --git a/REFLECTION b/REFLECTION
index 12e4a2c..c6c9f56 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #153 varnish version 1.2.0 ] {
+Extension [ <persistent> extension #153 varnish version 1.2.1 ] {
- Dependencies {
Dependency [ hash (Required) ]
diff --git a/php-pecl-varnish.spec b/php-pecl-varnish.spec
index d0f00da..9507bad 100644
--- a/php-pecl-varnish.spec
+++ b/php-pecl-varnish.spec
@@ -22,18 +22,13 @@
Summary: Varnish Cache bindings
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.2.0
+Version: 1.2.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# http://svn.php.net/viewvc?view=revision&revision=335941
-# http://svn.php.net/viewvc?view=revision&revision=335942
-# http://svn.php.net/viewvc?view=revision&revision=335943
-Patch0: %{pecl_name}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
@@ -91,7 +86,6 @@ mv %{pecl_name}-%{version} NTS
sed -e 's/role="test"/role="src"/' -i package.xml
cd NTS
-%patch0 -p3 -b .upstream
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_VARNISH_VERSION/{s/.* "//;s/".*$//;p}' php_varnish.h)
@@ -275,6 +269,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Feb 14 2015 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
+- Update to 1.2.1
+
* Sat Feb 14 2015 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
- Update to 1.2.0
- don't install test suite
diff --git a/varnish-upstream.patch b/varnish-upstream.patch
deleted file mode 100644
index e146a54..0000000
--- a/varnish-upstream.patch
+++ /dev/null
@@ -1,101 +0,0 @@
---- pecl/varnish/trunk/varnish_lib.c 2015/02/13 21:33:27 335940
-+++ pecl/varnish/trunk/varnish_lib.c 2015/02/14 09:42:22 335941
-@@ -812,6 +812,13 @@
- return 0;
- }/*}}}*/
-
-+#if HAVE_VARNISHAPILIB >= 4
-+int
-+php_varnish_snap_stats(zval *storage, const char *ident TSRMLS_DC)
-+{/*{{{*/
-+ return 0;
-+}/*}}}*/
-+#else
- int
- php_varnish_snap_stats(zval *storage, const char *ident TSRMLS_DC)
- {/*{{{*/
-@@ -832,25 +839,21 @@
- return 0;
- }
-
--#if HAVE_VARNISHAPILIB >= 4
-- /* XXX use VSM_fantom */
-- vcm = VSC_Main(vd, NULL);
--
-- return !VSC_Iter(vd, NULL, php_varnish_snap_stats_cb, storage);
--#else
- vcm = VSC_Main(vd);
-
- return !VSC_Iter(vd, php_varnish_snap_stats_cb, storage);
--#endif
- }/*}}}*/
-+#endif
-
--#if HAVE_VARNISHAPILIB >=4
-+#if HAVE_VARNISHAPILIB >= 4
- int
--php_varnish_get_log(const struct VSL_data *vd, zval *line TSRMLS_DC)
-+php_varnish_get_log(const struct VSM_data *vd, zval *line TSRMLS_DC)
-+{/*{{{*/
-+ return 0;
-+}/*}}}*/
- #else
- int
- php_varnish_get_log(const struct VSM_data *vd, zval *line TSRMLS_DC)
--#endif
- {/*{{{*/
- uint32_t *p;
- int i;
-@@ -880,6 +883,7 @@
-
- }/*}}}*/
- #endif
-+#endif
-
- int
- php_varnish_is_running(int sock, int *status, int tmo TSRMLS_DC)
---- pecl/varnish/trunk/varnish_lib.h 2015/02/13 21:33:27 335940
-+++ pecl/varnish/trunk/varnish_lib.h 2015/02/14 09:42:22 335941
-@@ -96,13 +96,8 @@
- php_varnish_clear_panic(int sock, int *status, int tmo TSRMLS_DC);
-
- #ifndef PHP_WIN32
--#if HAVE_VARNISHAPILIB >=4
--int
--php_varnish_get_log(const struct VSL_data *vd, zval *line TSRMLS_DC);
--#else
- int
- php_varnish_get_log(const struct VSM_data *vd, zval *line TSRMLS_DC);
--#endif
-
- void
- php_varnish_log_get_tag_name(int index, char **ret, int *ret_len TSRMLS_DC);
---- pecl/varnish/trunk/varnish_lib.c 2015/02/14 09:42:22 335941
-+++ pecl/varnish/trunk/varnish_lib.c 2015/02/14 10:05:43 335942
-@@ -777,6 +777,7 @@
- }/*}}}*/
-
- #ifndef PHP_WIN32
-+#if HAVE_VARNISHAPILIB < 4
- static int
- php_varnish_snap_stats_cb(void *priv, const struct VSC_point const *pt)
- {/*{{{*/
-@@ -811,6 +812,7 @@
-
- return 0;
- }/*}}}*/
-+#endif
-
- #if HAVE_VARNISHAPILIB >= 4
- int
---- pecl/varnish/trunk/varnish_lib.c 2015/02/14 10:05:43 335942
-+++ pecl/varnish/trunk/varnish_lib.c 2015/02/14 10:15:29 335943
-@@ -350,8 +350,6 @@
- char *t_arg, *t_start, *p, tmp_addr[41];
- #if HAVE_VARNISHAPILIB >= 4
- struct VSM_fantom vt;
--#else
-- char *p;
- #endif
-
- vsd = VSM_New();