summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-05 06:17:49 +0100
committerRemi Collet <remi@remirepo.net>2018-03-05 06:17:49 +0100
commit07f45bf4766b72af934a8ba7494dfd93e9a51ecc (patch)
treea0ed6379c3734b645952f8cef772b065bc865c02
parenta1a5a097b5cc455d8b1fcca006bc5e1d591b7ebd (diff)
v1.2.3
-rw-r--r--REFLECTION185
-rw-r--r--php-pecl-varnish.spec49
2 files changed, 111 insertions, 123 deletions
diff --git a/REFLECTION b/REFLECTION
index 32bb819..76e5e49 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #130 varnish version 1.2.2 ] {
+Extension [ <persistent> extension #160 varnish version 1.2.3 ] {
- Dependencies {
Dependency [ hash (Required) ]
@@ -129,97 +129,98 @@ Extension [ <persistent> extension #130 varnish version 1.2.2 ] {
Class [ <internal:varnish> class VarnishLog ] {
- - Constants [90] {
- Constant [ integer TAG_Debug ] { 1 }
- Constant [ integer TAG_Error ] { 2 }
- Constant [ integer TAG_CLI ] { 3 }
- Constant [ integer TAG_SessOpen ] { 4 }
- Constant [ integer TAG_SessClose ] { 5 }
- Constant [ integer TAG_BackendOpen ] { 6 }
- Constant [ integer TAG_BackendReuse ] { 7 }
- Constant [ integer TAG_BackendClose ] { 8 }
- Constant [ integer TAG_HttpGarbage ] { 9 }
- Constant [ integer TAG_Proxy ] { 10 }
- Constant [ integer TAG_ProxyGarbage ] { 11 }
- Constant [ integer TAG_Backend ] { 12 }
- Constant [ integer TAG_Length ] { 13 }
- Constant [ integer TAG_FetchError ] { 14 }
- Constant [ integer TAG_ReqMethod ] { 15 }
- Constant [ integer TAG_ReqURL ] { 16 }
- Constant [ integer TAG_ReqProtocol ] { 17 }
- Constant [ integer TAG_ReqStatus ] { 18 }
- Constant [ integer TAG_ReqReason ] { 19 }
- Constant [ integer TAG_ReqHeader ] { 20 }
- Constant [ integer TAG_ReqUnset ] { 21 }
- Constant [ integer TAG_ReqLost ] { 22 }
- Constant [ integer TAG_RespMethod ] { 23 }
- Constant [ integer TAG_RespURL ] { 24 }
- Constant [ integer TAG_RespProtocol ] { 25 }
- Constant [ integer TAG_RespStatus ] { 26 }
- Constant [ integer TAG_RespReason ] { 27 }
- Constant [ integer TAG_RespHeader ] { 28 }
- Constant [ integer TAG_RespUnset ] { 29 }
- Constant [ integer TAG_RespLost ] { 30 }
- Constant [ integer TAG_BereqMethod ] { 31 }
- Constant [ integer TAG_BereqURL ] { 32 }
- Constant [ integer TAG_BereqProtocol ] { 33 }
- Constant [ integer TAG_BereqStatus ] { 34 }
- Constant [ integer TAG_BereqReason ] { 35 }
- Constant [ integer TAG_BereqHeader ] { 36 }
- Constant [ integer TAG_BereqUnset ] { 37 }
- Constant [ integer TAG_BereqLost ] { 38 }
- Constant [ integer TAG_BerespMethod ] { 39 }
- Constant [ integer TAG_BerespURL ] { 40 }
- Constant [ integer TAG_BerespProtocol ] { 41 }
- Constant [ integer TAG_BerespStatus ] { 42 }
- Constant [ integer TAG_BerespReason ] { 43 }
- Constant [ integer TAG_BerespHeader ] { 44 }
- Constant [ integer TAG_BerespUnset ] { 45 }
- Constant [ integer TAG_BerespLost ] { 46 }
- Constant [ integer TAG_ObjMethod ] { 47 }
- Constant [ integer TAG_ObjURL ] { 48 }
- Constant [ integer TAG_ObjProtocol ] { 49 }
- Constant [ integer TAG_ObjStatus ] { 50 }
- Constant [ integer TAG_ObjReason ] { 51 }
- Constant [ integer TAG_ObjHeader ] { 52 }
- Constant [ integer TAG_ObjUnset ] { 53 }
- Constant [ integer TAG_ObjLost ] { 54 }
- Constant [ integer TAG_BogoHeader ] { 55 }
- Constant [ integer TAG_LostHeader ] { 56 }
- Constant [ integer TAG_TTL ] { 57 }
- Constant [ integer TAG_Fetch_Body ] { 58 }
- Constant [ integer TAG_VCL_acl ] { 59 }
- Constant [ integer TAG_VCL_call ] { 60 }
- Constant [ integer TAG_VCL_trace ] { 61 }
- Constant [ integer TAG_VCL_return ] { 62 }
- Constant [ integer TAG_ReqStart ] { 63 }
- Constant [ integer TAG_Hit ] { 64 }
- Constant [ integer TAG_HitPass ] { 65 }
- Constant [ integer TAG_ExpBan ] { 66 }
- Constant [ integer TAG_ExpKill ] { 67 }
- Constant [ integer TAG_WorkThread ] { 68 }
- Constant [ integer TAG_ESI_xmlerror ] { 69 }
- Constant [ integer TAG_Hash ] { 70 }
- Constant [ integer TAG_Backend_health ] { 71 }
- Constant [ integer TAG_VCL_Log ] { 72 }
- Constant [ integer TAG_VCL_Error ] { 73 }
- Constant [ integer TAG_Gzip ] { 74 }
- Constant [ integer TAG_Link ] { 75 }
- Constant [ integer TAG_Begin ] { 76 }
- Constant [ integer TAG_End ] { 77 }
- Constant [ integer TAG_VSL ] { 78 }
- Constant [ integer TAG_Storage ] { 79 }
- Constant [ integer TAG_Timestamp ] { 80 }
- Constant [ integer TAG_ReqAcct ] { 81 }
- Constant [ integer TAG_PipeAcct ] { 82 }
- Constant [ integer TAG_BereqAcct ] { 83 }
- Constant [ integer TAG_VfpAcct ] { 84 }
- Constant [ integer TAG_Witness ] { 85 }
- Constant [ integer TAG_BackendStart ] { 86 }
- Constant [ integer TAG_H2RxHdr ] { 87 }
- Constant [ integer TAG_H2RxBody ] { 88 }
- Constant [ integer TAG_H2TxHdr ] { 89 }
- Constant [ integer TAG_H2TxBody ] { 90 }
+ - Constants [91] {
+ Constant [ public integer TAG_Debug ] { 1 }
+ Constant [ public integer TAG_Error ] { 2 }
+ Constant [ public integer TAG_CLI ] { 3 }
+ Constant [ public integer TAG_SessOpen ] { 4 }
+ Constant [ public integer TAG_SessClose ] { 5 }
+ Constant [ public integer TAG_BackendOpen ] { 6 }
+ Constant [ public integer TAG_BackendReuse ] { 7 }
+ Constant [ public integer TAG_BackendClose ] { 8 }
+ Constant [ public integer TAG_HttpGarbage ] { 9 }
+ Constant [ public integer TAG_Proxy ] { 10 }
+ Constant [ public integer TAG_ProxyGarbage ] { 11 }
+ Constant [ public integer TAG_Backend ] { 12 }
+ Constant [ public integer TAG_Length ] { 13 }
+ Constant [ public integer TAG_FetchError ] { 14 }
+ Constant [ public integer TAG_ReqMethod ] { 15 }
+ Constant [ public integer TAG_ReqURL ] { 16 }
+ Constant [ public integer TAG_ReqProtocol ] { 17 }
+ Constant [ public integer TAG_ReqStatus ] { 18 }
+ Constant [ public integer TAG_ReqReason ] { 19 }
+ Constant [ public integer TAG_ReqHeader ] { 20 }
+ Constant [ public integer TAG_ReqUnset ] { 21 }
+ Constant [ public integer TAG_ReqLost ] { 22 }
+ Constant [ public integer TAG_RespMethod ] { 23 }
+ Constant [ public integer TAG_RespURL ] { 24 }
+ Constant [ public integer TAG_RespProtocol ] { 25 }
+ Constant [ public integer TAG_RespStatus ] { 26 }
+ Constant [ public integer TAG_RespReason ] { 27 }
+ Constant [ public integer TAG_RespHeader ] { 28 }
+ Constant [ public integer TAG_RespUnset ] { 29 }
+ Constant [ public integer TAG_RespLost ] { 30 }
+ Constant [ public integer TAG_BereqMethod ] { 31 }
+ Constant [ public integer TAG_BereqURL ] { 32 }
+ Constant [ public integer TAG_BereqProtocol ] { 33 }
+ Constant [ public integer TAG_BereqStatus ] { 34 }
+ Constant [ public integer TAG_BereqReason ] { 35 }
+ Constant [ public integer TAG_BereqHeader ] { 36 }
+ Constant [ public integer TAG_BereqUnset ] { 37 }
+ Constant [ public integer TAG_BereqLost ] { 38 }
+ Constant [ public integer TAG_BerespMethod ] { 39 }
+ Constant [ public integer TAG_BerespURL ] { 40 }
+ Constant [ public integer TAG_BerespProtocol ] { 41 }
+ Constant [ public integer TAG_BerespStatus ] { 42 }
+ Constant [ public integer TAG_BerespReason ] { 43 }
+ Constant [ public integer TAG_BerespHeader ] { 44 }
+ Constant [ public integer TAG_BerespUnset ] { 45 }
+ Constant [ public integer TAG_BerespLost ] { 46 }
+ Constant [ public integer TAG_ObjMethod ] { 47 }
+ Constant [ public integer TAG_ObjURL ] { 48 }
+ Constant [ public integer TAG_ObjProtocol ] { 49 }
+ Constant [ public integer TAG_ObjStatus ] { 50 }
+ Constant [ public integer TAG_ObjReason ] { 51 }
+ Constant [ public integer TAG_ObjHeader ] { 52 }
+ Constant [ public integer TAG_ObjUnset ] { 53 }
+ Constant [ public integer TAG_ObjLost ] { 54 }
+ Constant [ public integer TAG_BogoHeader ] { 55 }
+ Constant [ public integer TAG_LostHeader ] { 56 }
+ Constant [ public integer TAG_TTL ] { 57 }
+ Constant [ public integer TAG_Fetch_Body ] { 58 }
+ Constant [ public integer TAG_VCL_acl ] { 59 }
+ Constant [ public integer TAG_VCL_call ] { 60 }
+ Constant [ public integer TAG_VCL_trace ] { 61 }
+ Constant [ public integer TAG_VCL_return ] { 62 }
+ Constant [ public integer TAG_ReqStart ] { 63 }
+ Constant [ public integer TAG_Hit ] { 64 }
+ Constant [ public integer TAG_HitPass ] { 65 }
+ Constant [ public integer TAG_ExpBan ] { 66 }
+ Constant [ public integer TAG_ExpKill ] { 67 }
+ Constant [ public integer TAG_WorkThread ] { 68 }
+ Constant [ public integer TAG_ESI_xmlerror ] { 69 }
+ Constant [ public integer TAG_Hash ] { 70 }
+ Constant [ public integer TAG_Backend_health ] { 71 }
+ Constant [ public integer TAG_VCL_Log ] { 72 }
+ Constant [ public integer TAG_VCL_Error ] { 73 }
+ Constant [ public integer TAG_Gzip ] { 74 }
+ Constant [ public integer TAG_Link ] { 75 }
+ Constant [ public integer TAG_Begin ] { 76 }
+ Constant [ public integer TAG_End ] { 77 }
+ Constant [ public integer TAG_VSL ] { 78 }
+ Constant [ public integer TAG_Storage ] { 79 }
+ Constant [ public integer TAG_Timestamp ] { 80 }
+ Constant [ public integer TAG_ReqAcct ] { 81 }
+ Constant [ public integer TAG_PipeAcct ] { 82 }
+ Constant [ public integer TAG_BereqAcct ] { 83 }
+ Constant [ public integer TAG_VfpAcct ] { 84 }
+ Constant [ public integer TAG_Witness ] { 85 }
+ Constant [ public integer TAG_BackendStart ] { 86 }
+ Constant [ public integer TAG_H2RxHdr ] { 87 }
+ Constant [ public integer TAG_H2RxBody ] { 88 }
+ Constant [ public integer TAG_H2TxHdr ] { 89 }
+ Constant [ public integer TAG_H2TxBody ] { 90 }
+ Constant [ public integer TAG_HitMiss ] { 91 }
}
- Static properties [0] {
diff --git a/php-pecl-varnish.spec b/php-pecl-varnish.spec
index 65b621c..a436ca7 100644
--- a/php-pecl-varnish.spec
+++ b/php-pecl-varnish.spec
@@ -1,20 +1,19 @@
# remirepo spec file for php-pecl-varnish
#
-# Copyright (c) 2013-2017 Remi Collet
+# Copyright (c) 2013-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-varnish
%endif
-%endif
-
-%{?scl: %scl_package php-pecl-varnish}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name varnish
@@ -27,14 +26,13 @@
Summary: Varnish Cache bindings
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.2
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 5.3
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-hash
@@ -59,14 +57,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
@@ -133,6 +123,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -151,10 +143,8 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
-make -C NTS \
- install INSTALL_ROOT=%{buildroot}
+%{?dtsenable}
+make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -163,8 +153,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS \
- install INSTALL_ROOT=%{buildroot}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -175,7 +164,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -276,12 +265,7 @@ exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{?_licensedir:%license NTS/LICENSE}
%{pecl_xmldir}/%{name}.xml
@@ -296,6 +280,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Mar 5 2018 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- Update to 1.2.3
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.2.2-3
- rebuild for PHP 7.2.0beta1 new API