summaryrefslogtreecommitdiffstats
path: root/php-pecl-var-representation.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-10-17 15:30:16 +0200
committerRemi Collet <remi@php.net>2024-10-17 15:30:16 +0200
commit8c1babadae4c4f1821741d7dd474d93ceba62eaa (patch)
treed3b477b744367b50af71258d135b450f604d92af /php-pecl-var-representation.spec
parent1d52345dac1fa7602de20c444d6ed8be5d74c495 (diff)
modernizeHEADmaster
Diffstat (limited to 'php-pecl-var-representation.spec')
-rw-r--r--php-pecl-var-representation.spec11
1 files changed, 7 insertions, 4 deletions
diff --git a/php-pecl-var-representation.spec b/php-pecl-var-representation.spec
index c0ffce4..05566e4 100644
--- a/php-pecl-var-representation.spec
+++ b/php-pecl-var-representation.spec
@@ -95,15 +95,18 @@ peclconf() {
cd %{sources}
%{__phpize}
+# Test need for PHP < 7.4
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
peclconf %{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
peclconf %{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
@@ -111,7 +114,7 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
@@ -119,7 +122,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
# Install the ZTS stuff
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif