summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-v8js.spec16
-rw-r--r--v8js-pr266.patch41
3 files changed, 10 insertions, 49 deletions
diff --git a/REFLECTION b/REFLECTION
index 5132b42..c51cc8d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #138 v8js version 1.3.3 ] {
+Extension [ <persistent> extension #144 v8js version 1.3.4 ] {
- INI {
Entry [ v8js.flags <ALL> ]
diff --git a/php-pecl-v8js.spec b/php-pecl-v8js.spec
index ef41c59..561ee04 100644
--- a/php-pecl-v8js.spec
+++ b/php-pecl-v8js.spec
@@ -17,16 +17,13 @@
Summary: V8 Javascript Engine for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.3
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.3.4
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/phpv8/v8js/pull/266
-Patch0: %{pecl_name}-pr266.patch
-
# See http://pkgs.fedoraproject.org/cgit/rpms/v8.git/tree/v8.spec#n49
# arm is excluded because of bz1334406
ExclusiveArch: %{ix86} x86_64 ppc ppc64 aarch64 %{mips} s390 s390x
@@ -83,8 +80,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr266
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_V8JS_VERSION/{s/.* "//;s/".*$//;p}' php_v8js_macros.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -116,6 +111,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -136,6 +133,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
@@ -235,6 +234,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Mar 6 2017 Remi Collet <remi@remirepo.net> - 1.3.4-1
+- Update to 1.3.4
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.3.3-2
- rebuild with PHP 7.1.0 GA
diff --git a/v8js-pr266.patch b/v8js-pr266.patch
deleted file mode 100644
index a1a1394..0000000
--- a/v8js-pr266.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 2b9d37672c4e2d065b996bb80f3086018d639115 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 29 Sep 2016 16:05:46 +0200
-Subject: [PATCH] honours --with-libdir option, instead of harcoding lib or
- lib64
-
----
- config.m4 | 13 ++++---------
- 1 file changed, 4 insertions(+), 9 deletions(-)
-
-diff --git a/config.m4 b/config.m4
-index 3c92535..390c829 100644
---- a/config.m4
-+++ b/config.m4
-@@ -137,14 +137,9 @@ int main ()
- AC_MSG_CHECKING([for $static_link_extra_file])
- static_link_dir=""
-
-- if test -r $V8_DIR/lib64/$static_link_extra_file; then
-- static_link_dir=$V8_DIR/lib64
-- AC_MSG_RESULT(found in $V8_DIR/lib64)
-- fi
--
-- if test -r $V8_DIR/lib/$static_link_extra_file; then
-- static_link_dir=$V8_DIR/lib
-- AC_MSG_RESULT(found in $V8_DIR/lib)
-+ if test -r $V8_DIR/$PHP_LIBDIR/$static_link_extra_file; then
-+ static_link_dir=$V8_DIR/$PHP_LIBDIR
-+ AC_MSG_RESULT(found in $V8_DIR/$PHP_LIBDIR)
- fi
-
- if test -z "$static_link_dir"; then
-@@ -196,7 +191,7 @@ public:
- AC_MSG_RESULT([yes])
- AC_DEFINE([PHP_V8_USE_EXTERNAL_STARTUP_DATA], [1], [Whether V8 requires (and can be provided with custom versions of) external startup data])
-
-- SEARCH_PATH="$V8_DIR/lib $V8_DIR/share/v8"
-+ SEARCH_PATH="$V8_DIR/$PHP_LIBDIR $V8_DIR/share/v8"
-
- AC_MSG_CHECKING([for natives_blob.bin])
- SEARCH_FOR="natives_blob.bin"