summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-v8.spec9
-rw-r--r--v8-hack.patch39
2 files changed, 6 insertions, 42 deletions
diff --git a/php-pecl-v8.spec b/php-pecl-v8.spec
index ffb9689..23fd08e 100644
--- a/php-pecl-v8.spec
+++ b/php-pecl-v8.spec
@@ -20,7 +20,7 @@
Summary: V8 JavaScript engine API for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.2.2
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -33,10 +33,8 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
-# because of https://bugzilla.redhat.com/1378889
# upstream minimal 6.6.313
-BuildRequires: nodejs-devel
-BuildRequires: nodejs(v8-abi) >= 6.6
+BuildRequires: v8-devel >= 6.6.313
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -243,6 +241,9 @@ TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
%changelog
+* Wed Apr 24 2019 Remi Collet <remi@remirepo.net> - 2.1.0-5
+- switch back to v8-devel using compatibility package from nodejs
+
* Wed Apr 24 2019 Remi Collet <remi@remirepo.net> - 0.2.2-1
- initial package, version 0.2.2 (stable)
- add hack to switch from v8-devel to nodejs-devel
diff --git a/v8-hack.patch b/v8-hack.patch
index 49f4563..2426696 100644
--- a/v8-hack.patch
+++ b/v8-hack.patch
@@ -1,33 +1,6 @@
diff -up ./config.m4.hack ./config.m4
--- ./config.m4.hack 2019-04-24 12:16:06.018817259 +0200
+++ ./config.m4 2019-04-24 13:05:48.244406629 +0200
-@@ -17,7 +17,7 @@ if test "$PHP_V8" != "no"; then
- V8_INCLUDE_DIR=""
-
- SEARCH_PATH="/usr/local /usr"
-- SEARCH_FOR="include/v8.h"
-+ SEARCH_FOR="include/node/v8.h"
-
- V8_MIN_API_VERSION_STR=6.6.313
-
-@@ -25,7 +25,7 @@ if test "$PHP_V8" != "no"; then
-
- # Path where v8 from packages we recommend are installed, it's /opt/libv8-MAJOR.MINOR on Ubuntu
- # and /usr/local/opt/v8@MAJOR.MINOR on macOS. For Docker image it's just /opt/libv8
-- PRIORITY_SEARCH_PATH="/opt/libv8-${DESIRED_V8_VERSION} /usr/local/opt/v8@${DESIRED_V8_VERSION} /opt/libv8"
-+ PRIORITY_SEARCH_PATH="/opt/libv8-${DESIRED_V8_VERSION} /usr/local/opt/v8@${DESIRED_V8_VERSION} /opt/libv8 /usr"
- SEARCH_PATH="${PRIORITY_SEARCH_PATH} ${SEARCH_PATH}"
-
- if test -r $PHP_V8/$SEARCH_FOR; then
-@@ -47,7 +47,7 @@ if test "$PHP_V8" != "no"; then
- fi
-
- V8_LIB_DIR=$V8_ROOT_DIR/$PHP_LIBDIR
-- V8_INCLUDE_DIR=$V8_ROOT_DIR/include
-+ V8_INCLUDE_DIR=$V8_ROOT_DIR/include/node
-
- AC_MSG_CHECKING([for ICU data file icudtl.dat])
-
@@ -63,16 +63,6 @@ if test "$PHP_V8" != "no"; then
AC_DEFINE_UNQUOTED([PHP_V8_ICU_DATA_DIR], ["$PHP_V8_ICU_DATA_DIR"], [ICU data path (trailing slash is required)])
@@ -45,14 +18,4 @@ diff -up ./config.m4.hack ./config.m4
AC_CACHE_CHECK(for V8 version, ac_cv_v8_version, [
if test -z "$V8_INCLUDE_DIR/v8-version.h"; then
AC_MSG_RESULT([not found])
-@@ -110,9 +100,7 @@ if test "$PHP_V8" != "no"; then
- PHP_ADD_INCLUDE($V8_DIR)
- PHP_ADD_INCLUDE($V8_INCLUDE_DIR)
-
-- PHP_ADD_LIBRARY_WITH_PATH(v8, $V8_LIB_DIR, V8_SHARED_LIBADD)
-- PHP_ADD_LIBRARY_WITH_PATH(v8_libbase, $V8_LIB_DIR, V8_SHARED_LIBADD)
-- PHP_ADD_LIBRARY_WITH_PATH(v8_libplatform, $V8_LIB_DIR, V8_SHARED_LIBADD)
-+ PHP_ADD_LIBRARY_WITH_PATH(node, $V8_LIB_DIR, V8_SHARED_LIBADD)
-
- PHP_SUBST(V8_SHARED_LIBADD)
- PHP_REQUIRE_CXX()
+