summaryrefslogtreecommitdiffstats
path: root/php-pecl-uv.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-19 08:00:13 +0200
committerRemi Collet <remi@php.net>2023-06-19 08:00:13 +0200
commit828942d16b12806ca5ec8d5ab4e7c3e90497ed15 (patch)
tree56d3b556a466e1e0c853c0b8cc98a111f39f7501 /php-pecl-uv.spec
parent6f753329e9b933c43c21a5ff55186e64acea8e97 (diff)
update to 0.3.0
raise dependency on PHP 8 open https://github.com/bwoebi/php-uv/issues/108 1 test failing
Diffstat (limited to 'php-pecl-uv.spec')
-rw-r--r--php-pecl-uv.spec73
1 files changed, 24 insertions, 49 deletions
diff --git a/php-pecl-uv.spec b/php-pecl-uv.spec
index 394fc83..3a5dca3 100644
--- a/php-pecl-uv.spec
+++ b/php-pecl-uv.spec
@@ -1,15 +1,14 @@
# remirepo spec file for php-pecl-uv
#
-# Copyright (c) 2016-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-uv
-%endif
+%{?scl:%scl_package php-pecl-uv}
+
+%bcond_without tests
%global pecl_name uv
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -17,16 +16,17 @@
#global prever RC9
Summary: Libuv wrapper
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.2.4
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.3.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP-3.01
Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: make
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pkgconfig(libuv) >= 1.0.0
# For tests
@@ -40,38 +40,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
%description
@@ -188,9 +156,8 @@ else
: only local tests when mock is used
export SKIP_ONLINE_TESTS=1
fi
-: see https://github.com/bwoebi/php-uv/issues/66
-#rm ?TS/tests/320-fs-poll.phpt
-#rm ?TS/tests/330-poll-pipe.phpt
+: see https://github.com/amphp/ext-uv/issues/108
+rm ?TS/tests/200-ares_getaddrinfo.phpt
: Minimal load test for NTS extension
cd NTS
@@ -198,13 +165,14 @@ cd NTS
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{_bindir}/php -n run-tests.php --show-diff
-
+%endif
%if %{with_zts}
: Minimal load test for ZTS extension
@@ -214,6 +182,7 @@ cd ../ZTS
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
@@ -221,6 +190,7 @@ NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
%endif
+%endif
%files
@@ -238,6 +208,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Jun 19 2023 Remi Collet <remi@remirepo.net> - 0.3.0-1
+- update to 0.3.0
+- raise dependency on PHP 8
+- open https://github.com/bwoebi/php-uv/issues/108 1 test failing
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.2.4-3
- rebuild for 7.4.0RC1