summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION23
-rw-r--r--php-pecl-uuid.spec7
3 files changed, 26 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index a3930cc..4e33e46 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
uuid
UUID extension => enabled
-Version => 1.0.5 (stable)
+Version => 1.1.0 (stable)
Released => 2019-11-28
Authors => Hartmut Holzgraefe, Remi Collet
diff --git a/REFLECTION b/REFLECTION
index ba49ab0..e0a7add 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,15 +1,18 @@
-Extension [ <persistent> extension #156 uuid version 1.0.5 ] {
+Extension [ <persistent> extension #156 uuid version 1.1.0 ] {
- - Constants [11] {
+ - Constants [14] {
Constant [ int UUID_VARIANT_NCS ] { 0 }
Constant [ int UUID_VARIANT_DCE ] { 1 }
Constant [ int UUID_VARIANT_MICROSOFT ] { 2 }
Constant [ int UUID_VARIANT_OTHER ] { 3 }
Constant [ int UUID_TYPE_DEFAULT ] { 0 }
- Constant [ int UUID_TYPE_TIME ] { 1 }
Constant [ int UUID_TYPE_DCE ] { 4 }
Constant [ int UUID_TYPE_NAME ] { 1 }
+ Constant [ int UUID_TYPE_TIME ] { 1 }
+ Constant [ int UUID_TYPE_SECURITY ] { 2 }
+ Constant [ int UUID_TYPE_MD5 ] { 3 }
Constant [ int UUID_TYPE_RANDOM ] { 4 }
+ Constant [ int UUID_TYPE_SHA1 ] { 5 }
Constant [ int UUID_TYPE_NULL ] { -1 }
Constant [ int UUID_TYPE_INVALID ] { -42 }
}
@@ -40,6 +43,20 @@ Extension [ <persistent> extension #156 uuid version 1.0.5 ] {
Parameter #0 [ <required> $uuid ]
}
}
+ Function [ <internal:uuid> function uuid_generate_md5 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $uuid_ns ]
+ Parameter #1 [ <required> $name ]
+ }
+ }
+ Function [ <internal:uuid> function uuid_generate_sha1 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $uuid_ns ]
+ Parameter #1 [ <required> $name ]
+ }
+ }
Function [ <internal:uuid> function uuid_type ] {
- Parameters [1] {
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
index ed4ee5f..d2e19ae 100644
--- a/php-pecl-uuid.spec
+++ b/php-pecl-uuid.spec
@@ -29,14 +29,14 @@
Summary: Universally Unique Identifier extension for PHP
Name: %{?sub_prefix}php-pecl-uuid
-Version: 1.0.5
+Version: 1.1.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: LGPLv2+
URL: http://pecl.php.net/package/uuid
Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libuuid-devel
@@ -219,6 +219,9 @@ fi
%changelog
+* Thu Nov 28 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Thu Nov 28 2019 Remi Collet <remi@remirepo.net> - 1.0.5-1
- update to 1.0.5