summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION7
-rw-r--r--php-pecl-uuid.spec24
3 files changed, 21 insertions, 14 deletions
diff --git a/PHPINFO b/PHPINFO
index 2313fee..fdbc958 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
uuid
UUID extension => enabled
-Version => 1.2.1 (stable)
-Released => 2024-10-08
+Version => 1.3.0 (stable)
+Released => 2025-05-12
Authors => Hartmut Holzgraefe, Remi Collet
diff --git a/REFLECTION b/REFLECTION
index 36bf9c0..1ee6d97 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #102 uuid version 1.2.1 ] {
+Extension [ <persistent> extension #115 uuid version 1.3.0 ] {
- - Constants [14] {
+ - Constants [17] {
Constant [ int UUID_VARIANT_NCS ] { 0 }
Constant [ int UUID_VARIANT_DCE ] { 1 }
Constant [ int UUID_VARIANT_MICROSOFT ] { 2 }
@@ -9,6 +9,9 @@ Extension [ <persistent> extension #102 uuid version 1.2.1 ] {
Constant [ int UUID_TYPE_DCE ] { 4 }
Constant [ int UUID_TYPE_NAME ] { 1 }
Constant [ int UUID_TYPE_TIME ] { 1 }
+ Constant [ int UUID_TYPE_TIME_V6 ] { 6 }
+ Constant [ int UUID_TYPE_TIME_V7 ] { 7 }
+ Constant [ int UUID_TYPE_VENDOR ] { 8 }
Constant [ int UUID_TYPE_SECURITY ] { 2 }
Constant [ int UUID_TYPE_MD5 ] { 3 }
Constant [ int UUID_TYPE_RANDOM ] { 4 }
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
index be88ac3..7f88453 100644
--- a/php-pecl-uuid.spec
+++ b/php-pecl-uuid.spec
@@ -3,9 +3,9 @@
#
# Fedora spec file for php-pecl-uuid
#
-# Copyright (c) 2012-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2012-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -14,6 +14,8 @@
%bcond_without tests
+%global pie_vend pecl
+%global pie_proj uuid
%global pecl_name uuid
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
@@ -23,7 +25,7 @@
Summary: Universally Unique Identifier extension for PHP
Name: %{?scl_prefix}php-pecl-uuid
-Version: 1.2.1
+Version: 1.3.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: LGPL-2.1-or-later
URL: https://pecl.php.net/package/uuid
@@ -41,12 +43,11 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
# both provides same extension, with different API
Conflicts: %{?scl_prefix}uuid-php
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pie(%{pie_vend}/%{pie_proj}) = %{version}
%description
@@ -172,6 +173,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon May 12 2025 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+
* Tue Oct 8 2024 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1