summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION23
-rw-r--r--php-pecl-uuid.spec72
4 files changed, 68 insertions, 33 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index a3930cc..fa74e96 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
uuid
UUID extension => enabled
-Version => 1.0.5 (stable)
-Released => 2019-11-28
+Version => 1.2.0 (stable)
+Released => 2020-10-06
Authors => Hartmut Holzgraefe, Remi Collet
diff --git a/REFLECTION b/REFLECTION
index ba49ab0..d6a04df 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,15 +1,18 @@
-Extension [ <persistent> extension #156 uuid version 1.0.5 ] {
+Extension [ <persistent> extension #102 uuid version 1.2.0 ] {
- - Constants [11] {
+ - Constants [14] {
Constant [ int UUID_VARIANT_NCS ] { 0 }
Constant [ int UUID_VARIANT_DCE ] { 1 }
Constant [ int UUID_VARIANT_MICROSOFT ] { 2 }
Constant [ int UUID_VARIANT_OTHER ] { 3 }
Constant [ int UUID_TYPE_DEFAULT ] { 0 }
- Constant [ int UUID_TYPE_TIME ] { 1 }
Constant [ int UUID_TYPE_DCE ] { 4 }
Constant [ int UUID_TYPE_NAME ] { 1 }
+ Constant [ int UUID_TYPE_TIME ] { 1 }
+ Constant [ int UUID_TYPE_SECURITY ] { 2 }
+ Constant [ int UUID_TYPE_MD5 ] { 3 }
Constant [ int UUID_TYPE_RANDOM ] { 4 }
+ Constant [ int UUID_TYPE_SHA1 ] { 5 }
Constant [ int UUID_TYPE_NULL ] { -1 }
Constant [ int UUID_TYPE_INVALID ] { -42 }
}
@@ -40,6 +43,20 @@ Extension [ <persistent> extension #156 uuid version 1.0.5 ] {
Parameter #0 [ <required> $uuid ]
}
}
+ Function [ <internal:uuid> function uuid_generate_md5 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $uuid_ns ]
+ Parameter #1 [ <required> $name ]
+ }
+ }
+ Function [ <internal:uuid> function uuid_generate_sha1 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $uuid_ns ]
+ Parameter #1 [ <required> $name ]
+ }
+ }
Function [ <internal:uuid> function uuid_type ] {
- Parameters [1] {
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
index ed4ee5f..18b98a4 100644
--- a/php-pecl-uuid.spec
+++ b/php-pecl-uuid.spec
@@ -3,8 +3,8 @@
#
# Fedora spec file for php-pecl-uuid
#
-# Copyright (c) 2012-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2012-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -14,7 +14,6 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-uuid
%endif
@@ -28,21 +27,21 @@
#global prever RC1
Summary: Universally Unique Identifier extension for PHP
-Name: %{?sub_prefix}php-pecl-uuid
-Version: 1.0.5
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: LGPLv2+
-URL: http://pecl.php.net/package/uuid
-Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-
+Name: %{?scl_prefix}php-pecl-uuid
+Version: 1.2.0
+Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: LGPL-2.1-or-later
+URL: https://pecl.php.net/package/uuid
+Source: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libuuid-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
# both provides same extension, with different API
Conflicts: %{?scl_prefix}uuid-php
@@ -54,30 +53,20 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -219,6 +208,33 @@ fi
%changelog
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.2.0-6
+- rebuild for PHP 8.3.0RC1
+
+* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 1.2.0-5
+- rebuild for PHP 8.2.0RC1
+
+* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.2.0-4
+- rebuild for 8.1.0RC1
+
+* Fri Apr 30 2021 Remi Collet <remi@remirepo.net> - 1.2.0-3
+- F34 rebuild for https://github.com/remicollet/remirepo/issues/174
+
+* Tue Oct 6 2020 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
+* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 1.1.0-4
+- rebuild for PHP 8.0.0RC1
+
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 1.1.0-3
+- rebuild for PHP 8.0.0beta3
+
+* Wed Aug 5 2020 Remi Collet <remi@remirepo.net> - 1.1.0-2
+- rebuild for 8.0.0beta1
+
+* Thu Nov 28 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Thu Nov 28 2019 Remi Collet <remi@remirepo.net> - 1.0.5-1
- update to 1.0.5