summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-06 12:41:23 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-06 12:41:23 +0100
commita1477a984fd514ba800c0b77c268c66b34c77d15 (patch)
treeff1805c7030b8e5a938a9906b0e9ab344c22e761
parent02ad335b05ee3f015955c7cc2285a78b7fc52aa2 (diff)
php-pecl-uuid: more upstream patches
-rw-r--r--php-pecl-uuid.spec15
-rw-r--r--uuid-build.patch11
-rw-r--r--uuid-ereg.patch7
-rw-r--r--uuid-info.patch26
4 files changed, 53 insertions, 6 deletions
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
index f79c243..3e9e0ba 100644
--- a/php-pecl-uuid.spec
+++ b/php-pecl-uuid.spec
@@ -6,7 +6,7 @@
Summary: Universally Unique Identifier extension for PHP
Name: php-pecl-uuid
Version: 1.0.3
-Release: 1%{?dist}
+Release: 2%{?dist}
# https://bugs.php.net/63446 - Please Provides LICENSE file
License: LGPLv2+
Group: Development/Languages
@@ -16,6 +16,12 @@ Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# http://svn.php.net/viewvc?view=revision&revision=328255
# Use preg_match to avoid "Function ereg() is deprecated" in test suite
Patch0: %{pecl_name}-ereg.patch
+# http://svn.php.net/viewvc?view=revision&revision=328259
+# Fix build warnings
+Patch1: %{pecl_name}-build.patch
+# http://svn.php.net/viewvc?view=revision&revision=328261
+# Improves phpinfo() output
+Patch2: %{pecl_name}-info.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: php-devel
@@ -53,7 +59,9 @@ A wrapper around Universally Unique Identifier library (libuuid).
%setup -q -c
cd %{pecl_name}-%{version}
-%patch0 -p1 -b .ereg
+%patch0 -p3 -b .ereg
+%patch1 -p3 -b .build
+%patch2 -p3 -b .info
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_UUID_VERSION/{s/.* "//;s/".*$//;p}' php_uuid.h)
@@ -156,5 +164,8 @@ rm -rf %{buildroot}
%changelog
+* Tue Nov 6 2012 Remi Collet <remi@fedoraproject.org> - 1.0.3-2
+- more upstream patches (build warning + phpinfo output)
+
* Tue Nov 6 2012 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
- initial package, version 1.0.3 (stable)
diff --git a/uuid-build.patch b/uuid-build.patch
new file mode 100644
index 0000000..c1b0f7e
--- /dev/null
+++ b/uuid-build.patch
@@ -0,0 +1,11 @@
+--- pecl/uuid/trunk/uuid.c 2012/11/06 09:09:21 328258
++++ pecl/uuid/trunk/uuid.c 2012/11/06 09:46:03 328259
+@@ -177,7 +177,7 @@
+ default:
+ php_error_docref(NULL TSRMLS_CC,
+ E_WARNING,
+- "Unknown/invalid UUID type '%d' requested, using default type instead",
++ "Unknown/invalid UUID type '%ld' requested, using default type instead",
+ uuid_type);
+ uuid_generate(uuid);
+ break;
diff --git a/uuid-ereg.patch b/uuid-ereg.patch
index 575aecd..b061158 100644
--- a/uuid-ereg.patch
+++ b/uuid-ereg.patch
@@ -1,7 +1,6 @@
-diff -up uuid-1.0.3/tests/uuid_create.phpt.old uuid-1.0.3/tests/uuid_create.phpt
---- uuid-1.0.3/tests/uuid_create.phpt.old 2012-11-06 09:30:20.644788269 +0100
-+++ uuid-1.0.3/tests/uuid_create.phpt 2012-11-06 09:30:30.512821665 +0100
-@@ -10,7 +10,7 @@ if(!extension_loaded('uuid')) die('skip
+--- pecl/uuid/trunk/tests/uuid_create.phpt 2012/11/06 05:35:52 328254
++++ pecl/uuid/trunk/tests/uuid_create.phpt 2012/11/06 08:38:46 328255
+@@ -10,7 +10,7 @@
<?php
// check basic format of generated UUIDs
$uuid = uuid_create();
diff --git a/uuid-info.patch b/uuid-info.patch
new file mode 100644
index 0000000..b6aed98
--- /dev/null
+++ b/uuid-info.patch
@@ -0,0 +1,26 @@
+--- pecl/uuid/trunk/uuid.c 2012/11/06 09:53:26 328260
++++ pecl/uuid/trunk/uuid.c 2012/11/06 10:03:36 328261
+@@ -134,10 +134,10 @@
+ /* {{{ PHP_MINFO_FUNCTION */
+ PHP_MINFO_FUNCTION(uuid)
+ {
+- php_printf("UUID extension\n");
+ php_info_print_table_start();
+- php_info_print_table_row(2, "Version",PHP_UUID_VERSION " (stable)");
+- php_info_print_table_row(2, "Released", "2008-04-01");
++ php_info_print_table_header(2, "UUID extension", "enabled");
++ php_info_print_table_row(2, "Version", PHP_UUID_VERSION " (stable)");
++ php_info_print_table_row(2, "Released", PHP_UUID_RELEASED);
+ php_info_print_table_row(2, "CVS Revision", "$Id: uuid.c 297236 2010-03-31 20:39:48Z johannes $");
+ php_info_print_table_row(2, "Authors", "Hartmut Holzgraefe 'hartmut@php.net' (lead)\n");
+ php_info_print_table_end();
+--- pecl/uuid/trunk/php_uuid.h 2012/11/06 09:53:26 328260
++++ pecl/uuid/trunk/php_uuid.h 2012/11/06 10:03:36 328261
+@@ -39,6 +39,7 @@
+
+ #ifdef HAVE_UUID
+ #define PHP_UUID_VERSION "1.0.3"
++#define PHP_UUID_RELEASED "2012-06-18"
+
+
+ #include <php_ini.h>