summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-06 10:07:18 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-06 10:07:18 +0100
commit9de9a6db3f6e74582af7d3c1699ebeb666a185a7 (patch)
tree3409ce4f77047b4679e3c4378c1e1d5f4b57bb55
php-pecl-uuid: mew package
-rw-r--r--Makefile4
-rw-r--r--php-pecl-uuid.spec160
-rw-r--r--uuid-ereg.patch12
3 files changed, 176 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
new file mode 100644
index 0000000..f79c243
--- /dev/null
+++ b/php-pecl-uuid.spec
@@ -0,0 +1,160 @@
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name uuid
+
+Summary: Universally Unique Identifier extension for PHP
+Name: php-pecl-uuid
+Version: 1.0.3
+Release: 1%{?dist}
+# https://bugs.php.net/63446 - Please Provides LICENSE file
+License: LGPLv2+
+Group: Development/Languages
+URL: http://pecl.php.net/package/uuid
+Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# http://svn.php.net/viewvc?view=revision&revision=328255
+# Use preg_match to avoid "Function ereg() is deprecated" in test suite
+Patch0: %{pecl_name}-ereg.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: php-devel
+BuildRequires: php-pear
+BuildRequires: libuuid-devel
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+# both provides same extension, with different API
+Conflicts: uuid-php
+
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+%if "%{php_version}" > "5.4"
+Obsoletes: php54-pecl-%{pecl_name}
+%endif
+
+
+# Filter private shared
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+
+
+%description
+A wrapper around Universally Unique Identifier library (libuuid).
+
+
+%prep
+%setup -q -c
+
+cd %{pecl_name}-%{version}
+%patch0 -p1 -b .ereg
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_UUID_VERSION/{s/.* "//;s/".*$//;p}' php_uuid.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr %{pecl_name}-%{version} %{pecl_name}-zts
+%endif
+
+# Drop in the bit of configuration
+cat > %{pecl_name}.ini << 'EOF'
+; Enable UUID extension module
+extension = %{pecl_name}.so
+EOF
+
+
+%build
+export PHP_RPATH=no
+
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../%{pecl_name}-zts
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+# Install the NTS stuff
+make -C %{pecl_name}-%{version} install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{_sysconfdir}/php.d/%{pecl_name}.ini
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C %{pecl_name}-zts install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+%endif
+
+# Install the package XML file
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+
+%check
+cd %{pecl_name}-%{version}
+
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php
+
+%if %{with_zts}
+cd ../%{pecl_name}-zts
+
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+%endif
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-, root, root, 0755)
+%doc %{pecl_name}-%{version}/CREDITS
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{_sysconfdir}/php.d/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%endif
+
+
+%changelog
+* Tue Nov 6 2012 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
+- initial package, version 1.0.3 (stable)
diff --git a/uuid-ereg.patch b/uuid-ereg.patch
new file mode 100644
index 0000000..575aecd
--- /dev/null
+++ b/uuid-ereg.patch
@@ -0,0 +1,12 @@
+diff -up uuid-1.0.3/tests/uuid_create.phpt.old uuid-1.0.3/tests/uuid_create.phpt
+--- uuid-1.0.3/tests/uuid_create.phpt.old 2012-11-06 09:30:20.644788269 +0100
++++ uuid-1.0.3/tests/uuid_create.phpt 2012-11-06 09:30:30.512821665 +0100
+@@ -10,7 +10,7 @@ if(!extension_loaded('uuid')) die('skip
+ <?php
+ // check basic format of generated UUIDs
+ $uuid = uuid_create();
+- if (ereg("[[:xdigit:]]{8}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{12}", $uuid)) {
++ if (preg_match("/[[:xdigit:]]{8}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{12}/", $uuid)) {
+ echo "basic format ok\n";
+ } else {
+ echo "basic UUID format check failed, generated UUID was $uuid\n";