summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-10 19:17:29 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-10 19:17:29 +0200
commit371734b3976fdaf8f8176382ae1cc30cc3ee7939 (patch)
tree6f7e12ca6efe09d426358b503e7fcf680cb57999
parentcd2dba67faf469d6a36f3e1b9379b1c85fe573de (diff)
php-pecl-uuid: add numerical prefix to extension configuration file
-rw-r--r--php-pecl-uuid.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
index 0f319eb..c8e9809 100644
--- a/php-pecl-uuid.spec
+++ b/php-pecl-uuid.spec
@@ -13,11 +13,16 @@
%global pecl_name uuid
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Universally Unique Identifier extension for PHP
Name: %{?scl_prefix}php-pecl-uuid
Version: 1.0.3
-Release: 8%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 9%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: LGPLv2+
Group: Development/Languages
URL: http://pecl.php.net/package/uuid
@@ -104,7 +109,7 @@ cp -pr NTS ZTS
%endif
# Drop in the bit of configuration
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable UUID extension module
extension = %{pecl_name}.so
EOF
@@ -130,12 +135,12 @@ make %{?_smp_mflags}
rm -rf %{buildroot}
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Install the package XML file
@@ -191,16 +196,19 @@ rm -rf %{buildroot}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
%{php_ztsextdir}/%{pecl_name}.so
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%endif
%changelog
+* Thu Apr 10 2014 Remi Collet <remi@fedoraproject.org> - 1.0.3-9
+- add numerical prefix to extension configuration file
+
* Mon Mar 24 2014 Remi Collet <remi@fedoraproject.org> - 1.0.3-8
- allow SCL build