summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-04-04 07:53:24 +0200
committerRemi Collet <fedora@famillecollet.com>2015-04-04 07:53:24 +0200
commit0ee1fcea5fffcea97d84a26630a83e256c209096 (patch)
treed6e4c3f01acfdbbf41cec63e2f92c92bd3c20587
parent550527031eabea15edda7d42e2587e8ae1955213 (diff)
php-pecl-uuid: 1.0.4RC1
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-uuid.spec50
-rw-r--r--uuid-LICENSE458
-rw-r--r--uuid-build.patch46
-rw-r--r--uuid-ereg.patch11
-rw-r--r--uuid-info.patch26
-rw-r--r--uuid-pecl.txt80
-rw-r--r--uuid-php.txt76
-rw-r--r--uuid-php7.patch151
9 files changed, 20 insertions, 880 deletions
diff --git a/REFLECTION b/REFLECTION
index 6611904..f2d3583 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #139 uuid version 1.0.3 ] {
+Extension [ <persistent> extension #75 uuid version 1.0.3 ] {
- Constants [10] {
Constant [ integer UUID_VARIANT_DCE ] { 1 }
diff --git a/php-pecl-uuid.spec b/php-pecl-uuid.spec
index a85f9c9..6391df5 100644
--- a/php-pecl-uuid.spec
+++ b/php-pecl-uuid.spec
@@ -18,32 +18,16 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
+%global prever RC1
Summary: Universally Unique Identifier extension for PHP
Name: %{?scl_prefix}php-pecl-uuid
-Version: 1.0.3
-Release: 11%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.0.4
+Release: 0.1.RC1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: LGPLv2+
Group: Development/Languages
URL: http://pecl.php.net/package/uuid
-Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://bugs.php.net/63446 - Please Provides LICENSE file
-# http://svn.php.net/viewvc/pecl/uuid/trunk/LICENSE?view=co
-Source1: %{pecl_name}-LICENSE
-
-# http://svn.php.net/viewvc?view=revision&revision=328255
-# Use preg_match to avoid "Function ereg() is deprecated" in test suite
-Patch0: %{pecl_name}-ereg.patch
-# http://svn.php.net/viewvc?view=revision&revision=328259
-# Fix build warnings
-Patch1: %{pecl_name}-build.patch
-# http://svn.php.net/viewvc?view=revision&revision=328261
-# http://svn.php.net/viewvc?view=revision&revision=336226
-# Improves phpinfo() output
-Patch2: %{pecl_name}-info.patch
-# http://svn.php.net/viewvc?view=revision&revision=336225
-# http://svn.php.net/viewvc?view=revision&revision=336227
-Patch3: %{pecl_name}-php7.patch
+Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel
@@ -95,19 +79,13 @@ A wrapper around Universally Unique Identifier library (libuuid).
# Don't install/register tests
sed -e 's/role="test"/role="src"/' -i package.xml
-mv %{pecl_name}-%{version} NTS
+mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
-cp %{SOURCE1} LICENSE
-
-%patch0 -p3 -b .ereg
-%patch1 -p3 -b .build
-%patch2 -p3 -b .info
-%patch3 -p3 -b .php7
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_UUID_VERSION/{s/.* "//;s/".*$//;p}' php_uuid.h)
-if test "x${extver}" != "x%{version}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}.
+if test "x${extver}" != "x%{version}%{?prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
cd ..
@@ -129,13 +107,19 @@ export PHP_RPATH=no
cd NTS
%{_bindir}/phpize
-%configure --with-php-config=%{_bindir}/php-config
+%configure \
+ --with-php-config=%{_bindir}/php-config \
+ --with-libdir=%{_lib} \
+ --with-uuid
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
%{_bindir}/zts-phpize
-%configure --with-php-config=%{_bindir}/zts-php-config
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config \
+ --with-libdir=%{_lib} \
+ --with-uuid
make %{?_smp_mflags}
%endif
@@ -220,6 +204,10 @@ rm -rf %{buildroot}
%changelog
+* Sat Apr 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.4-0.1.RC1
+- update to 1.0.4RC1
+- drop upstream patches
+
* Sat Mar 28 2015 Remi Collet <remi@fedoraproject.org> - 1.0.3-11
- more upstream patches, fix for PHP 7
- drop runtime dependency on pear, new scriptlets
diff --git a/uuid-LICENSE b/uuid-LICENSE
deleted file mode 100644
index 2c012a8..0000000
--- a/uuid-LICENSE
+++ /dev/null
@@ -1,458 +0,0 @@
- GNU LESSER GENERAL PUBLIC LICENSE
- Version 2.1, February 1999
-
- Copyright (C) 1991, 1999 Free Software Foundation, Inc.
- 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- Everyone is permitted to copy and distribute verbatim copies
- of this license document, but changing it is not allowed.
-
-[This is the first released version of the Lesser GPL. It also counts
- as the successor of the GNU Library Public License, version 2, hence
- the version number 2.1.]
-
- Preamble
-
- The licenses for most software are designed to take away your
-freedom to share and change it. By contrast, the GNU General Public
-Licenses are intended to guarantee your freedom to share and change
-free software--to make sure the software is free for all its users.
-
- This license, the Lesser General Public License, applies to some
-specially designated software packages--typically libraries--of the
-Free Software Foundation and other authors who decide to use it. You
-can use it too, but we suggest you first think carefully about whether
-this license or the ordinary General Public License is the better
-strategy to use in any particular case, based on the explanations below.
-
- When we speak of free software, we are referring to freedom of use,
-not price. Our General Public Licenses are designed to make sure that
-you have the freedom to distribute copies of free software (and charge
-for this service if you wish); that you receive source code or can get
-it if you want it; that you can change the software and use pieces of
-it in new free programs; and that you are informed that you can do
-these things.
-
- To protect your rights, we need to make restrictions that forbid
-distributors to deny you these rights or to ask you to surrender these
-rights. These restrictions translate to certain responsibilities for
-you if you distribute copies of the library or if you modify it.
-
- For example, if you distribute copies of the library, whether gratis
-or for a fee, you must give the recipients all the rights that we gave
-you. You must make sure that they, too, receive or can get the source
-code. If you link other code with the library, you must provide
-complete object files to the recipients, so that they can relink them
-with the library after making changes to the library and recompiling
-it. And you must show them these terms so they know their rights.
-
- We protect your rights with a two-step method: (1) we copyright the
-library, and (2) we offer you this license, which gives you legal
-permission to copy, distribute and/or modify the library.
-
- To protect each distributor, we want to make it very clear that
-there is no warranty for the free library. Also, if the library is
-modified by someone else and passed on, the recipients should know
-that what they have is not the original version, so that the original
-author's reputation will not be affected by problems that might be
-introduced by others.
-
- Finally, software patents pose a constant threat to the existence of
-any free program. We wish to make sure that a company cannot
-effectively restrict the users of a free program by obtaining a
-restrictive license from a patent holder. Therefore, we insist that
-any patent license obtained for a version of the library must be
-consistent with the full freedom of use specified in this license.
-
- Most GNU software, including some libraries, is covered by the
-ordinary GNU General Public License. This license, the GNU Lesser
-General Public License, applies to certain designated libraries, and
-is quite different from the ordinary General Public License. We use
-this license for certain libraries in order to permit linking those
-libraries into non-free programs.
-
- When a program is linked with a library, whether statically or using
-a shared library, the combination of the two is legally speaking a
-combined work, a derivative of the original library. The ordinary
-General Public License therefore permits such linking only if the
-entire combination fits its criteria of freedom. The Lesser General
-Public License permits more lax criteria for linking other code with
-the library.
-
- We call this license the "Lesser" General Public License because it
-does Less to protect the user's freedom than the ordinary General
-Public License. It also provides other free software developers Less
-of an advantage over competing non-free programs. These disadvantages
-are the reason we use the ordinary General Public License for many
-libraries. However, the Lesser license provides advantages in certain
-special circumstances.
-
- For example, on rare occasions, there may be a special need to
-encourage the widest possible use of a certain library, so that it becomes
-a de-facto standard. To achieve this, non-free programs must be
-allowed to use the library. A more frequent case is that a free
-library does the same job as widely used non-free libraries. In this
-case, there is little to gain by limiting the free library to free
-software only, so we use the Lesser General Public License.
-
- In other cases, permission to use a particular library in non-free
-programs enables a greater number of people to use a large body of
-free software. For example, permission to use the GNU C Library in
-non-free programs enables many more people to use the whole GNU
-operating system, as well as its variant, the GNU/Linux operating
-system.
-
- Although the Lesser General Public License is Less protective of the
-users' freedom, it does ensure that the user of a program that is
-linked with the Library has the freedom and the wherewithal to run
-that program using a modified version of the Library.
-
- The precise terms and conditions for copying, distribution and
-modification follow. Pay close attention to the difference between a
-"work based on the library" and a "work that uses the library". The
-former contains code derived from the library, whereas the latter must
-be combined with the library in order to run.
-
- GNU LESSER GENERAL PUBLIC LICENSE
- TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
-
- 0. This License Agreement applies to any software library or other
-program which contains a notice placed by the copyright holder or
-other authorized party saying it may be distributed under the terms of
-this Lesser General Public License (also called "this License").
-Each licensee is addressed as "you".
-
- A "library" means a collection of software functions and/or data
-prepared so as to be conveniently linked with application programs
-(which use some of those functions and data) to form executables.
-
- The "Library", below, refers to any such software library or work
-which has been distributed under these terms. A "work based on the
-Library" means either the Library or any derivative work under
-copyright law: that is to say, a work containing the Library or a
-portion of it, either verbatim or with modifications and/or translated
-straightforwardly into another language. (Hereinafter, translation is
-included without limitation in the term "modification".)
-
- "Source code" for a work means the preferred form of the work for
-making modifications to it. For a library, complete source code means
-all the source code for all modules it contains, plus any associated
-interface definition files, plus the scripts used to control compilation
-and installation of the library.
-
- Activities other than copying, distribution and modification are not
-covered by this License; they are outside its scope. The act of
-running a program using the Library is not restricted, and output from
-such a program is covered only if its contents constitute a work based
-on the Library (independent of the use of the Library in a tool for
-writing it). Whether that is true depends on what the Library does
-and what the program that uses the Library does.
-
- 1. You may copy and distribute verbatim copies of the Library's
-complete source code as you receive it, in any medium, provided that
-you conspicuously and appropriately publish on each copy an
-appropriate copyright notice and disclaimer of warranty; keep intact
-all the notices that refer to this License and to the absence of any
-warranty; and distribute a copy of this License along with the
-Library.
-
- You may charge a fee for the physical act of transferring a copy,
-and you may at your option offer warranty protection in exchange for a
-fee.
-
- 2. You may modify your copy or copies of the Library or any portion
-of it, thus forming a work based on the Library, and copy and
-distribute such modifications or work under the terms of Section 1
-above, provided that you also meet all of these conditions:
-
- a) The modified work must itself be a software library.
-
- b) You must cause the files modified to carry prominent notices
- stating that you changed the files and the date of any change.
-
- c) You must cause the whole of the work to be licensed at no
- charge to all third parties under the terms of this License.
-
- d) If a facility in the modified Library refers to a function or a
- table of data to be supplied by an application program that uses
- the facility, other than as an argument passed when the facility
- is invoked, then you must make a good faith effort to ensure that,
- in the event an application does not supply such function or
- table, the facility still operates, and performs whatever part of
- its purpose remains meaningful.
-
- (For example, a function in a library to compute square roots has
- a purpose that is entirely well-defined independent of the
- application. Therefore, Subsection 2d requires that any
- application-supplied function or table used by this function must
- be optional: if the application does not supply it, the square
- root function must still compute square roots.)
-
-These requirements apply to the modified work as a whole. If
-identifiable sections of that work are not derived from the Library,
-and can be reasonably considered independent and separate works in
-themselves, then this License, and its terms, do not apply to those
-sections when you distribute them as separate works. But when you
-distribute the same sections as part of a whole which is a work based
-on the Library, the distribution of the whole must be on the terms of
-this License, whose permissions for other licensees extend to the
-entire whole, and thus to each and every part regardless of who wrote
-it.
-
-Thus, it is not the intent of this section to claim rights or contest
-your rights to work written entirely by you; rather, the intent is to
-exercise the right to control the distribution of derivative or
-collective works based on the Library.
-
-In addition, mere aggregation of another work not based on the Library
-with the Library (or with a work based on the Library) on a volume of
-a storage or distribution medium does not bring the other work under
-the scope of this License.
-
- 3. You may opt to apply the terms of the ordinary GNU General Public
-License instead of this License to a given copy of the Library. To do
-this, you must alter all the notices that refer to this License, so
-that they refer to the ordinary GNU General Public License, version 2,
-instead of to this License. (If a newer version than version 2 of the
-ordinary GNU General Public License has appeared, then you can specify
-that version instead if you wish.) Do not make any other change in
-these notices.
-
- Once this change is made in a given copy, it is irreversible for
-that copy, so the ordinary GNU General Public License applies to all
-subsequent copies and derivative works made from that copy.
-
- This option is useful when you wish to copy part of the code of
-the Library into a program that is not a library.
-
- 4. You may copy and distribute the Library (or a portion or
-derivative of it, under Section 2) in object code or executable form
-under the terms of Sections 1 and 2 above provided that you accompany
-it with the complete corresponding machine-readable source code, which
-must be distributed under the terms of Sections 1 and 2 above on a
-medium customarily used for software interchange.
-
- If distribution of object code is made by offering access to copy
-from a designated place, then offering equivalent access to copy the
-source code from the same place satisfies the requirement to
-distribute the source code, even though third parties are not
-compelled to copy the source along with the object code.
-
- 5. A program that contains no derivative of any portion of the
-Library, but is designed to work with the Library by being compiled or
-linked with it, is called a "work that uses the Library". Such a
-work, in isolation, is not a derivative work of the Library, and
-therefore falls outside the scope of this License.
-
- However, linking a "work that uses the Library" with the Library
-creates an executable that is a derivative of the Library (because it
-contains portions of the Library), rather than a "work that uses the
-library". The executable is therefore covered by this License.
-Section 6 states terms for distribution of such executables.
-
- When a "work that uses the Library" uses material from a header file
-that is part of the Library, the object code for the work may be a
-derivative work of the Library even though the source code is not.
-Whether this is true is especially significant if the work can be
-linked without the Library, or if the work is itself a library. The
-threshold for this to be true is not precisely defined by law.
-
- If such an object file uses only numerical parameters, data
-structure layouts and accessors, and small macros and small inline
-functions (ten lines or less in length), then the use of the object
-file is unrestricted, regardless of whether it is legally a derivative
-work. (Executables containing this object code plus portions of the
-Library will still fall under Section 6.)
-
- Otherwise, if the work is a derivative of the Library, you may
-distribute the object code for the work under the terms of Section 6.
-Any executables containing that work also fall under Section 6,
-whether or not they are linked directly with the Library itself.
-
- 6. As an exception to the Sections above, you may also combine or
-link a "work that uses the Library" with the Library to produce a
-work containing portions of the Library, and distribute that work
-under terms of your choice, provided that the terms permit
-modification of the work for the customer's own use and reverse
-engineering for debugging such modifications.
-
- You must give prominent notice with each copy of the work that the
-Library is used in it and that the Library and its use are covered by
-this License. You must supply a copy of this License. If the work
-during execution displays copyright notices, you must include the
-copyright notice for the Library among them, as well as a reference
-directing the user to the copy of this License. Also, you must do one
-of these things:
-
- a) Accompany the work with the complete corresponding
- machine-readable source code for the Library including whatever
- changes were used in the work (which must be distributed under
- Sections 1 and 2 above); and, if the work is an executable linked
- with the Library, with the complete machine-readable "work that
- uses the Library", as object code and/or source code, so that the
- user can modify the Library and then relink to produce a modified
- executable containing the modified Library. (It is understood
- that the user who changes the contents of definitions files in the
- Library will not necessarily be able to recompile the application
- to use the modified definitions.)
-
- b) Use a suitable shared library mechanism for linking with the
- Library. A suitable mechanism is one that (1) uses at run time a
- copy of the library already present on the user's computer system,
- rather than copying library functions into the executable, and (2)
- will operate properly with a modified version of the library, if
- the user installs one, as long as the modified version is
- interface-compatible with the version that the work was made with.
-
- c) Accompany the work with a written offer, valid for at
- least three years, to give the same user the materials
- specified in Subsection 6a, above, for a charge no more
- than the cost of performing this distribution.
-
- d) If distribution of the work is made by offering access to copy
- from a designated place, offer equivalent access to copy the above
- specified materials from the same place.
-
- e) Verify that the user has already received a copy of these
- materials or that you have already sent this user a copy.
-
- For an executable, the required form of the "work that uses the
-Library" must include any data and utility programs needed for
-reproducing the executable from it. However, as a special exception,
-the materials to be distributed need not include anything that is
-normally distributed (in either source or binary form) with the major
-components (compiler, kernel, and so on) of the operating system on
-which the executable runs, unless that component itself accompanies
-the executable.
-
- It may happen that this requirement contradicts the license
-restrictions of other proprietary libraries that do not normally
-accompany the operating system. Such a contradiction means you cannot
-use both them and the Library together in an executable that you
-distribute.
-
- 7. You may place library facilities that are a work based on the
-Library side-by-side in a single library together with other library
-facilities not covered by this License, and distribute such a combined
-library, provided that the separate distribution of the work based on
-the Library and of the other library facilities is otherwise
-permitted, and provided that you do these two things:
-
- a) Accompany the combined library with a copy of the same work
- based on the Library, uncombined with any other library
- facilities. This must be distributed under the terms of the
- Sections above.
-
- b) Give prominent notice with the combined library of the fact
- that part of it is a work based on the Library, and explaining
- where to find the accompanying uncombined form of the same work.
-
- 8. You may not copy, modify, sublicense, link with, or distribute
-the Library except as expressly provided under this License. Any
-attempt otherwise to copy, modify, sublicense, link with, or
-distribute the Library is void, and will automatically terminate your
-rights under this License. However, parties who have received copies,
-or rights, from you under this License will not have their licenses
-terminated so long as such parties remain in full compliance.
-
- 9. You are not required to accept this License, since you have not
-signed it. However, nothing else grants you permission to modify or
-distribute the Library or its derivative works. These actions are
-prohibited by law if you do not accept this License. Therefore, by
-modifying or distributing the Library (or any work based on the
-Library), you indicate your acceptance of this License to do so, and
-all its terms and conditions for copying, distributing or modifying
-the Library or works based on it.
-
- 10. Each time you redistribute the Library (or any work based on the
-Library), the recipient automatically receives a license from the
-original licensor to copy, distribute, link with or modify the Library
-subject to these terms and conditions. You may not impose any further
-restrictions on the recipients' exercise of the rights granted herein.
-You are not responsible for enforcing compliance by third parties with
-this License.
-
- 11. If, as a consequence of a court judgment or allegation of patent
-infringement or for any other reason (not limited to patent issues),
-conditions are imposed on you (whether by court order, agreement or
-otherwise) that contradict the conditions of this License, they do not
-excuse you from the conditions of this License. If you cannot
-distribute so as to satisfy simultaneously your obligations under this
-License and any other pertinent obligations, then as a consequence you
-may not distribute the Library at all. For example, if a patent
-license would not permit royalty-free redistribution of the Library by
-all those who receive copies directly or indirectly through you, then
-the only way you could satisfy both it and this License would be to
-refrain entirely from distribution of the Library.
-
-If any portion of this section is held invalid or unenforceable under any
-particular circumstance, the balance of the section is intended to apply,
-and the section as a whole is intended to apply in other circumstances.
-
-It is not the purpose of this section to induce you to infringe any
-patents or other property right claims or to contest validity of any
-such claims; this section has the sole purpose of protecting the
-integrity of the free software distribution system which is
-implemented by public license practices. Many people have made
-generous contributions to the wide range of software distributed
-through that system in reliance on consistent application of that
-system; it is up to the author/donor to decide if he or she is willing
-to distribute software through any other system and a licensee cannot
-impose that choice.
-
-This section is intended to make thoroughly clear what is believed to
-be a consequence of the rest of this License.
-
- 12. If the distribution and/or use of the Library is restricted in
-certain countries either by patents or by copyrighted interfaces, the
-original copyright holder who places the Library under this License may add
-an explicit geographical distribution limitation excluding those countries,
-so that distribution is permitted only in or among countries not thus
-excluded. In such case, this License incorporates the limitation as if
-written in the body of this License.
-
- 13. The Free Software Foundation may publish revised and/or new
-versions of the Lesser General Public License from time to time.
-Such new versions will be similar in spirit to the present version,
-but may differ in detail to address new problems or concerns.
-
-Each version is given a distinguishing version number. If the Library
-specifies a version number of this License which applies to it and
-"any later version", you have the option of following the terms and
-conditions either of that version or of any later version published by
-the Free Software Foundation. If the Library does not specify a
-license version number, you may choose any version ever published by
-the Free Software Foundation.
-
- 14. If you wish to incorporate parts of the Library into other free
-programs whose distribution conditions are incompatible with these,
-write to the author to ask for permission. For software which is
-copyrighted by the Free Software Foundation, write to the Free
-Software Foundation; we sometimes make exceptions for this. Our
-decision will be guided by the two goals of preserving the free status
-of all derivatives of our free software and of promoting the sharing
-and reuse of software generally.
-
- NO WARRANTY
-
- 15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO
-WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
-EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR
-OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY
-KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE
-LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME
-THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.
-
- 16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN
-WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY
-AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU
-FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR
-CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE
-LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING
-RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A
-FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF
-SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH
-DAMAGES.
-
- END OF TERMS AND CONDITIONS
diff --git a/uuid-build.patch b/uuid-build.patch
deleted file mode 100644
index db6a999..0000000
--- a/uuid-build.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- pecl/uuid/trunk/uuid.c 2012/11/06 09:09:21 328258
-+++ pecl/uuid/trunk/uuid.c 2012/11/06 09:46:03 328259
-@@ -177,7 +177,7 @@
- default:
- php_error_docref(NULL TSRMLS_CC,
- E_WARNING,
-- "Unknown/invalid UUID type '%d' requested, using default type instead",
-+ "Unknown/invalid UUID type '%ld' requested, using default type instead",
- uuid_type);
- uuid_generate(uuid);
- break;
---- pecl/uuid/trunk/config.m4 2015/03/28 06:45:58 336225
-+++ pecl/uuid/trunk/config.m4 2015/03/28 07:05:04 336226
-@@ -6,18 +6,28 @@
-
-
- if test "$PHP_UUID" != "no"; then
-- PHP_CHECK_FUNC_LIB(uuid_type, uuid)
-- PHP_CHECK_FUNC_LIB(uuid_variant, uuid)
--
-
-+ AC_MSG_CHECKING([for the location of libuuid])
-+ for dir in $PHP_UUID /usr/local /usr; do
-+ if test -f "$dir/include/uuid/uuid.h"; then
-+ PHP_UUID_DIR="$dir"
-+ fi
-+ done
-+ if test -z "$PHP_UUID_DIR"; then
-+ AC_MSG_ERROR(not found)
-+ else
-+ AC_MSG_RESULT(found in $PHP_UUID_DIR)
-+ fi
- PHP_ADD_INCLUDE($PHP_UUID_DIR/include)
-+ PHP_CHECK_FUNC_LIB(uuid_type, uuid)
-+ PHP_CHECK_FUNC_LIB(uuid_variant, uuid)
-
- export OLD_CPPFLAGS="$CPPFLAGS"
- export CPPFLAGS="$CPPFLAGS $INCLUDES -DHAVE_UUID"
- AC_CHECK_HEADER([uuid/uuid.h], [], AC_MSG_ERROR('uuid/uuid.h' header not found))
- PHP_SUBST(UUID_SHARED_LIBADD)
-
-- PHP_ADD_LIBRARY_WITH_PATH(uuid, $PHP_UUID_DIR/lib, UUID_SHARED_LIBADD)
-+ PHP_ADD_LIBRARY_WITH_PATH(uuid, $PHP_UUID_DIR/$PHP_LIBDIR, UUID_SHARED_LIBADD)
- export CPPFLAGS="$OLD_CPPFLAGS"
-
- export OLD_CPPFLAGS="$CPPFLAGS"
diff --git a/uuid-ereg.patch b/uuid-ereg.patch
deleted file mode 100644
index b061158..0000000
--- a/uuid-ereg.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- pecl/uuid/trunk/tests/uuid_create.phpt 2012/11/06 05:35:52 328254
-+++ pecl/uuid/trunk/tests/uuid_create.phpt 2012/11/06 08:38:46 328255
-@@ -10,7 +10,7 @@
- <?php
- // check basic format of generated UUIDs
- $uuid = uuid_create();
-- if (ereg("[[:xdigit:]]{8}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{12}", $uuid)) {
-+ if (preg_match("/[[:xdigit:]]{8}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{12}/", $uuid)) {
- echo "basic format ok\n";
- } else {
- echo "basic UUID format check failed, generated UUID was $uuid\n";
diff --git a/uuid-info.patch b/uuid-info.patch
deleted file mode 100644
index b6aed98..0000000
--- a/uuid-info.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- pecl/uuid/trunk/uuid.c 2012/11/06 09:53:26 328260
-+++ pecl/uuid/trunk/uuid.c 2012/11/06 10:03:36 328261
-@@ -134,10 +134,10 @@
- /* {{{ PHP_MINFO_FUNCTION */
- PHP_MINFO_FUNCTION(uuid)
- {
-- php_printf("UUID extension\n");
- php_info_print_table_start();
-- php_info_print_table_row(2, "Version",PHP_UUID_VERSION " (stable)");
-- php_info_print_table_row(2, "Released", "2008-04-01");
-+ php_info_print_table_header(2, "UUID extension", "enabled");
-+ php_info_print_table_row(2, "Version", PHP_UUID_VERSION " (stable)");
-+ php_info_print_table_row(2, "Released", PHP_UUID_RELEASED);
- php_info_print_table_row(2, "CVS Revision", "$Id: uuid.c 297236 2010-03-31 20:39:48Z johannes $");
- php_info_print_table_row(2, "Authors", "Hartmut Holzgraefe 'hartmut@php.net' (lead)\n");
- php_info_print_table_end();
---- pecl/uuid/trunk/php_uuid.h 2012/11/06 09:53:26 328260
-+++ pecl/uuid/trunk/php_uuid.h 2012/11/06 10:03:36 328261
-@@ -39,6 +39,7 @@
-
- #ifdef HAVE_UUID
- #define PHP_UUID_VERSION "1.0.3"
-+#define PHP_UUID_RELEASED "2012-06-18"
-
-
- #include <php_ini.h>
diff --git a/uuid-pecl.txt b/uuid-pecl.txt
deleted file mode 100644
index 19b4b55..0000000
--- a/uuid-pecl.txt
+++ /dev/null
@@ -1,80 +0,0 @@
-Extension [ <persistent> extension #103 uuid version 1.0.3 ] {
-
- - Constants [10] {
- Constant [ integer UUID_VARIANT_DCE ] { 1 }
- Constant [ integer UUID_VARIANT_MICROSOFT ] { 2 }
- Constant [ integer UUID_VARIANT_OTHER ] { 3 }
- Constant [ integer UUID_TYPE_DEFAULT ] { 0 }
- Constant [ integer UUID_TYPE_TIME ] { 1 }
- Constant [ integer UUID_TYPE_DCE ] { 4 }
- Constant [ integer UUID_TYPE_NAME ] { 1 }
- Constant [ integer UUID_TYPE_RANDOM ] { 4 }
- Constant [ integer UUID_TYPE_NULL ] { -1 }
- Constant [ integer UUID_TYPE_INVALID ] { -42 }
- }
-
- - Functions {
- Function [ <internal:uuid> function uuid_create ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $uuid_type ]
- }
- }
- Function [ <internal:uuid> function uuid_is_valid ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $uuid ]
- }
- }
- Function [ <internal:uuid> function uuid_compare ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $uuid1 ]
- Parameter #1 [ <required> $uuid2 ]
- }
- }
- Function [ <internal:uuid> function uuid_is_null ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $uuid ]
- }
- }
- Function [ <internal:uuid> function uuid_type ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $uuid ]
- }
- }
- Function [ <internal:uuid> function uuid_variant ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $uuid ]
- }
- }
- Function [ <internal:uuid> function uuid_time ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $uuid ]
- }
- }
- Function [ <internal:uuid> function uuid_mac ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $uuid ]
- }
- }
- Function [ <internal:uuid> function uuid_parse ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $uuid ]
- }
- }
- Function [ <internal:uuid> function uuid_unparse ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $uuid ]
- }
- }
- }
-}
-
diff --git a/uuid-php.txt b/uuid-php.txt
deleted file mode 100644
index a30161e..0000000
--- a/uuid-php.txt
+++ /dev/null
@@ -1,76 +0,0 @@
-Extension [ <persistent> extension #103 uuid version <no_version> ] {
-
- - Constants [19] {
- Constant [ integer UUID_VERSION ] { 1073666 }
- Constant [ integer UUID_LEN_BIN ] { 16 }
- Constant [ integer UUID_LEN_STR ] { 36 }
- Constant [ integer UUID_LEN_SIV ] { 39 }
- Constant [ integer UUID_RC_OK ] { 0 }
- Constant [ integer UUID_RC_ARG ] { 1 }
- Constant [ integer UUID_RC_MEM ] { 2 }
- Constant [ integer UUID_RC_SYS ] { 3 }
- Constant [ integer UUID_RC_INT ] { 4 }
- Constant [ integer UUID_RC_IMP ] { 5 }
- Constant [ integer UUID_MAKE_V1 ] { 1 }
- Constant [ integer UUID_MAKE_V3 ] { 2 }
- Constant [ integer UUID_MAKE_V4 ] { 4 }
- Constant [ integer UUID_MAKE_V5 ] { 8 }
- Constant [ integer UUID_MAKE_MC ] { 16 }
- Constant [ integer UUID_FMT_BIN ] { 0 }
- Constant [ integer UUID_FMT_STR ] { 1 }
- Constant [ integer UUID_FMT_SIV ] { 2 }
- Constant [ integer UUID_FMT_TXT ] { 3 }
- }
-
- - Functions {
- Function [ <internal:uuid> function uuid_create ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> &$ctx ]
- }
- }
- Function [ <internal:uuid> function uuid_destroy ] {
- }
- Function [ <internal:uuid> function uuid_clone ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $ctx ]
- Parameter #1 [ <required> &$ctx2 ]
- }
- }
- Function [ <internal:uuid> function uuid_load ] {
- }
- Function [ <internal:uuid> function uuid_make ] {
- }
- Function [ <internal:uuid> function uuid_isnil ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $ctx ]
- Parameter #1 [ <required> &$result ]
- }
- }
- Function [ <internal:uuid> function uuid_compare ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $ctx ]
- Parameter #1 [ <required> $ctx2 ]
- Parameter #2 [ <required> &$result ]
- }
- }
- Function [ <internal:uuid> function uuid_import ] {
- }
- Function [ <internal:uuid> function uuid_export ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $ctx ]
- Parameter #1 [ <required> $fmt ]
- Parameter #2 [ <required> &$data ]
- }
- }
- Function [ <internal:uuid> function uuid_error ] {
- }
- Function [ <internal:uuid> function uuid_version ] {
- }
- }
-}
-
diff --git a/uuid-php7.patch b/uuid-php7.patch
deleted file mode 100644
index 5c1f900..0000000
--- a/uuid-php7.patch
+++ /dev/null
@@ -1,151 +0,0 @@
---- pecl/uuid/trunk/php_uuid.h 2015/03/27 16:21:02 336224
-+++ pecl/uuid/trunk/php_uuid.h 2015/03/28 06:45:58 336225
-@@ -197,6 +197,17 @@
-
- #endif /* PHP_HAVE_UUID */
-
-+#if PHP_MAJOR_VERSION < 7
-+typedef long zend_long;
-+typedef int strsize;
-+#define UUID_RETSTR(a) RETURN_STRING(a,1)
-+#define UUID_RETSTRL(a,l) RETURN_STRINGL(a,l,1)
-+#else
-+typedef size_t strsize;
-+#define UUID_RETSTR(a) RETURN_STRING(a)
-+#define UUID_RETSTRL(a,l) RETURN_STRINGL(a,l)
-+#endif
-+
- #endif /* PHP_UUID_H */
-
-
---- pecl/uuid/trunk/uuid.c 2015/03/27 16:21:02 336224
-+++ pecl/uuid/trunk/uuid.c 2015/03/28 06:45:58 336225
-@@ -152,7 +152,7 @@
- PHP_FUNCTION(uuid_create)
- {
-
-- long uuid_type = 0;
-+ zend_long uuid_type = 0;
-
-
-
-@@ -185,7 +185,7 @@
-
- uuid_unparse(uuid, uuid_str);
-
-- RETURN_STRING(uuid_str, 1);
-+ UUID_RETSTR(uuid_str);
- } while (0);
- }
- /* }}} uuid_create */
-@@ -197,7 +197,7 @@
- {
-
- const char * uuid = NULL;
-- int uuid_len = 0;
-+ strsize uuid_len = 0;
-
-
-
-@@ -219,9 +219,9 @@
- {
-
- const char * uuid1 = NULL;
-- int uuid1_len = 0;
-+ strsize uuid1_len = 0;
- const char * uuid2 = NULL;
-- int uuid2_len = 0;
-+ strsize uuid2_len = 0;
-
-
-
-@@ -247,7 +247,7 @@
- {
-
- const char * uuid = NULL;
-- int uuid_len = 0;
-+ strsize uuid_len = 0;
-
-
-
-@@ -273,7 +273,7 @@
- {
-
- const char * uuid = NULL;
-- int uuid_len = 0;
-+ strsize uuid_len = 0;
-
-
-
-@@ -302,7 +302,7 @@
- {
-
- const char * uuid = NULL;
-- int uuid_len = 0;
-+ strsize uuid_len = 0;
-
-
-
-@@ -330,7 +330,7 @@
- {
-
- const char * uuid = NULL;
-- int uuid_len = 0;
-+ strsize uuid_len = 0;
-
-
-
-@@ -361,7 +361,7 @@
- {
-
- const char * uuid = NULL;
-- int uuid_len = 0;
-+ strsize uuid_len = 0;
-
-
-
-@@ -384,7 +384,7 @@
- if(uuid[10] & 0x80) RETURN_FALSE; // invalid MAC
-
- uuid_unparse(u, uuid_str);
-- RETURN_STRING((char *)(uuid_str + 24), 1);
-+ UUID_RETSTR((char *)(uuid_str + 24));
- } while (0);
- }
- /* }}} uuid_mac */
-@@ -396,7 +396,7 @@
- {
-
- const char * uuid = NULL;
-- int uuid_len = 0;
-+ strsize uuid_len = 0;
-
-
-
-@@ -411,7 +411,7 @@
- RETURN_FALSE;
- }
-
-- RETURN_STRINGL((char *)uuid_bin, sizeof(uuid_t), 1);
-+ UUID_RETSTRL((char *)uuid_bin, sizeof(uuid_t));
- } while (0);
- }
- /* }}} uuid_parse */
-@@ -423,7 +423,7 @@
- {
-
- const char * uuid = NULL;
-- int uuid_len = 0;
-+ strsize uuid_len = 0;
-
-
-
-@@ -440,7 +440,7 @@
-
- uuid_unparse((unsigned char *)uuid, uuid_txt);
-
-- RETURN_STRINGL(uuid_txt, 36, 1);
-+ UUID_RETSTRL(uuid_txt, 36);
- } while (0);
- }
- /* }}} uuid_unparse */