summaryrefslogtreecommitdiffstats
path: root/php-pecl-uploadprogress.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-29 07:25:27 +0200
committerRemi Collet <remi@remirepo.net>2021-09-29 07:25:27 +0200
commit942680bb4886369488b4594173b0e2191df8b1dc (patch)
treed5c3a1f8c500c6543d8342582aa8d9544bb598a2 /php-pecl-uploadprogress.spec
parent34177af949fd90c03b8219f367f1bffc67b643d3 (diff)
update to 1.1.4
run upstream test suite during build drop patches merged upstream
Diffstat (limited to 'php-pecl-uploadprogress.spec')
-rw-r--r--php-pecl-uploadprogress.spec34
1 files changed, 20 insertions, 14 deletions
diff --git a/php-pecl-uploadprogress.spec b/php-pecl-uploadprogress.spec
index 60fde78..dea09e5 100644
--- a/php-pecl-uploadprogress.spec
+++ b/php-pecl-uploadprogress.spec
@@ -8,9 +8,11 @@
#
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-uploadprogress
+%scl_package php-pecl-uploadprogress
%endif
+%bcond_without tests
+
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name uploadprogress
%if "%{php_version}" < "5.6"
@@ -21,22 +23,15 @@
Summary: An extension to track progress of a file upload
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.1.3
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.1.4
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# Fix segmentation fault in uploadprogress
-# https://github.com/php/pecl-php-uploadprogress/pull/8
-Patch0: %{pecl_name}-arginfo.patch
-# Add arginfo to functions
-# https://github.com/php/pecl-php-uploadprogress/pull/9
-Patch1: %{pecl_name}-segfault.patch
-
-BuildRequires: %{?dtsprefix}gcc
BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -92,9 +87,6 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch1 -p1 -b .pr9
-%patch0 -p1 -b .pr8
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_UPLOADPROGRESS_VERSION/{s/.* "//;s/".*$//;p}' php_uploadprogress.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -199,6 +191,15 @@ cd ../ZTS
--modules | grep %{pecl_name}
%endif
+%if %{with tests}
+cd ../NTS
+: Run upstream test suite
+REPORT_EXIT_STATUS=1 \
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php -q --show-diff
+%endif
+
%files
%{?_licensedir:%license NTS/LICENSE}
@@ -215,6 +216,11 @@ cd ../ZTS
%changelog
+* Wed Sep 29 2021 Remi Collet <remi@remirepo.net> - 1.1.4-1
+- update to 1.1.4
+- run upstream test suite during build
+- drop patches merged upstream
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.1.3-3
- rebuild for 8.1.0RC1