summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-uopz.spec16
-rw-r--r--uopz-xdebug.patch72
3 files changed, 91 insertions, 11 deletions
diff --git a/REFLECTION b/REFLECTION
index c82e90e..f0e0ac9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -10,13 +10,13 @@ Extension [ <persistent> extension #15 uopz version 6.1.1 ] {
}
- Constants [7] {
- Constant [ integer ZEND_ACC_PUBLIC ] { 256 }
- Constant [ integer ZEND_ACC_PRIVATE ] { 1024 }
- Constant [ integer ZEND_ACC_PROTECTED ] { 512 }
- Constant [ integer ZEND_ACC_PPP_MASK ] { 1792 }
- Constant [ integer ZEND_ACC_STATIC ] { 1 }
- Constant [ integer ZEND_ACC_FINAL ] { 4 }
- Constant [ integer ZEND_ACC_ABSTRACT ] { 2 }
+ Constant [ int ZEND_ACC_PUBLIC ] { 256 }
+ Constant [ int ZEND_ACC_PRIVATE ] { 1024 }
+ Constant [ int ZEND_ACC_PROTECTED ] { 512 }
+ Constant [ int ZEND_ACC_PPP_MASK ] { 1792 }
+ Constant [ int ZEND_ACC_STATIC ] { 1 }
+ Constant [ int ZEND_ACC_FINAL ] { 4 }
+ Constant [ int ZEND_ACC_ABSTRACT ] { 2 }
}
- Functions {
diff --git a/php-pecl-uopz.spec b/php-pecl-uopz.spec
index ab06f47..2add1b9 100644
--- a/php-pecl-uopz.spec
+++ b/php-pecl-uopz.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-uopz
#
-# Copyright (c) 2014-2019 Remi Collet
+# Copyright (c) 2014-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -24,15 +24,17 @@
Summary: User Operations for Zend
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 6.1.1
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
-URL: http://pecl.php.net/package/%{pecl_name}
+URL: https://pecl.php.net/package/%{pecl_name}
%if 0%{?gh_commit:1}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
%else
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
+Patch0: uopz-xdebug.patch
+
BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
@@ -48,6 +50,7 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
+Conflicts: %{?scl_prefix}php-pecl-xdebug < 2.9.4
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -121,6 +124,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .revert
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_UOPZ_VERSION/{s/.* "//;s/".*$//;p}' uopz.h)
if test "x${extver}" != "x%{version}"; then
@@ -256,6 +261,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue May 19 2020 Remi Collet <remi@remirepo.net> - 6.1.1-4
+- revert workaround for xdebug < 2.9.4
+
* Wed Sep 18 2019 Remi Collet <remi@remirepo.net> - 6.1.1-1
- update to 6.1.1
diff --git a/uopz-xdebug.patch b/uopz-xdebug.patch
new file mode 100644
index 0000000..ef07ba9
--- /dev/null
+++ b/uopz-xdebug.patch
@@ -0,0 +1,72 @@
+
+Revert workaround to xdebug < 2.9.4
+
+ d9785ce7357fae2a49ba5f00a6705cd75d6fbdcd.
+ db01930f131eb5f673cba7bd536dab881818760c
+
+---
+ src/handlers.c | 14 --------------
+ src/handlers.h | 1 -
+ uopz.c | 8 +++++---
+ 3 files changed, 5 insertions(+), 18 deletions(-)
+
+diff --git a/src/handlers.c b/src/handlers.c
+index 386b840..42910d3 100644
+--- a/src/handlers.c
++++ b/src/handlers.c
+@@ -163,20 +163,6 @@ void uopz_handlers_init(void) {
+ }
+ }
+
+-void uopz_handlers_update(void) {
+- uopz_vm_handler_t *handler = uopz_vm_handlers;
+-
+- while (handler) {
+- if (!handler->opcode) {
+- break;
+- }
+- if (zend_get_user_opcode_handler(handler->opcode) != handler->uopz) {
+- UOPZ_HANDLER_OVERLOAD(handler);
+- }
+- handler++;
+- }
+-}
+-
+ void uopz_handlers_shutdown(void) {
+ uopz_vm_handler_t *handler = uopz_vm_handlers;
+
+diff --git a/src/handlers.h b/src/handlers.h
+index 80574d3..6884faf 100644
+--- a/src/handlers.h
++++ b/src/handlers.h
+@@ -20,7 +20,6 @@
+ #define UOPZ_HANDLERS_H
+
+ void uopz_handlers_init(void);
+-void uopz_handlers_update(void);
+ void uopz_handlers_shutdown(void);
+
+ #endif /* UOPZ_HANDLERS_H */
+diff --git a/uopz.c b/uopz.c
+index b181dda..2f8c193 100644
+--- a/uopz.c
++++ b/uopz.c
+@@ -24,7 +24,6 @@
+ #include "php_ini.h"
+ #include "ext/standard/info.h"
+
+-#include "SAPI.h"
+
+ #include "uopz.h"
+
+@@ -154,8 +152,6 @@ static PHP_RINIT_FUNCTION(uopz)
+
+ uopz_request_init();
+
+- uopz_handlers_update();
+-
+ return SUCCESS;
+ } /* }}} */
+
+
+