summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-28 13:53:34 +0200
committerRemi Collet <remi@remirepo.net>2021-07-28 13:53:34 +0200
commit7c2e3e3c3e38229780cfabb0674bca1a3fa2047c (patch)
treecbf62af47081b968e897fb5c9faa8580541bac20
parent0c6fc20f8b55ef84a927a2cd2d49cd4141c9ae08 (diff)
update to 7.0.0
raise dependency on PHP 8.0
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION111
-rw-r--r--php-pecl-uopz.spec21
3 files changed, 121 insertions, 19 deletions
diff --git a/PHPINFO b/PHPINFO
index a367c1d..de4ff74 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,9 +1,9 @@
uopz
-uopz support => disabled
-Version => 6.1.2
+uopz support => enabled
+Version => 7.0.0
Directive => Local Value => Master Value
-uopz.disable => 1 => 1
-uopz.exit => 1 => 1
+uopz.disable => 0 => 0
+uopz.exit => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 57686ae..d52e783 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,62 +1,167 @@
-Extension [ <persistent> extension #119 uopz version 6.1.2 ] {
+Extension [ <persistent> extension #16 uopz version 7.0.0 ] {
- INI {
Entry [ uopz.disable <SYSTEM> ]
- Current = '1'
+ Current = '0'
}
Entry [ uopz.exit <SYSTEM> ]
- Current = '1'
+ Current = '0'
}
}
+ - Constants [7] {
+ Constant [ int ZEND_ACC_PUBLIC ] { 1 }
+ Constant [ int ZEND_ACC_PRIVATE ] { 4 }
+ Constant [ int ZEND_ACC_PROTECTED ] { 2 }
+ Constant [ int ZEND_ACC_PPP_MASK ] { 7 }
+ Constant [ int ZEND_ACC_STATIC ] { 16 }
+ Constant [ int ZEND_ACC_FINAL ] { 32 }
+ Constant [ int ZEND_ACC_ABSTRACT ] { 64 }
+ }
+
- Functions {
Function [ <internal:uopz> function uopz_set_return ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_get_return ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_unset_return ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_set_mock ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_get_mock ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_unset_mock ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_get_static ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_set_static ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_set_hook ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_get_hook ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_unset_hook ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_add_function ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_del_function ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_extend ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_implement ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_flags ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_redefine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_undefine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_set_property ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_get_property ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_get_exit_status ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:uopz> function uopz_allow_exit ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_call_user_func ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
Function [ <internal:uopz> function uopz_call_user_func_array ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> ...$arguments ]
+ }
}
}
}
diff --git a/php-pecl-uopz.spec b/php-pecl-uopz.spec
index c540c3f..be69d70 100644
--- a/php-pecl-uopz.spec
+++ b/php-pecl-uopz.spec
@@ -23,8 +23,8 @@
Summary: User Operations for Zend
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 6.1.2
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 7.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
%if 0%{?gh_commit:1}
@@ -33,11 +33,9 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
-Patch0: %{pecl_name}-php8.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -56,14 +54,11 @@ Conflicts: %{?scl_prefix}php-pecl-xdebug < 2.9.4
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -113,8 +108,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .up
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_UOPZ_VERSION/{s/.* "//;s/".*$//;p}' uopz.h)
if test "x${extver}" != "x%{version}"; then
@@ -250,6 +243,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Jul 28 2021 Remi Collet <remi@remirepo.net> - 7.0.0-1
+- update to 7.0.0
+- raise dependency on PHP 8.0
+
* Tue Jun 30 2020 Remi Collet <remi@remirepo.net> - 6.1.2-4
- add upstream patches for PHP 8