summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-05 09:15:49 +0100
committerRemi Collet <remi@remirepo.net>2021-03-05 09:15:49 +0100
commit2f6231e68e0f35b8441732f5eb56fd302c755982 (patch)
tree8958daafa0f9cd82302a4696d7c53ad3000719ac
parent0e0304569960aed3bfe502a5cdb2452a8c60e7c9 (diff)
add upstream patches for PHP 8
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION16
-rw-r--r--php-pecl-uopz.spec32
3 files changed, 20 insertions, 34 deletions
diff --git a/PHPINFO b/PHPINFO
index 8fd5194..a367c1d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,9 +1,9 @@
uopz
-uopz support => enabled
+uopz support => disabled
Version => 6.1.2
Directive => Local Value => Master Value
-uopz.disable => 0 => 0
-uopz.exit => 0 => 0
+uopz.disable => 1 => 1
+uopz.exit => 1 => 1
diff --git a/REFLECTION b/REFLECTION
index 76edc04..57686ae 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,24 +1,14 @@
-Extension [ <persistent> extension #15 uopz version 6.1.2 ] {
+Extension [ <persistent> extension #119 uopz version 6.1.2 ] {
- INI {
Entry [ uopz.disable <SYSTEM> ]
- Current = '0'
+ Current = '1'
}
Entry [ uopz.exit <SYSTEM> ]
- Current = '0'
+ Current = '1'
}
}
- - Constants [7] {
- Constant [ int ZEND_ACC_PUBLIC ] { 256 }
- Constant [ int ZEND_ACC_PRIVATE ] { 1024 }
- Constant [ int ZEND_ACC_PROTECTED ] { 512 }
- Constant [ int ZEND_ACC_PPP_MASK ] { 1792 }
- Constant [ int ZEND_ACC_STATIC ] { 1 }
- Constant [ int ZEND_ACC_FINAL ] { 4 }
- Constant [ int ZEND_ACC_ABSTRACT ] { 2 }
- }
-
- Functions {
Function [ <internal:uopz> function uopz_set_return ] {
}
diff --git a/php-pecl-uopz.spec b/php-pecl-uopz.spec
index 0c5da09..c540c3f 100644
--- a/php-pecl-uopz.spec
+++ b/php-pecl-uopz.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-uopz
#
-# Copyright (c) 2014-2020 Remi Collet
+# Copyright (c) 2014-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -24,7 +24,7 @@
Summary: User Operations for Zend
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 6.1.2
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
%if 0%{?gh_commit:1}
@@ -33,6 +33,10 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
+Patch0: %{pecl_name}-php8.patch
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
@@ -50,30 +54,17 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%endif
Conflicts: %{?scl_prefix}php-pecl-xdebug < 2.9.4
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -122,6 +113,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .up
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_UOPZ_VERSION/{s/.* "//;s/".*$//;p}' uopz.h)
if test "x${extver}" != "x%{version}"; then
@@ -257,6 +250,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Jun 30 2020 Remi Collet <remi@remirepo.net> - 6.1.2-4
+- add upstream patches for PHP 8
+
* Tue Jun 30 2020 Remi Collet <remi@remirepo.net> - 6.1.2-1
- update to 6.1.2