summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--LICENSE23
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION18
-rw-r--r--php-pecl-translit.spec125
5 files changed, 73 insertions, 97 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index bef7949..0000000
--- a/LICENSE
+++ /dev/null
@@ -1,23 +0,0 @@
-Copyright (c) 2004-2015, Derick Rethans
-
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
- - Redistributions of source code must retain the above copyright notice, this
- list of conditions and the following disclaimer.
- - Redistributions in binary form must reproduce the above copyright notice,
- this list of conditions and the following disclaimer in the documentation
- and/or other materials provided with the distribution.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PHPINFO b/PHPINFO
index 3af6ae2..1c887d1 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
translit
Transliteration support => enabled
-Version => 0.6.3
+Version => 0.7.1
diff --git a/REFLECTION b/REFLECTION
index 1346434..bc67b0f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,25 @@
-Extension [ <persistent> extension #164 translit version 0.6.3 ] {
+Extension [ <persistent> extension #125 translit version 0.7.1 ] {
+
+ - Dependencies {
+ Dependency [ iconv (Required) ]
+ }
- Functions {
Function [ <internal:translit> function transliterate ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $string ]
+ Parameter #1 [ <required> array $filter_list ]
+ Parameter #2 [ <optional> string $charset_in = "" ]
+ Parameter #3 [ <optional> string $charset_out = "" ]
+ }
+ - Return [ string ]
}
Function [ <internal:translit> function transliterate_filters_get ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
}
}
diff --git a/php-pecl-translit.spec b/php-pecl-translit.spec
index 23efc90..f06ba35 100644
--- a/php-pecl-translit.spec
+++ b/php-pecl-translit.spec
@@ -1,82 +1,47 @@
# remirepo spec file for php-pecl-translit
#
-# Copyright (c) 2015-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-translit
-%endif
+
+%{?scl:%scl_package php-pecl-translit}
+
+%bcond_without tests
%global pecl_name translit
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-# see https://github.com/derickr/pecl-translit/releases
-%global gh_commit f2e23d91068047a3d08a8e8d999aca13013ff9cc
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner derickr
-%global gh_project pecl-translit
-%global with_tests 0%{!?_without_tests:1}
# After 20-iconv
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Transliterates non-latin character sets to latin
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.6.3
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: BSD
-URL: http://pecl.php.net/package/%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 0.7.1
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: BSD-2-Clause
+URL: https://pecl.php.net/package/%{pecl_name}
-# Pull sources from github to get tests
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 5.6
+BuildRequires: make
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
-%if %{with_tests}
+%if %{with tests}
BuildRequires: %{?scl_prefix}php-iconv
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared provides
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
%description
@@ -93,13 +58,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package.xml .
-
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
-cd NTS
-
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_TRANSLIT_VERSION/{s/.* "//;s/".*$//;p}' php_translit.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -108,8 +69,9 @@ if test "x${extver}" != "x%{version}%{?prever}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -122,19 +84,20 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--enable-translit \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--enable-translit \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -157,7 +120,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -188,17 +151,18 @@ fi
%{__php} -n \
$DEPMOD \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- -m | grep %{pecl_name}
+ -m | grep '^%{pecl_name}$'
%if %{with_zts}
: Minimal load test for ZTS extension
%{__ztsphp} -n \
$DEPMOD \
-d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- -m | grep %{pecl_name}
+ -m | grep '^%{pecl_name}$'
%endif
-%if %{with_tests}
+%if %{with tests}
+cd %{sources}
%if "%{php_version}" > "7.4"
TEST_OPTS="-q %{?_smp_mflags} --show-diff"
%else
@@ -206,15 +170,13 @@ TEST_OPTS="-q --show-diff"
%endif
: Upstream test suite NTS extension
-cd NTS
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php $TEST_OPTS
+%{__php} -n run-tests.php $TEST_OPTS
%if %{with_zts}
: Upstream test suite NTS extension
-cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
@@ -226,7 +188,7 @@ REPORT_EXIT_STATUS=1 \
%files
%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -239,6 +201,25 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 0.7.1-2
+- build out of sources tree
+
+* Thu Oct 1 2020 Remi Collet <remi@remirepo.net> - 0.7.1-1
+- update to 0.7.1
+- drop patch merged upstream
+
+* Mon Feb 24 2020 Remi Collet <remi@remirepo.net> - 0.7.0-5
+- add patch for PHP 8 from
+ https://github.com/derickr/pecl-translit/pull/8
+
+* Mon Feb 24 2020 Remi Collet <remi@remirepo.net> - 0.7.0-4
+- update to 0.7.0
+- raise dependency on PHP 7.0
+- sources from PECL
+
+* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.6.3-4
+- rebuild for 7.4.0RC1
+
* Tue Jul 23 2019 Remi Collet <remi@remirepo.net> - 0.6.3-3
- rebuild for 7.4.0beta1