summaryrefslogtreecommitdiffstats
path: root/php-pecl-translit.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-04 10:30:11 +0200
committerRemi Collet <remi@php.net>2023-09-04 10:30:11 +0200
commit7b02a07d7c64b9b31a21854c92b5830ee2117ea4 (patch)
tree176b1c4e570dd5fdc607ac85b94266fdd2dbf5ad /php-pecl-translit.spec
parent3aa2c07531eda13a4de476a01ecffa3a5d52aa68 (diff)
build out of sources treeHEADmaster
Diffstat (limited to 'php-pecl-translit.spec')
-rw-r--r--php-pecl-translit.spec84
1 files changed, 32 insertions, 52 deletions
diff --git a/php-pecl-translit.spec b/php-pecl-translit.spec
index 965e4ca..f06ba35 100644
--- a/php-pecl-translit.spec
+++ b/php-pecl-translit.spec
@@ -1,69 +1,47 @@
# remirepo spec file for php-pecl-translit
#
-# Copyright (c) 2015-2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-translit
-%endif
+
+%{?scl:%scl_package php-pecl-translit}
+
+%bcond_without tests
%global pecl_name translit
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global with_tests 0%{!?_without_tests:1}
# After 20-iconv
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Transliterates non-latin character sets to latin
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.7.1
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: BSD
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: BSD-2-Clause
URL: https://pecl.php.net/package/%{pecl_name}
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: %{?dtsprefix}gcc
+BuildRequires: make
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
-%if %{with_tests}
+%if %{with tests}
BuildRequires: %{?scl_prefix}php-iconv
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared provides
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
%description
@@ -80,11 +58,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-mv %{pecl_name}-%{version} NTS
-
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
-cd NTS
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_TRANSLIT_VERSION/{s/.* "//;s/".*$//;p}' php_translit.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -93,8 +69,9 @@ if test "x${extver}" != "x%{version}%{?prever}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -107,19 +84,20 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--enable-translit \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--enable-translit \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -142,7 +120,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -183,7 +161,8 @@ fi
-m | grep '^%{pecl_name}$'
%endif
-%if %{with_tests}
+%if %{with tests}
+cd %{sources}
%if "%{php_version}" > "7.4"
TEST_OPTS="-q %{?_smp_mflags} --show-diff"
%else
@@ -191,15 +170,13 @@ TEST_OPTS="-q --show-diff"
%endif
: Upstream test suite NTS extension
-cd NTS
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php $TEST_OPTS
+%{__php} -n run-tests.php $TEST_OPTS
%if %{with_zts}
: Upstream test suite NTS extension
-cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n $DEPMOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
@@ -211,7 +188,7 @@ REPORT_EXIT_STATUS=1 \
%files
%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -224,6 +201,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Sep 4 2023 Remi Collet <remi@remirepo.net> - 0.7.1-2
+- build out of sources tree
+
* Thu Oct 1 2020 Remi Collet <remi@remirepo.net> - 0.7.1-1
- update to 0.7.1
- drop patch merged upstream