summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-24 13:21:05 +0100
committerRemi Collet <remi@remirepo.net>2020-02-24 13:21:05 +0100
commit69d52c663edf6ede1c6bf510219efc63d92440a7 (patch)
tree0e2949ece06f3a0ab5f9cc15f780c4454485a13f
parent9565fd90e5f8e7bf4c77ede435f58a4ca4716fd1 (diff)
update to 0.7.0
raise dependency on PHP 7.0 sources from PECL
-rw-r--r--LICENSE23
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-translit.spec28
4 files changed, 13 insertions, 42 deletions
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index bef7949..0000000
--- a/LICENSE
+++ /dev/null
@@ -1,23 +0,0 @@
-Copyright (c) 2004-2015, Derick Rethans
-
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
- - Redistributions of source code must retain the above copyright notice, this
- list of conditions and the following disclaimer.
- - Redistributions in binary form must reproduce the above copyright notice,
- this list of conditions and the following disclaimer in the documentation
- and/or other materials provided with the distribution.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PHPINFO b/PHPINFO
index 3af6ae2..533addc 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
translit
Transliteration support => enabled
-Version => 0.6.3
+Version => 0.7.0
diff --git a/REFLECTION b/REFLECTION
index 1346434..cfcc86d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #164 translit version 0.6.3 ] {
+Extension [ <persistent> extension #111 translit version 0.7.0 ] {
- Functions {
Function [ <internal:translit> function transliterate ] {
diff --git a/php-pecl-translit.spec b/php-pecl-translit.spec
index df28435..f8a1995 100644
--- a/php-pecl-translit.spec
+++ b/php-pecl-translit.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-translit
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,27 +13,21 @@
%global pecl_name translit
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-# see https://github.com/derickr/pecl-translit/releases
-%global gh_commit f2e23d91068047a3d08a8e8d999aca13013ff9cc
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner derickr
-%global gh_project pecl-translit
%global with_tests 0%{!?_without_tests:1}
# After 20-iconv
%global ini_name 40-%{pecl_name}.ini
Summary: Transliterates non-latin character sets to latin
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.6.3
+Version: 0.7.0
Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
-URL: http://pecl.php.net/package/%{pecl_name}
+URL: https://pecl.php.net/package/%{pecl_name}
-# Pull sources from github to get tests
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 5.6
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
%if %{with_tests}
BuildRequires: %{?scl_prefix}php-iconv
@@ -54,10 +48,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{releas
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
@@ -93,8 +83,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package.xml .
+mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
@@ -239,6 +228,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Feb 24 2020 Remi Collet <remi@remirepo.net> - 0.7.0-1
+- update to 0.7.0
+- raise dependency on PHP 7.0
+- sources from PECL
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.6.3-4
- rebuild for 7.4.0RC1