summaryrefslogtreecommitdiffstats
path: root/php-pecl-timecop.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-15 09:12:19 +0100
committerRemi Collet <remi@remirepo.net>2019-12-15 09:12:19 +0100
commit4cf7c27103cdd62893b3bf78065ad1819cf331ad (patch)
treeab21e8ccb15a26507768c7d1094b6be2fce8294b /php-pecl-timecop.spec
parent72eec8064d05740635548e1fa3e15e0206b2e564 (diff)
- add upstream patches for 7.3 and 7.4HEADmaster
- disable ZTS for now
Diffstat (limited to 'php-pecl-timecop.spec')
-rw-r--r--php-pecl-timecop.spec46
1 files changed, 26 insertions, 20 deletions
diff --git a/php-pecl-timecop.spec b/php-pecl-timecop.spec
index 52931f8..280b6fd 100644
--- a/php-pecl-timecop.spec
+++ b/php-pecl-timecop.spec
@@ -12,7 +12,9 @@
%endif
%global pecl_name timecop
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+# Disable ZTS for now
+# PR 45 seems needed, but raise segfaults
+%global with_zts 0
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -23,7 +25,7 @@
Summary: Time travel and freezing extension
Name: %{?sub_prefix}php-pecl-timecop
Version: 1.2.10
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -32,6 +34,12 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Patch0: https://patch-diff.githubusercontent.com/raw/hnw/php-timecop/pull/44.patch
# https://github.com/hnw/php-timecop/pull/45 for ZTS
Patch1: https://patch-diff.githubusercontent.com/raw/hnw/php-timecop/pull/45.patch
+# Upstream patches
+Patch2: https://github.com/hnw/php-timecop/commit/70fe4e091eadb40a57b90c0d6345b7722b6817db.patch
+Patch3: https://github.com/hnw/php-timecop/commit/06897991d042115185fd98ff4e79569fbe51e0bf.patch
+Patch4: https://github.com/hnw/php-timecop/commit/7e8816a4be83c43f3a0b373fe3d619dff5bc5fd8.patch
+Patch5: https://github.com/hnw/php-timecop/commit/ab34c77a5a9c8611d1fc87601fcd72c9defb809d.patch
+Patch6: https://github.com/hnw/php-timecop/commit/61748491a773a7f47694e2fd97dc2c3c61ce9f18.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -53,18 +61,18 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -91,8 +99,13 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr44
-%patch1 -p1 -b .pr45
+#patch0 -p1 -b .pr44
+#patch1 -p1 -b .pr45
+%patch2 -p1 -b .up1
+%patch3 -p1 -b .up2
+%patch4 -p1 -b .up3
+%patch5 -p1 -b .up4
+%patch6 -p1 -b .up5
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_TIMECOP_VERSION/{s/.* "//;s/".*$//;p}' php_timecop.h)
@@ -173,17 +186,6 @@ fi
--modules | grep %{pecl_name}
%if %{with_tests}
-%if "%{php_version}" > "7.3"
-rm ?TS/tests/date_007.phpt
-rm ?TS/tests/date_008.phpt
-rm ?TS/tests/date_override_007.phpt
-rm ?TS/tests/date_override_008.phpt
-rm ?TS/tests/immutable_007.phpt
-rm ?TS/tests/immutable_008.phpt
-rm ?TS/tests/immutable_override_007.phpt
-rm ?TS/tests/immutable_override_008.phpt
-%endif
-
cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
@@ -246,6 +248,10 @@ fi
%changelog
+* Sun Dec 15 2019 Remi Collet <remi@remirepo.net> - 1.2.10-9
+- add upstream patches for 7.3 and 7.4
+- disable ZTS for now
+
* Thu Feb 28 2019 Remi Collet <remi@remirepo.net> - 1.2.10-5
- fix strict_types support, patch from
https://github.com/hnw/php-timecop/pull/44