summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-07 15:43:10 +0200
committerRemi Collet <remi@remirepo.net>2017-07-07 15:43:10 +0200
commitb81724946b80a74a1708372fb03c3a059b2781ac (patch)
tree9ad072d3f4955358269f7b739b1f29d513571b93
parentb2d84b66c7a216552878d563fcc297923011c7c0 (diff)
v1.2.8
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-timecop.spec11
-rw-r--r--tests-skipcheck.inc.php29
3 files changed, 5 insertions, 37 deletions
diff --git a/REFLECTION b/REFLECTION
index 0f47284..81b2d01 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #142 timecop version 1.2.7 ] {
+Extension [ <persistent> extension #142 timecop version 1.2.8 ] {
- INI {
Entry [ timecop.func_override <SYSTEM> ]
diff --git a/php-pecl-timecop.spec b/php-pecl-timecop.spec
index a358119..ca3d070 100644
--- a/php-pecl-timecop.spec
+++ b/php-pecl-timecop.spec
@@ -22,14 +22,12 @@
Summary: Time travel and freezing extension
Name: %{?sub_prefix}php-pecl-timecop
-Version: 1.2.7
+Version: 1.2.8
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/hnw/php-timecop/pull/22
-Source1: https://raw.githubusercontent.com/hnw/php-timecop/master/tests-skipcheck.inc.php
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -87,15 +85,11 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Don't install/register tests
-# see https://github.com/hnw/php-timecop/pull/21
sed -e 's/role="test"/role="src"/' \
- -e '/README/s/role="src"/role="doc"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- %{!?_licensedir:-e '/LICENSE/s/role="src"/role="doc"/' } \
-i package.xml
cd NTS
-cp %{SOURCE1} .
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_TIMECOP_VERSION/{s/.* "//;s/".*$//;p}' php_timecop.h)
@@ -238,6 +232,9 @@ fi
%changelog
+* Fri Jul 7 2017 Remi Collet <remi@remirepo.net> - 1.2.8-1
+- Update to 1.2.8 (no change)
+
* Fri Jul 7 2017 Remi Collet <remi@remirepo.net> - 1.2.7-1
- rename to php-pecl-timecop
- use sources from pecl
diff --git a/tests-skipcheck.inc.php b/tests-skipcheck.inc.php
deleted file mode 100644
index 0d494a9..0000000
--- a/tests-skipcheck.inc.php
+++ /dev/null
@@ -1,29 +0,0 @@
-<?php
-extension_loaded('timecop') or die('skip timecop module not available');
-if (isset($required_version)) {
- if (version_compare(PHP_VERSION, $required_version, "<")) {
- die("skip PHP ${required_version}+ required for this test");
- }
-}
-if (isset($required_func)) {
- foreach ($required_func as $func_name) {
- if (!function_exists($func_name)) {
- die("skip $func_name() function is not available.");
- }
- }
-}
-if (isset($required_class)) {
- foreach ($required_class as $class_name) {
- if (!class_exists($class_name)) {
- die("skip $class_name class is not available.");
- }
- }
-}
-if (isset($required_method)) {
- foreach ($required_method as $v) {
- list($class_name, $method_name) = $v;
- if (!method_exists($class_name, $method_name)) {
- die("skip $class_name::$method_name() method is not available.");
- }
- }
-}