summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-04 07:34:15 +0200
committerRemi Collet <remi@remirepo.net>2017-07-04 07:34:15 +0200
commita2c506f51ace035b28c01bc80b15785fe4b054a3 (patch)
tree34aaafc64d544b2862e95dc0f66a20e09951f61a
new package
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--REFLECTION944
-rw-r--r--php-timecop.spec194
4 files changed, 1149 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..76380b4
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,944 @@
+Extension [ <persistent> extension #142 timecop version 1.2.6 ] {
+
+ - INI {
+ Entry [ timecop.func_override <SYSTEM> ]
+ Current = '1'
+ }
+ Entry [ timecop.sync_request_time <SYSTEM> ]
+ Current = '1'
+ }
+ }
+
+ - Functions {
+ Function [ <internal:timecop> function timecop_strtotime ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $time ]
+ Parameter #1 [ <optional> $now ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_idate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_gmdate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_mktime ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <optional> $hour ]
+ Parameter #1 [ <optional> $min ]
+ Parameter #2 [ <optional> $sec ]
+ Parameter #3 [ <optional> $mon ]
+ Parameter #4 [ <optional> $day ]
+ Parameter #5 [ <optional> $year ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_gmmktime ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <optional> $hour ]
+ Parameter #1 [ <optional> $min ]
+ Parameter #2 [ <optional> $sec ]
+ Parameter #3 [ <optional> $mon ]
+ Parameter #4 [ <optional> $day ]
+ Parameter #5 [ <optional> $year ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_strftime ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_gmstrftime ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_time ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:timecop> function timecop_localtime ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $timestamp ]
+ Parameter #1 [ <optional> $associative_array ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_getdate ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date_create ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $time ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date_create_immutable ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $time ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date_create_from_format ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <required> $time ]
+ Parameter #2 [ <optional> $object ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date_create_immutable_from_format ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <required> $time ]
+ Parameter #2 [ <optional> $object ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_microtime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $get_as_float ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_gettimeofday ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $get_as_float ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_unixtojd ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_freeze ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_travel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_scale ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $scale ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_return ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:timecop> function timecop_time ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:timecop> function timecop_mktime ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <optional> $hour ]
+ Parameter #1 [ <optional> $min ]
+ Parameter #2 [ <optional> $sec ]
+ Parameter #3 [ <optional> $mon ]
+ Parameter #4 [ <optional> $day ]
+ Parameter #5 [ <optional> $year ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_gmmktime ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <optional> $hour ]
+ Parameter #1 [ <optional> $min ]
+ Parameter #2 [ <optional> $sec ]
+ Parameter #3 [ <optional> $mon ]
+ Parameter #4 [ <optional> $day ]
+ Parameter #5 [ <optional> $year ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_gmdate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_idate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_getdate ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_localtime ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $timestamp ]
+ Parameter #1 [ <optional> $associative_array ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_strtotime ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $time ]
+ Parameter #1 [ <optional> $now ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_strftime ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_gmstrftime ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_microtime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $get_as_float ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_gettimeofday ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $get_as_float ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_unixtojd ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timestamp ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date_create ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $time ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date_create_from_format ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <required> $time ]
+ Parameter #2 [ <optional> $object ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date_create_immutable ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $time ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+ Function [ <internal:timecop> function timecop_date_create_immutable_from_format ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <required> $time ]
+ Parameter #2 [ <optional> $object ]
+ }
+ }
+ }
+
+ - Classes [5] {
+ Class [ <internal:timecop> class Timecop ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:timecop> static public method freeze ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timestamp ]
+ }
+ }
+
+ Method [ <internal:timecop> static public method travel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timestamp ]
+ }
+ }
+
+ Method [ <internal:timecop> static public method scale ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $scale ]
+ }
+ }
+
+ Method [ <internal:timecop> static public method return ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:timecop> class TimecopDateTime extends DateTime implements DateTimeInterface ] {
+
+ - Constants [13] {
+ Constant [ string ATOM ] { Y-m-d\TH:i:sP }
+ Constant [ string COOKIE ] { l, d-M-Y H:i:s T }
+ Constant [ string ISO8601 ] { Y-m-d\TH:i:sO }
+ Constant [ string RFC822 ] { D, d M y H:i:s O }
+ Constant [ string RFC850 ] { l, d-M-y H:i:s T }
+ Constant [ string RFC1036 ] { D, d M y H:i:s O }
+ Constant [ string RFC1123 ] { D, d M Y H:i:s O }
+ Constant [ string RFC7231 ] { D, d M Y H:i:s \G\M\T }
+ Constant [ string RFC2822 ] { D, d M Y H:i:s O }
+ Constant [ string RFC3339 ] { Y-m-d\TH:i:sP }
+ Constant [ string RFC3339_EXTENDED ] { Y-m-d\TH:i:s.vP }
+ Constant [ string RSS ] { D, d M Y H:i:s O }
+ Constant [ string W3C ] { Y-m-d\TH:i:sP }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [3] {
+ Method [ <internal:timecop, prototype DateTimeImmutable> static public method createFromFormat ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <required> $time ]
+ Parameter #2 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> static public method __set_state ] {
+ }
+
+ Method [ <internal:date, inherits DateTime> static public method getLastErrors ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [15] {
+ Method [ <internal:timecop, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $time ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method __wakeup ] {
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method format ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $format ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method modify ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $modify ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method sub ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method getTimezone ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setTimezone ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timezone ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method getOffset ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setTime ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $hour ]
+ Parameter #1 [ <required> $minute ]
+ Parameter #2 [ <optional> $second ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setDate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $year ]
+ Parameter #1 [ <required> $month ]
+ Parameter #2 [ <required> $day ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setISODate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $year ]
+ Parameter #1 [ <required> $week ]
+ Parameter #2 [ <optional> $day ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setTimestamp ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $unixtimestamp ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method diff ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $object ]
+ Parameter #1 [ <optional> $absolute ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:timecop> class TimecopOrigDateTime extends DateTime implements DateTimeInterface ] {
+
+ - Constants [13] {
+ Constant [ string ATOM ] { Y-m-d\TH:i:sP }
+ Constant [ string COOKIE ] { l, d-M-Y H:i:s T }
+ Constant [ string ISO8601 ] { Y-m-d\TH:i:sO }
+ Constant [ string RFC822 ] { D, d M y H:i:s O }
+ Constant [ string RFC850 ] { l, d-M-y H:i:s T }
+ Constant [ string RFC1036 ] { D, d M y H:i:s O }
+ Constant [ string RFC1123 ] { D, d M Y H:i:s O }
+ Constant [ string RFC7231 ] { D, d M Y H:i:s \G\M\T }
+ Constant [ string RFC2822 ] { D, d M Y H:i:s O }
+ Constant [ string RFC3339 ] { Y-m-d\TH:i:sP }
+ Constant [ string RFC3339_EXTENDED ] { Y-m-d\TH:i:s.vP }
+ Constant [ string RSS ] { D, d M Y H:i:s O }
+ Constant [ string W3C ] { Y-m-d\TH:i:sP }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [3] {
+ Method [ <internal:date, inherits DateTime> static public method __set_state ] {
+ }
+
+ Method [ <internal:date, inherits DateTime> static public method createFromFormat ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <required> $time ]
+ Parameter #2 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> static public method getLastErrors ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [15] {
+ Method [ <internal:timecop, overwrites TimecopDateTime, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $time ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method __wakeup ] {
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method format ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $format ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method modify ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $modify ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method sub ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method getTimezone ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setTimezone ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timezone ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method getOffset ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setTime ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $hour ]
+ Parameter #1 [ <required> $minute ]
+ Parameter #2 [ <optional> $second ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setDate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $year ]
+ Parameter #1 [ <required> $month ]
+ Parameter #2 [ <required> $day ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setISODate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $year ]
+ Parameter #1 [ <required> $week ]
+ Parameter #2 [ <optional> $day ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime> public method setTimestamp ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $unixtimestamp ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTime, prototype DateTimeInterface> public method diff ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $object ]
+ Parameter #1 [ <optional> $absolute ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:timecop> class TimecopDateTimeImmutable extends DateTimeImmutable implements DateTimeInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:timecop> static public method createFromFormat ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <required> $time ]
+ Parameter #2 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> static public method __set_state ] {
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> static public method getLastErrors ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> static public method createFromMutable ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $DateTime ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [15] {
+ Method [ <internal:timecop, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $time ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method __wakeup ] {
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method format ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $format ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method getTimezone ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method getOffset ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method diff ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $object ]
+ Parameter #1 [ <optional> $absolute ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method modify ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $modify ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method sub ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setTimezone ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timezone ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setTime ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $hour ]
+ Parameter #1 [ <required> $minute ]
+ Parameter #2 [ <optional> $second ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setDate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $year ]
+ Parameter #1 [ <required> $month ]
+ Parameter #2 [ <required> $day ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setISODate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $year ]
+ Parameter #1 [ <required> $week ]
+ Parameter #2 [ <optional> $day ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setTimestamp ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $unixtimestamp ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:timecop> class TimecopOrigDateTimeImmutable extends DateTimeImmutable implements DateTimeInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:date, inherits DateTimeImmutable> static public method __set_state ] {
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> static public method createFromFormat ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $format ]
+ Parameter #1 [ <required> $time ]
+ Parameter #2 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> static public method getLastErrors ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> static public method createFromMutable ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $DateTime ]
+ }
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [15] {
+ Method [ <internal:timecop, overwrites TimecopDateTimeImmutable, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $time ]
+ Parameter #1 [ <optional> $object ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method __wakeup ] {
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method format ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $format ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method getTimezone ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method getOffset ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable, prototype DateTimeInterface> public method diff ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $object ]
+ Parameter #1 [ <optional> $absolute ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method modify ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $modify ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method sub ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setTimezone ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timezone ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setTime ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $hour ]
+ Parameter #1 [ <required> $minute ]
+ Parameter #2 [ <optional> $second ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setDate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $year ]
+ Parameter #1 [ <required> $month ]
+ Parameter #2 [ <required> $day ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setISODate ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $year ]
+ Parameter #1 [ <required> $week ]
+ Parameter #2 [ <optional> $day ]
+ }
+ }
+
+ Method [ <internal:date, inherits DateTimeImmutable> public method setTimestamp ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $unixtimestamp ]
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-timecop.spec b/php-timecop.spec
new file mode 100644
index 0000000..0478297
--- /dev/null
+++ b/php-timecop.spec
@@ -0,0 +1,194 @@
+# remirepo spec file for php-timecop
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-timecop
+%endif
+
+%global gh_commit 0a0f0a1db2796a6d1dd003dab8f70401a2e9ec2a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner hnw
+%global gh_project php-timecop
+#global gh_date 20160608
+%global pecl_name timecop
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: Time travel and freezing extension
+Name: %{?sub_prefix}php-timecop
+Version: 1.2.6
+%if 0%{?gh_date:1}
+Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%else
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%endif
+License: MIT
+Group: Development/Languages
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildRequires: %{?scl_prefix}php-devel
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-%{pecl_name} <= %{version}
+Obsoletes: php56w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-%{pecl_name} <= %{version}
+Obsoletes: php70w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-%{pecl_name} <= %{version}
+Obsoletes: php71w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-%{pecl_name} <= %{version}
+Obsoletes: php72w-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+A PHP extension providing "time travel" and "time freezing" capabilities,
+inspired by ruby timecop gem.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+
+cd NTS
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_TIMECOP_VERSION/{s/.* "//;s/".*$//;p}' php_timecop.h)
+if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Drop in the bit of configuration
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' module
+extension = %{pecl_name}.so
+
+; Configuration
+;timecop.func_override = 1
+:timecop.sync_request_time = 1
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config \
+ --with-libdir=%{_lib} \
+ --enable-timecop
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config \
+ --with-libdir=%{_lib} \
+ --enable-timecop
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+# Install the ZTS stuff
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff || : ignore
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license NTS/LICENSE
+%doc NTS/CREDITS
+%doc NTS/README.md
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Jul 4 2017 Remi Collet <remi@remirepo.net> - 1.2.6-1
+- new package, version 1.2.6 (beta)